summaryrefslogtreecommitdiffstats
path: root/php-channel-guzzle.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-19 07:15:46 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-19 07:15:46 +0100
commited9e91fa847f09b520bffd7a77c0b38c94963eba (patch)
tree2c663202e96df2a0a4655eb844eb47d7e3dc1c44 /php-channel-guzzle.spec
php-channel-guzzle: import from rawhide
Diffstat (limited to 'php-channel-guzzle.spec')
-rw-r--r--php-channel-guzzle.spec62
1 files changed, 62 insertions, 0 deletions
diff --git a/php-channel-guzzle.spec b/php-channel-guzzle.spec
new file mode 100644
index 0000000..9df4505
--- /dev/null
+++ b/php-channel-guzzle.spec
@@ -0,0 +1,62 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+
+%global pear_channel guzzlephp.org/pear
+
+Name: php-channel-guzzle
+Version: 1.3
+Release: 1%{?dist}
+Summary: Adds %{pear_channel} channel to PEAR
+
+Group: Development/Libraries
+License: Public Domain
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/channel.xml
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-channel(%{pear_channel})
+
+%description
+This package adds the %{pear_channel} channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{SOURCE0} %{buildroot}%{pear_xmldir}/%{name}.xml
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null || :
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{pear_channel} > /dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+
+
+%changelog
+* Sat Dec 8 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.3-1
+- Initial package (version matches channel REST version)