summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-09 10:59:54 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-09 10:59:54 +0100
commit652c12d773961abf1b2a31782a881c25c3ccac76 (patch)
treec195ad19c5dfbf75f337cd962cd2e5d11c28f9a0
php-channel-dropbox-php: import from rawhide
-rw-r--r--Makefile4
-rw-r--r--channel.xml16
-rw-r--r--php-channel-dropbox-php.spec64
3 files changed, 84 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 0000000..8c77e08
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.dropbox-php.com</name>
+ <summary>Dropbox-PHP PEAR channel</summary>
+ <suggestedalias>dropbox-php</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.dropbox-php.com/rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.dropbox-php.com/rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.dropbox-php.com/rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.dropbox-php.com/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/php-channel-dropbox-php.spec b/php-channel-dropbox-php.spec
new file mode 100644
index 0000000..321759d
--- /dev/null
+++ b/php-channel-dropbox-php.spec
@@ -0,0 +1,64 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global channelname pear.dropbox-php.com
+
+Name: php-channel-dropbox-php
+Version: 1.3
+Release: 3%{?dist}
+Summary: Adds the Dropbox-PHP channel to PEAR
+
+License: Public Domain
+URL: http://www.dropbox-php.com/
+Source0: http://%{channelname}/channel.xml
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Provides: php-channel(%{channelname})
+
+%description
+This package adds the Dropbox-PHP channel which allows PEAR packages
+from this channel to be installed.
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/%{name}.xml
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null ||:
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{channelname} > /dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+
+
+
+%changelog
+* Thu Feb 28 2013 Gregor Tätzner <brummbq@fedoraproject.org> - 1.3-3
+- channelname: pear.dropbox-php.com
+
+* Wed Feb 27 2013 Gregor Tätzner <brummbq@fedoraproject.org> - 1.3-2
+- install channel.xml as %%{name}
+
+* Tue Feb 19 2013 Gregor Tätzner <brummbq@fedoraproject.org> - 1.3-1
+- Initial package \ No newline at end of file