summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:07:08 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:07:08 +0200
commit99df7bb4625e1ad12eb4671e5153b68169443796 (patch)
treebe612664017189648dc049d34827c06652bb979a
repo reorgHEADmaster
-rw-r--r--Makefile4
-rw-r--r--channel.xml16
-rw-r--r--php-channel-digitalsandwich.spec76
3 files changed, 96 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 0000000..3b98f6d
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.digitalsandwich.com</name>
+ <summary>Digital Sandwich PEAR channel</summary>
+ <suggestedalias>digitalsandwich</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.digitalsandwich.com//rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.digitalsandwich.com//rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.digitalsandwich.com//rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.digitalsandwich.com//rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/php-channel-digitalsandwich.spec b/php-channel-digitalsandwich.spec
new file mode 100644
index 0000000..93b2ba4
--- /dev/null
+++ b/php-channel-digitalsandwich.spec
@@ -0,0 +1,76 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+
+Name: php-channel-digitalsandwich
+# Use REST version (from channel.xml)
+Version: 1.3
+Release: 2%{?dist}
+Summary: Adds digitalsandwich channel to PEAR
+
+Group: Development/Languages
+License: Public Domain
+URL: http://digitalsandwich.com/
+Source0: http://pear.digitalsandwich.com/channel.xml
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch: noarch
+BuildRequires: php-pear >= 1:1.4.9-1.2
+Requires: php-pear(PEAR)
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-channel(pear.digitalsandwich.com)
+
+%description
+This package adds the digitalsandwich channel which allows
+PEAR packages from this channel to be installed.
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/pear.digitalsandwich.com.xml
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/pear.digitalsandwich.com.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/pear.digitalsandwich.com.xml > /dev/null ||:
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete pear.digitalsandwich.com > /dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/*
+
+
+%changelog
+* Wed May 23 2012 Remi Collet <RPMS@FamilleCollet.com> 1.3-2
+- rebuild for remi repository
+
+* Mon May 21 2012 Christof Damian <christof@damian.net> - 1.3-2
+- fixes for review:
+- remove php-cli from requires
+- change license to Public Domain
+- clean unneeded macros (rm, install, mkdir)
+
+* Wed May 2 2012 Christof Damian <christof@damian.net> - 1.3-1
+- initial release
+