summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:07:08 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:07:08 +0200
commitb524c5fe2c9ffb8dd1aa313a405c9c9bd031ade8 (patch)
treeb74456b30e45feaf2ba816c08285dfe91891ce9b
repo reorgHEADmaster
-rw-r--r--Makefile4
-rw-r--r--channel.xml16
-rw-r--r--php-channel-bartlett.spec70
3 files changed, 90 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 0000000..67a6aca
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>bartlett.laurent-laville.org</name>
+ <summary>Bartlett PEAR Channel</summary>
+ <suggestedalias>bartlett</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://bartlett.laurent-laville.org/rest/</baseurl>
+ <baseurl type="REST1.1">http://bartlett.laurent-laville.org/rest/</baseurl>
+ <baseurl type="REST1.2">http://bartlett.laurent-laville.org/rest/</baseurl>
+ <baseurl type="REST1.3">http://bartlett.laurent-laville.org/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/php-channel-bartlett.spec b/php-channel-bartlett.spec
new file mode 100644
index 0000000..f74333b
--- /dev/null
+++ b/php-channel-bartlett.spec
@@ -0,0 +1,70 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+
+%global channel bartlett.laurent-laville.org
+
+Name: php-channel-bartlett
+# Use REST version
+Version: 1.3
+Release: 1%{?dist}
+Summary: Adds bartlett channel to PEAR
+
+Group: Development/Languages
+License: BSD
+URL: http://%{channel}/
+Source0: http://%{channel}/channel.xml
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear >= 1:1.4.9-1.2
+
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Provides: php-channel(%{channel})
+
+%description
+This package adds the bartlett channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/%{name}.xml
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null ||:
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{channel} > /dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/%{name}.xml
+
+
+%changelog
+* Wed Feb 25 2011 Remi Collet <Fedora@FamilleCollet.com> - 1.3-1
+- Initial Release
+