summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-07 09:49:17 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-07 09:49:17 +0100
commit724b021acf873a19a4828fa98541a6671a3cff29 (patch)
tree3cafb2f5fe17943ccf7a951e819921461fefc678
php-channel-aws: import from rawhide
-rw-r--r--Makefile4
-rw-r--r--channel.xml16
-rw-r--r--php-channel-aws.spec65
3 files changed, 85 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 0000000..82a6ef2
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.amazonwebservices.com</name>
+ <summary>Amazon Web Services PEAR Channel</summary>
+ <suggestedalias>aws</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.amazonwebservices.com/rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.amazonwebservices.com/rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.amazonwebservices.com/rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.amazonwebservices.com/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/php-channel-aws.spec b/php-channel-aws.spec
new file mode 100644
index 0000000..d9ce597
--- /dev/null
+++ b/php-channel-aws.spec
@@ -0,0 +1,65 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global channelname pear.amazonwebservices.com
+
+Name: php-channel-aws
+Version: 1.3
+Release: 3%{?dist}
+Summary: Adds the Amazon Web Services channel to PEAR
+
+Group: Development/Languages
+License: Public Domain
+URL: http://aws.amazon.com/sdkforphp
+Source0: http://pear.amazonwebservices.com/channel.xml
+
+BuildArch: noarch
+BuildRequires: php-pear >= 1:1.4.9-1.2
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Provides: php-channel(%{channelname})
+
+%description
+This package adds the Amazon Web Services channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/%{channelname}.xml
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{channelname}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{channelname}.xml > /dev/null ||:
+fi
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{channelname} > /dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{channelname}.xml
+
+
+%changelog
+* Mon Dec 17 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.3-3
+- fix mixed use of tabs and spaces
+- eliminate macro in the changelog
+* Thu Nov 13 2012 Joseph Marrero <jmarrero@fedoraproject.org> - 1.3-2
+- set licence to public domain
+- fix channel name in global from http://pear.amazonwebservices.com/ to pear.amazonwebservices.com
+- remove clean section.
+* Tue Sep 11 2012 Felix Kaechele <heffer@fedoraproject.org> - 1.3-1
+- initial package