summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json3
-rw-r--r--php-cakephp4.spec14
2 files changed, 12 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index ef3bd4b..fc8677c 100644
--- a/composer.json
+++ b/composer.json
@@ -31,6 +31,7 @@
"laminas/laminas-diactoros": "^2.2.2",
"laminas/laminas-httphandlerrunner": "^1.1",
"league/container": "^4.1.1",
+ "psr/container": "^2.0",
"psr/http-client": "^1.0",
"psr/http-server-handler": "^1.0",
"psr/http-server-middleware": "^1.0",
@@ -110,7 +111,7 @@
"@psalm"
],
"stan-tests": "phpstan.phar analyze -c tests/phpstan.neon",
- "stan-setup": "cp composer.json composer.backup && composer require --dev symfony/polyfill-php81 phpstan/phpstan:0.12.96 psalm/phar:~4.10.0 && mv composer.backup composer.json",
+ "stan-setup": "cp composer.json composer.backup && composer require --dev symfony/polyfill-php81 phpstan/phpstan:~1.0.0 psalm/phar:~4.11.0 && mv composer.backup composer.json",
"test": "phpunit",
"test-coverage": "phpunit --coverage-clover=clover.xml"
},
diff --git a/php-cakephp4.spec b/php-cakephp4.spec
index aa840d1..b2e1e7e 100644
--- a/php-cakephp4.spec
+++ b/php-cakephp4.spec
@@ -12,7 +12,7 @@
# https://github.com/cakephp/cakephp/releases
-%global gh_commit fc71c2d7e1bda979da41ed1dea726d6e04240d3b
+%global gh_commit 6b1cf0e74bbfbb73ecdb1e8a5d0fd36230930931
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cakephp
%global gh_project cakephp
@@ -28,7 +28,7 @@
%global chronos_version 2.3.0
Name: php-%{pk_vendor}%{major}
-Version: 4.3.0
+Version: 4.3.1
Release: 1%{?dist}
Summary: The CakePHP framework
@@ -961,9 +961,10 @@ ret=0
# testEmailDeep|testConfigContext|testDataAvailable|testAddresses|testHost are online
# testCurrency|testConfig issue with ICU version
# CspMiddlewareTest paragonie/csp-builder not packaged
-# testReplaceLinkBinaryUuid nedd investigation
+# testReplaceLinkBinaryUuid need investigation
+# testRsa* broekn with OpenSSL 3.0
%{_bindir}/phpunit8 tests/TestCase \
- --filter '^((?!(CspMiddlewareTest|testEmailDeep|testConfigContext|testDataAvailable|testAddresses|testHost|testCurrency|testConfig|testReplaceLinkBinaryUuid)).)*$' \
+ --filter '^((?!(CspMiddlewareTest|testEmailDeep|testConfigContext|testDataAvailable|testAddresses|testHost|testCurrency|testConfig|testReplaceLinkBinaryUuid|testRsaSigningWithPassphraseString|testRsaSigningStringWithPassphraseString|testRsaSigningWithPassphraseFile|testRsaSigningStringWithPassphraseFile)).)*$' \
--verbose || ret=1
exit $ret
@@ -1133,6 +1134,11 @@ exit $ret
%changelog
+* Mon Nov 8 2021 Remi Collet <remi@remirepo.net> - 4.3.1-1
+- update to 4.3.1
+- open https://github.com/cakephp/cakephp/issues/16101
+ test failure with OpenSSL 3.0
+
* Mon Oct 25 2021 Remi Collet <remi@remirepo.net> - 4.3.0-1
- update to 4.3.0
- raise dependency on league/container 4.1.1