summaryrefslogtreecommitdiffstats
path: root/php-cakephp4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-02 10:56:37 +0100
committerRemi Collet <remi@remirepo.net>2020-01-02 10:56:37 +0100
commit911472660adb26744556d6f32ee00041e44e3166 (patch)
tree074f8bd9a9011e64481097bc15e6fe43a0960a6d /php-cakephp4.spec
parent4b2747dee4fa2c494d0692c81ff95877c1f8bdf0 (diff)
wip
Diffstat (limited to 'php-cakephp4.spec')
-rw-r--r--php-cakephp4.spec19
1 files changed, 16 insertions, 3 deletions
diff --git a/php-cakephp4.spec b/php-cakephp4.spec
index 3c435d6..b6f406d 100644
--- a/php-cakephp4.spec
+++ b/php-cakephp4.spec
@@ -195,6 +195,14 @@ Summary: CakePHP Framework Core classes
# "cakephp/utility": "^4.0"
Requires: php(language) >= 7.2
Requires: php-composer(%{pk_vendor}/utility) = %{version}
+# not in composer.json
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(psr/http-server-handler) >= 1.0.0 with php-composer(psr/http-server-handler) < 2)
+Requires: (php-composer(psr/http-server-handler) >= 1.0.0 with php-composer(psr/http-server-handler) < 2)
+%else
+BuildRequires: php-psr-http-server-handler >= 1.0.0
+Requires: php-psr-http-server-handler >= 1.0.0
+%endif
# From phpcompatinfo report
Requires: php-reflection
Requires: php-json
@@ -436,8 +444,8 @@ Requires: php-composer(%{pk_vendor}/utility) = %{version}
BuildRequires: (php-composer(psr/http-message) >= 1.0.0 with php-composer(psr/http-message) < 2)
Requires: (php-composer(psr/http-message) >= 1.0.0 with php-composer(psr/http-message) < 2)
%else
-BuildRequires: php-php-psr-http-message >= 1.0.0
-Requires: php-php-psr-http-message >= 1.0.0
+BuildRequires: php-psr-http-message >= 1.0.0
+Requires: php-psr-http-message >= 1.0.0
%endif
# From phpcompatinfo report
Requires: php-reflection
@@ -490,6 +498,7 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
'%{php_home}/Psr/Log/autoload.php',
'%{php_home}/Psr/SimpleCache/autoload.php',
'%{php_home}/Psr/Http/Message/autoload.php',
+ '%{php_home}/Psr/Http/Server/autoload.php',
'%{php_home}/Zend/Diactoros/autoload.php',
'%{php_home}/org/bovigo/vfs/autoload.php',
]);
@@ -551,6 +560,7 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Cake\\Core\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Psr/Http/Server/autoload.php',
dirname(__DIR__) . '/Utility/autoload.php',
__DIR__ . '/functions.php',
]);
@@ -742,7 +752,10 @@ phpunit8 tests/TestCase/Filesystem --verbose || ret=1
phpunit8 tests/TestCase/I18n --verbose || ret=1
phpunit8 tests/TestCase/Log --verbose || ret=1
phpunit8 tests/TestCase/Utility --verbose || ret=1
-phpunit8 tests/TestCase/Validation --verbose || ret=1
+# testEmailDeep is online
+phpunit8 tests/TestCase/Validation \
+ --filter '^((?!(testEmailDeep)).)*$' \
+ --verbose || ret=1
exit $ret
%else
: Test suite disabled