summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-20 08:28:15 +0100
committerRemi Collet <remi@remirepo.net>2021-01-20 08:28:15 +0100
commit69d343290503e115524de3d23889d51ae8187237 (patch)
tree6a1836be7a87d6bc5d4075c58972e3ccafeecc2c
parent0397bd8f09d713eead433669245e8541d21358b1 (diff)
update chronos to 2.1.0
-rw-r--r--composer-chronos.json19
-rw-r--r--php-cakephp4.spec18
2 files changed, 19 insertions, 18 deletions
diff --git a/composer-chronos.json b/composer-chronos.json
index 6677232..a54ca7d 100644
--- a/composer-chronos.json
+++ b/composer-chronos.json
@@ -29,9 +29,8 @@
"php": ">=7.2"
},
"require-dev": {
- "phpunit/phpunit": "^8.0",
- "cakephp/cakephp-codesniffer": "^4.0",
- "phpbench/phpbench": "^1.0@dev"
+ "phpunit/phpunit": "^8.0 || ^9.0",
+ "cakephp/cakephp-codesniffer": "^4.0"
},
"autoload": {
"psr-4": {
@@ -52,11 +51,13 @@
"@cs-check",
"@phpstan"
],
- "test": "phpunit",
- "cs-check": "phpcs",
- "cs-fix": "phpcbf",
- "benchmark": "phpbench run --report=chronos",
- "phpstan": "phpstan analyze -c phpstan.neon src/",
- "phpstan-setup": "cp composer.json composer.backup && composer require --dev phpstan/phpstan:^0.12 && mv composer.backup composer.json"
+ "cs-check": "phpcs --colors --parallel=16 -p src/ tests/",
+ "cs-fix": "phpcbf --colors --parallel=16 -p src/ tests/",
+ "phpstan": "phpstan.phar analyse",
+ "stan": [
+ "@phpstan"
+ ],
+ "stan-setup": "cp composer.json composer.backup && composer require --dev phpstan/phpstan:^0.12.54 && mv composer.backup composer.json",
+ "test": "phpunit"
}
}
diff --git a/php-cakephp4.spec b/php-cakephp4.spec
index c7ebf63..caa2d4d 100644
--- a/php-cakephp4.spec
+++ b/php-cakephp4.spec
@@ -23,13 +23,13 @@
%global major 4
# https://github.com/cakephp/chronos/releases
-%global chronos_commit 30baea51824076719921c6c2d720bfd6b49e6dca
+%global chronos_commit 3f119d1eb8105ed2c43bb72e8fc5c78487620089
%global chronos_short %(c=%{chronos_commit}; echo ${c:0:7})
-%global chronos_version 2.0.6
+%global chronos_version 2.1.0
Name: php-%{pk_vendor}%{major}
Version: 4.2.2
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The CakePHP framework
License: MIT
@@ -952,12 +952,9 @@ sed -e 's:vendor/phpunit/phpunit/src/::' -i \
export LANG=fr_FR.UTF-8
ret=0
: Run chronos test suite
-%{_bindir}/phpunit8 tests2 --verbose || ret=1
-
-# https://github.com/cakephp/cakephp/pull/15229
-sed -e 's/BinaryUuiditems/BinaryUuidItems/' \
- -e 's/BinaryUuidItemsBinaryUuidtags/BinaryUuiditemsBinaryUuidtags/' \
- -i tests/TestCase/ORM/Association/BelongsToManyTest.php
+%{_bindir}/phpunit8 tests2 \
+ --filter '^((?!(testDiffInMonthsIgnoreTimezone)).)*$' \
+ --verbose || ret=1
: Run cakephp test suite
# testEmailDeep|testConfigContext|testDataAvailable|testAddresses|testHost are online
@@ -1135,6 +1132,9 @@ exit $ret
%changelog
+* Wed Jan 20 2021 Remi Collet <remi@remirepo.net> - 4.2.2-2
+- update chronos to 2.1.0
+
* Thu Jan 7 2021 Remi Collet <remi@remirepo.net> - 4.2.2-1
- update to 4.2.2