summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-06 09:13:00 +0200
committerRemi Collet <remi@php.net>2022-07-06 09:13:00 +0200
commit1b435e5c1817b87fa21eb369c3279530825b1381 (patch)
tree5dc7a00eeca62078d2e3722a3a510763af9bfe62
parent373511ff0a026276917ef916e67b7fb270ef7a3b (diff)
update to 4.4.2
-rw-r--r--composer.json2
-rw-r--r--php-cakephp4.spec23
2 files changed, 17 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 29e898c..b8b8a3f 100644
--- a/composer.json
+++ b/composer.json
@@ -29,7 +29,7 @@
"cakephp/chronos": "^2.2",
"composer/ca-bundle": "^1.2",
"laminas/laminas-diactoros": "^2.2.2",
- "laminas/laminas-httphandlerrunner": "^1.1",
+ "laminas/laminas-httphandlerrunner": "^1.1 || ^2.0",
"league/container": "^4.2.0",
"psr/container": "^1.1 || ^2.0",
"psr/http-client": "^1.0",
diff --git a/php-cakephp4.spec b/php-cakephp4.spec
index c59dd74..b67d1c6 100644
--- a/php-cakephp4.spec
+++ b/php-cakephp4.spec
@@ -9,7 +9,7 @@
# https://github.com/cakephp/cakephp/releases
-%global gh_commit 83b46efc5ad4cd9325743a4db4fb97f1fd2587b4
+%global gh_commit 814db4d36f747258fc1790bf6ff2a3ecb936c388
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cakephp
%global gh_project cakephp
@@ -25,7 +25,7 @@
%global chronos_version 2.3.0
Name: php-%{pk_vendor}%{major}
-Version: 4.4.1
+Version: 4.4.2
Release: 1%{?dist}
Summary: The CakePHP framework
@@ -391,7 +391,7 @@ Summary: CakePHP Http Library
# "psr/http-server-handler": "^1.0",
# "psr/http-server-middleware": "^1.0",
# "laminas/laminas-diactoros": "^2.1",
-# "laminas/laminas-httphandlerrunner": "^1.0"
+# "laminas/laminas-httphandlerrunner": "^1.1 || ^2.0"
Requires: php(language) >= 7.4
Requires: php-composer(%{pk_vendor}/core) = %{version}
Requires: php-composer(%{pk_vendor}/event) = %{version}
@@ -407,8 +407,8 @@ BuildRequires: (php-composer(psr/http-server-middleware) >= 1.0 with ph
Requires: (php-composer(psr/http-server-middleware) >= 1.0 with php-composer(psr/http-server-middleware) < 2)
BuildRequires: (php-composer(laminas/laminas-diactoros) >= 2.1 with php-composer(laminas/laminas-diactoros) < 3)
Requires: (php-composer(laminas/laminas-diactoros) >= 2.1 with php-composer(laminas/laminas-diactoros) < 3)
-BuildRequires: (php-composer(laminas/laminas-httphandlerrunner) >= 1.0 with php-composer(laminas/laminas-httphandlerrunner) < 2)
-Requires: (php-composer(laminas/laminas-httphandlerrunner) >= 1.0 with php-composer(laminas/laminas-httphandlerrunner) < 2)
+BuildRequires: (php-composer(laminas/laminas-httphandlerrunner) >= 1.1 with php-composer(laminas/laminas-httphandlerrunner) < 3)
+Requires: (php-composer(laminas/laminas-httphandlerrunner) >= 1.1 with php-composer(laminas/laminas-httphandlerrunner) < 3)
# From composer.json "suggest": {
# "cakephp/cache": "To use cache session storage",
# "cakephp/orm": "To use database session storage"
@@ -632,7 +632,10 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
'%{php_home}/League/Container4/autoload.php',
'%{php_home}/Composer/CaBundle/autoload.php',
'%{php_home}/Laminas/Diactoros2/autoload.php',
- '%{php_home}/Laminas/HttpHandlerRunner/autoload.php',
+ [
+ '%{php_home}/Laminas/HttpHandlerRunner2/autoload.php',
+ '%{php_home}/Laminas/HttpHandlerRunner/autoload.php',
+ ]
]);
EOF
@@ -806,7 +809,10 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
'%{php_home}/Psr/Http/Server/autoload.php',
'%{php_home}/Psr/Http/Server/middleware-autoload.php',
'%{php_home}/Laminas/Diactoros2/autoload.php',
- '%{php_home}/Laminas/HttpHandlerRunner/autoload.php',
+ [
+ '%{php_home}/Laminas/HttpHandlerRunner2/autoload.php',
+ '%{php_home}/Laminas/HttpHandlerRunner/autoload.php',
+ ]
]);
EOF
@@ -1148,6 +1154,9 @@ exit $ret
%changelog
+* Wed Jul 6 2022 Remi Collet <remi@remirepo.net> - 4.4.2-1
+- update to 4.4.2
+
* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 4.4.1-1
- update to 4.4.1