summaryrefslogtreecommitdiffstats
path: root/php-brumann-polyfill-unserialize.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-brumann-polyfill-unserialize.spec')
-rw-r--r--php-brumann-polyfill-unserialize.spec34
1 files changed, 25 insertions, 9 deletions
diff --git a/php-brumann-polyfill-unserialize.spec b/php-brumann-polyfill-unserialize.spec
index 315bf10..ef70875 100644
--- a/php-brumann-polyfill-unserialize.spec
+++ b/php-brumann-polyfill-unserialize.spec
@@ -1,7 +1,8 @@
+# remirepo spec file for php-brumann-polyfill-unserialize, from
#
# Fedora spec file for php-brumann-polyfill-unserialize
#
-# Copyright (c) 2019 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2019-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -11,8 +12,8 @@
%global github_owner dbrumann
%global github_name polyfill-unserialize
-%global github_version 1.0.3
-%global github_commit 844d7e44b62a1a3d5c68cfb7ebbd59c17ea0fd7b
+%global github_version 1.0.4
+%global github_commit 8ed1cd343ddc134a7ef649aca0aa0fe2a1b45008
%global composer_vendor brumann
%global composer_project polyfill-unserialize
@@ -27,12 +28,16 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 4%{?github_release}%{?dist}
Summary: Backports unserialize options introduced in PHP 7.0
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+# GitHub export does not include tests.
+# Run php-brumann-polyfill-unserialize-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
@@ -40,7 +45,7 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo for version 1.0.3
+## phpcompatinfo for version 1.0.4
BuildRequires: php-pcre
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -48,7 +53,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo for version 1.0.3
+# phpcompatinfo for version 1.0.4
Requires: php-pcre
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -109,12 +114,17 @@ require '%{buildroot}%{phpdir}/Brumann/Polyfill/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Tests\\Brumann\\Polyfill\\', __DIR__.'/tests');
BOOTSTRAP
+# SKIP test_with_parent_not_allowed_serialized_class_is_not_accessible: notice promoted to warning
+
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php php70 php71 php72 php73 php74; do
+for PHP_EXEC in php php73 php74 php80; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
+ $PHP_EXEC $PHPUNIT \
+ --bootstrap bootstrap.php \
+ --filter '^((?!(test_with_parent_not_allowed_serialized_class_is_not_accessible)).)*$' \
+ --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -133,5 +143,11 @@ exit $RETURN_CODE
%changelog
+* Tue Apr 6 2021 Remi Collet <remi@remirepo.net> - 1.0.4-4
+- skip 1 test failing with PHP 8
+
+* Sun Apr 05 2020 Shawn Iwinski <shawn@iwin.ski> - 1.0.4-1
+- Update to 1.0.4 (RHBZ #1742087)
+
* Wed May 08 2019 Shawn Iwinski <shawn@iwin.ski> - 1.0.3-1
- Initial package