summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-19 12:03:52 +0200
committerRemi Collet <remi@remirepo.net>2019-06-19 12:03:52 +0200
commit950db6737720f7390d68c8e2844b51a9cf8b5c61 (patch)
tree01848ed189d1c09d3f901810f9259c6c7fe9eaa4
parentbe83d23eb51c7904a911bb38974cc0ae2dfa03d3 (diff)
backport stuff
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json26
-rw-r--r--php-brumann-polyfill-unserialize.spec3
4 files changed, 40 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..ec4a2cf
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,26 @@
+{
+ "name": "brumann/polyfill-unserialize",
+ "description": "Backports unserialize options introduced in PHP 7.0 to older PHP versions.",
+ "type": "library",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Denis Brumann",
+ "email": "denis.brumann@sensiolabs.de"
+ }
+ ],
+ "autoload": {
+ "psr-4": {
+ "Brumann\\Polyfill\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Tests\\Brumann\\Polyfill\\": "tests/"
+ }
+ },
+ "minimum-stability": "stable",
+ "require": {
+ "php": "^5.3|^7.0"
+ }
+}
diff --git a/php-brumann-polyfill-unserialize.spec b/php-brumann-polyfill-unserialize.spec
index 315bf10..e59d84f 100644
--- a/php-brumann-polyfill-unserialize.spec
+++ b/php-brumann-polyfill-unserialize.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-brumann-polyfill-unserialize, from
#
# Fedora spec file for php-brumann-polyfill-unserialize
#
@@ -112,7 +113,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php php70 php71 php72 php73 php74; do
+for PHP_EXEC in php php71 php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi