summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-brick-varexporter.spec77
2 files changed, 42 insertions, 43 deletions
diff --git a/composer.json b/composer.json
index 916985d..5355475 100644
--- a/composer.json
+++ b/composer.json
@@ -7,13 +7,13 @@
],
"license": "MIT",
"require": {
- "php": "^7.2 || ^8.0",
- "nikic/php-parser": "^4.0"
+ "php": "^8.1",
+ "nikic/php-parser": "^5.0"
},
"require-dev": {
- "phpunit/phpunit": "^8.5 || ^9.0",
+ "phpunit/phpunit": "^10.5",
"php-coveralls/php-coveralls": "^2.2",
- "vimeo/psalm": "4.23.0"
+ "vimeo/psalm": "6.8.4"
},
"autoload": {
"psr-4": {
diff --git a/php-brick-varexporter.spec b/php-brick-varexporter.spec
index 4e714ca..deb9b2d 100644
--- a/php-brick-varexporter.spec
+++ b/php-brick-varexporter.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-brick-varexporter
#
-# Copyright (c) 2020-2022 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2020-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 3361a8a30e807c0841a7ca98e5c72b6bffc73463
+%global gh_commit af98bfc2b702a312abbcaff37656dbe419cec5bc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner brick
%global gh_project varexporter
@@ -19,7 +19,7 @@
%global ns_project VarExporter
Name: php-%{pk_vendor}-%{pk_name}
-Version: 0.3.6
+Version: 0.6.0
Release: 1%{?dist}
Summary: A powerful alternative to var_export
@@ -31,43 +31,26 @@ Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 7.2
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(nikic/php-parser) >= 4.0 with php-composer(nikic/php-parser) < 5)
-# remirepo:3
-%else
-BuildRequires: php-nikic-php-parser4
-%endif
+BuildRequires: php(language) >= 8.1
+BuildRequires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
BuildRequires: php-reflection
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^8.5 || ^9.0",
+# "phpunit/phpunit": "^10.5",
# "php-coveralls/php-coveralls": "^2.2",
-# "vimeo/psalm": "4.4.1"
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
-BuildRequires: phpunit9
-%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8 >= 8.5
-%global phpunit %{_bindir}/phpunit8
-%endif
+# "vimeo/psalm": "6.8.4"
+BuildRequires: phpunit10 >= 10.5
+%global phpunit %{_bindir}/phpunit10
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.2 || ^8.0",
-# "nikic/php-parser": "^4.0"
-Requires: php(language) >= 7.2
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(nikic/php-parser) >= 4.0 with php-composer(nikic/php-parser) < 5)
-# remirepo:3
-%else
-Requires: php-nikic-php-parser4
-%endif
+# "php": "^8.1",
+# "nikic/php-parser": "^5.0"
+Requires: php(language) >= 8.1
+Requires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
# From phpcompatifo report for 0.3.2
Requires: php-reflection
Requires: php-pcre
@@ -100,7 +83,7 @@ phpab \
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '/usr/share/php/PhpParser4/autoload.php',
+ '/usr/share/php/PhpParser5/autoload.php',
]);
EOF
@@ -123,20 +106,17 @@ EOF
: Run upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} \
- --no-coverage \
- --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit10} \
+ --no-coverage || ret=1
fi
done
exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
@@ -144,6 +124,25 @@ exit $ret
%changelog
+* Tue Feb 25 2025 Remi Collet <remi@remirepo.net> - 0.6.0-1
+- update to 0.6.0
+- re-license spec file to CECILL-2.1
+- raise dependency on PHP 8.1
+
+* Mon May 13 2024 Remi Collet <remi@remirepo.net> - 0.5.0-1
+- update to 0.5.0
+- raise dependency on nikic/php-parser 5.0
+
+* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 0.4.0-1
+- update to 0.4.0
+- raise dependency on PHP 7.4
+
+* Wed Jan 25 2023 Remi Collet <remi@remirepo.net> - 0.3.8-1
+- update to 0.3.8
+
+* Thu Jun 30 2022 Remi Collet <remi@remirepo.net> - 0.3.7-1
+- update to 0.3.7
+
* Thu Jun 16 2022 Remi Collet <remi@remirepo.net> - 0.3.6-1
- update to 0.3.6