summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json13
-rw-r--r--php-brick-math.spec27
2 files changed, 25 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index ed817bd..bd67343 100644
--- a/composer.json
+++ b/composer.json
@@ -5,21 +5,26 @@
"keywords": [
"Brick",
"Math",
+ "Mathematics",
"Arbitrary-precision",
"Arithmetic",
"BigInteger",
"BigDecimal",
"BigRational",
- "Bignum"
+ "BigNumber",
+ "Bignum",
+ "Decimal",
+ "Rational",
+ "Integer"
],
"license": "MIT",
"require": {
- "php": "^8.0"
+ "php": "^8.1"
},
"require-dev": {
- "phpunit/phpunit": "^9.0",
+ "phpunit/phpunit": "^10.1",
"php-coveralls/php-coveralls": "^2.2",
- "vimeo/psalm": "5.0.0"
+ "vimeo/psalm": "5.16.0"
},
"autoload": {
"psr-4": {
diff --git a/php-brick-math.spec b/php-brick-math.spec
index 77ad788..d7cb178 100644
--- a/php-brick-math.spec
+++ b/php-brick-math.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 0ad82ce168c82ba30d1c01ec86116ab52f589478
+%global gh_commit 21e0a1e6bc7aa5b640ce8d82b2ff5f251c41a952
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner brick
%global gh_project math
@@ -22,7 +22,7 @@
%global ns_project Math
Name: php-%{pk_vendor}-%{pk_name}
-Version: 0.11.0
+Version: 0.12.0
Release: 1%{?dist}
Summary: Arbitrary-precision arithmetic library
@@ -34,25 +34,25 @@ Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.0
+BuildRequires: php(language) >= 8.1
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-bcmath
BuildRequires: php-gmp
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.0",
+# "phpunit/phpunit": "^10.1",
# "php-coveralls/php-coveralls": "^2.2",
-# "vimeo/psalm": "^4.25.0"
+# "vimeo/psalm": "^5.16.0"
%if %{with tests}
-BuildRequires: phpunit9
-%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit10 >= 10.1
+%global phpunit %{_bindir}/phpunit10
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": "^8.0"
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
# From phpcompatifo report for 0.9.1
Requires: php-pcre
Requires: php-spl
@@ -111,11 +111,11 @@ ret=0
# don't test Native with is terribly slow, as bcmath/gmp are set as mandatory
for calc in GMP BCMath; do
export CALCULATOR=$calc
- for cmdarg in "php %{phpunit}" php80 php81 php82; do
+ for cmdarg in "php %{phpunit}" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} \
- --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit10} \
+ --no-coverage || ret=1
fi
done
done
@@ -134,6 +134,11 @@ exit $ret
%changelog
+* Mon Nov 27 2023 Remi Collet <remi@remirepo.net> - 0.12.0-1
+- update to 0.12.0
+- raise dependency on PHP 8.1
+- switch to phpunit10
+
* Wed Apr 19 2023 Remi Collet <remi@remirepo.net> - 0.11.0-1
- update to 0.11.0
- raise dependency on PHP 8.0