summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-20 10:32:44 +0200
committerRemi Collet <remi@php.net>2022-06-20 10:32:44 +0200
commitb0484304ed2b8eaa2843db314f3b01eebbdf599d (patch)
treee645c39b5c466ebb74eb20984c2d9d9ec9e0acfc
parent7c06043b9077a6d7baded8c5b0527bb7891add23 (diff)
update to 0.10.0
raise dependency on PHP 7.4
-rw-r--r--composer.json6
-rw-r--r--php-brick-math.spec21
2 files changed, 13 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index ec19663..17bd9f7 100644
--- a/composer.json
+++ b/composer.json
@@ -14,13 +14,13 @@
],
"license": "MIT",
"require": {
- "php": "^7.1 || ^8.0",
+ "php": "^7.4 || ^8.0",
"ext-json": "*"
},
"require-dev": {
- "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
+ "phpunit/phpunit": "^9.0",
"php-coveralls/php-coveralls": "^2.2",
- "vimeo/psalm": "4.9.2"
+ "vimeo/psalm": "4.23.0"
},
"autoload": {
"psr-4": {
diff --git a/php-brick-math.spec b/php-brick-math.spec
index 338fd7e..33f35dc 100644
--- a/php-brick-math.spec
+++ b/php-brick-math.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit ca57d18f028f84f777b2168cd1911b0dee2343ae
+%global gh_commit 4da12356b27546867630ce14cc6b961827bff64e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner brick
%global gh_project math
@@ -22,7 +22,7 @@
%global ns_project Math
Name: php-%{pk_vendor}-%{pk_name}
-Version: 0.9.3
+Version: 0.10.0
Release: 1%{?dist}
Summary: Arbitrary-precision arithmetic library
@@ -34,30 +34,25 @@ Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.4
BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-bcmath
BuildRequires: php-gmp
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
+# "phpunit/phpunit": "^9.0",
# "php-coveralls/php-coveralls": "^2.2",
# "vimeo/psalm": "^3.5"
%if %{with tests}
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
BuildRequires: phpunit9
%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8 >= 8.5
-%global phpunit %{_bindir}/phpunit8
-%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.1 || ^8.0",
+# "php": "^7.4 || ^8.0",
# "ext-json": "*"
Requires: php(language) >= 7.1
Requires: php-json
@@ -119,7 +114,7 @@ ret=0
# don't test Native with is terribly slow, as bcmath/gmp are set as mandatory
for calc in GMP BCMath; do
export CALCULATOR=$calc
- for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+ for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -142,6 +137,10 @@ exit $ret
%changelog
+* Mon Jun 20 2022 Remi Collet <remi@remirepo.net> - 0.10.0-1
+- update to 0.10.0
+- raise dependency on PHP 7.4
+
* Thu Sep 2 2021 Remi Collet <remi@remirepo.net> - 0.9.3-1
- update to 0.9.3