summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-21 11:21:58 +0100
committerRemi Collet <remi@remirepo.net>2021-01-21 11:21:58 +0100
commit6bc594598b735acc5f9424e2ce88194bca7e0daa (patch)
treea3abaf111dccf698cd74fd9fb5cc58494b92c7bd
parent2268de1284b0438f40b4cfce1e151afeeb2e03dd (diff)
update to 0.9.2
switch to phpunit9
-rw-r--r--composer.json6
-rw-r--r--php-brick-math.spec28
2 files changed, 22 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index d347b6b..c89955d 100644
--- a/composer.json
+++ b/composer.json
@@ -14,13 +14,13 @@
],
"license": "MIT",
"require": {
- "php": "^7.1|^8.0",
+ "php": "^7.1 || ^8.0",
"ext-json": "*"
},
"require-dev": {
- "phpunit/phpunit": "^7.5.15|^8.5",
+ "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
"php-coveralls/php-coveralls": "^2.2",
- "vimeo/psalm": "^3.5"
+ "vimeo/psalm": "4.3.2"
},
"autoload": {
"psr-4": {
diff --git a/php-brick-math.spec b/php-brick-math.spec
index 156f352..4d1953a 100644
--- a/php-brick-math.spec
+++ b/php-brick-math.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 283a40c901101e66de7061bd359252c013dcc43c
+%global gh_commit dff976c2f3487d42c1db75a3b180e2b9f0e72ce0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner brick
%global gh_project math
@@ -22,7 +22,7 @@
%global ns_project Math
Name: php-%{pk_vendor}-%{pk_name}
-Version: 0.9.1
+Version: 0.9.2
Release: 1%{?dist}
Summary: Arbitrary-precision arithmetic library
@@ -41,17 +41,23 @@ BuildRequires: php-spl
BuildRequires: php-bcmath
BuildRequires: php-gmp
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^7.5.15|^8.5",
+# "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
# "php-coveralls/php-coveralls": "^2.2",
# "vimeo/psalm": "^3.5"
%if %{with tests}
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+BuildRequires: phpunit9
+%global phpunit %{_bindir}/phpunit9
+%else
BuildRequires: phpunit8 >= 8.5
+%global phpunit %{_bindir}/phpunit8
+%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.1|^8.0",
+# "php": "^7.1 || ^8.0",
# "ext-json": "*"
Requires: php(language) >= 7.1
Requires: php-json
@@ -113,11 +119,11 @@ ret=0
# don't test Native with is terribly slow, as bcmath/gmp are set as mandatory
for calc in GMP BCMath; do
export CALCULATOR=$calc
- for cmd in php php72 php73 php74 php80; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit8 \
- --no-coverage \
- --verbose || ret=1
+ for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} \
+ --no-coverage --verbose || ret=1
fi
done
done
@@ -136,5 +142,9 @@ exit $ret
%changelog
+* Thu Jan 21 2021 Remi Collet <remi@remirepo.net> - 0.9.2-1
+- update to 0.9.2
+- switch to phpunit9
+
* Thu Oct 1 2020 Remi Collet <remi@remirepo.net> - 0.9.1-1
- initial package