summaryrefslogtreecommitdiffstats
path: root/php-bjeavons-zxcvbn-php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-bjeavons-zxcvbn-php.spec')
-rw-r--r--php-bjeavons-zxcvbn-php.spec8
1 files changed, 7 insertions, 1 deletions
diff --git a/php-bjeavons-zxcvbn-php.spec b/php-bjeavons-zxcvbn-php.spec
index 94b8cf3..cd661f6 100644
--- a/php-bjeavons-zxcvbn-php.spec
+++ b/php-bjeavons-zxcvbn-php.spec
@@ -135,11 +135,17 @@ EOF
: Skip known failed test
sed -e '/h1dden_26191/d' -i test/ZxcvbnTest.php
+: https://github.com/bjeavons/zxcvbn-php/issues/61
+if php -r 'exit(PHP_INT_SIZE < 8 ? 0 : 1);'
+then
+ FILTER="--filter '^((?!(testBinomialMirrorIdentity|testBinomialPascalsTriangleIdentity)).)*$'"
+fi
+
: Run upstream test suite
ret=0
for cmd in php php74 php80 php81; do
if which $cmd; then
- $cmd %{_bindir}/phpunit9 --verbose || ret=1
+ $cmd %{_bindir}/phpunit9 $FILTER --verbose || ret=1
fi
done
exit $ret