summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-13 15:26:09 +0100
committerRemi Collet <remi@php.net>2021-12-13 15:26:09 +0100
commita4e2c8a00c5511005c51e28acdbf7563aa673cdd (patch)
tree2c20d7df6d4bb15b7f25f494881090d7b02b1cb5
parent0b87d8f09f10562c57b0cdcccf91ffc6df63cecd (diff)
update to 1.3.0
add weak dependency on gmp extension switch to phpunit9
-rw-r--r--composer.json8
-rw-r--r--php-bjeavons-zxcvbn-php.spec25
2 files changed, 23 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index ec189c1..2c40aaa 100644
--- a/composer.json
+++ b/composer.json
@@ -12,14 +12,18 @@
}
],
"require": {
- "php": "^7.2 | ^8.0",
- "symfony/polyfill-mbstring": ">=1.3.1"
+ "php": "^7.2 | ^8.0 | ^8.1",
+ "symfony/polyfill-mbstring": ">=1.3.1",
+ "ext-json": "*"
},
"require-dev": {
"phpunit/phpunit": "^8.5",
"php-coveralls/php-coveralls": "*",
"squizlabs/php_codesniffer": "3.*"
},
+ "suggest": {
+ "ext-gmp": "Required for optimized binomial calculations (also requires PHP >= 7.3)"
+ },
"autoload": {
"psr-4": { "ZxcvbnPhp\\": "src/" }
},
diff --git a/php-bjeavons-zxcvbn-php.spec b/php-bjeavons-zxcvbn-php.spec
index b1eb4ba..94b8cf3 100644
--- a/php-bjeavons-zxcvbn-php.spec
+++ b/php-bjeavons-zxcvbn-php.spec
@@ -8,7 +8,7 @@
#
%bcond_without tests
# Github
-%global gh_commit 13b505d53c6e72a8fce7f42e3392f13642bbf65e
+%global gh_commit 5268743bffbb8cd182c98a4e79d6ed87004a6621
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner bjeavons
%global gh_project zxcvbn-php
@@ -20,7 +20,7 @@
%global ns_project ZxcvbnPhp
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.2.0
+Version: 1.3.0
Release: 1%{?dist}
Summary: Realistic password strength estimation PHP library
@@ -54,18 +54,23 @@ BuildRequires: php-composer(symfony/polyfill-mbstring) >= 1.3.1
# "phpunit/phpunit": "^8.5",
# "php-coveralls/php-coveralls": "*",
# "squizlabs/php_codesniffer": "3.*"
-BuildRequires: phpunit8 >= 8.5
+BuildRequires: phpunit9
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.2 | ^8.0",
-# "symfony/polyfill-mbstring": ">=1.3.1"
+# "php": "^7.2 | ^8.0 | ^8.1",
+# "symfony/polyfill-mbstring": ">=1.3.1",
+# "ext-json": "*"
+# "suggest": {
+# "ext-gmp": "Required for optimized binomial calculations (also requires PHP >= 7.3)"
Requires: php(language) >= 7.2
+Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(symfony/polyfill-mbstring) >= 1.3.1 with php-composer(symfony/polyfill-mbstring) < 2)
+Recommends: php-gmp
# remirepo:4
%else
Requires: php-composer(symfony/polyfill-mbstring) < 2
@@ -75,7 +80,6 @@ Requires: php-composer(symfony/polyfill-mbstring) >= 1.3.1
Requires: php-ctype
Requires: php-date
Requires: php-intl
-Requires: php-json
Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
@@ -133,9 +137,9 @@ sed -e '/h1dden_26191/d' -i test/ZxcvbnTest.php
: Run upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php74 php80 php81; do
if which $cmd; then
- $cmd %{_bindir}/phpunit8 --verbose || ret=1
+ $cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -152,6 +156,11 @@ exit $ret
%changelog
+* Mon Dec 13 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+- add weak dependency on gmp extension
+- switch to phpunit9
+
* Wed Apr 21 2021 Remi Collet <remi@remirepo.net> - 1.2.0-1
- initial package, version 1.2.0
- rename from php-mkopinsky-zxcvbn-php to php-bjeavons-zxcvbn-php