summaryrefslogtreecommitdiffstats
path: root/php-behat-gherkin.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-17 15:23:06 +0100
committerRemi Collet <remi@remirepo.net>2020-03-17 15:23:06 +0100
commit4c5f8715c92bea4178b060095781367f68ac0a78 (patch)
treefadb3bcfeb46543c03ad8c2e7bc8699713fef472 /php-behat-gherkin.spec
parent370819914f97259652aea31100b3111720e2cc17 (diff)
v1.6.1 from Fedora
Diffstat (limited to 'php-behat-gherkin.spec')
-rw-r--r--php-behat-gherkin.spec57
1 files changed, 44 insertions, 13 deletions
diff --git a/php-behat-gherkin.spec b/php-behat-gherkin.spec
index fe1dbb2..6d61151 100644
--- a/php-behat-gherkin.spec
+++ b/php-behat-gherkin.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-behat-gherkin
#
-# Copyright (c) 2016-2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2020 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,30 +12,46 @@
%global github_owner Behat
%global github_name Gherkin
-%global github_version 4.4.5
-%global github_commit 5c14cff4f955b17d20d088dec1bde61c0539ec74
+%global github_version 4.6.1
+%global github_commit 25bdcaf37898b4a939fa3031d5d753ced97e4759
%global composer_vendor behat
%global composer_project gherkin
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 8
+%global with_symfony2 0
+%else
+%global with_symfony2 1
+%endif
+
# "php": ">=5.3.1"
%global php_min_ver 5.3.1
-# "symfony/yaml": "~2.3|~3"
-# NOTE: Min version not 2.1 because autoloader required
+# "symfony/yaml": "~2.3|~3|~4"
+%if %{with_symfony2}
+# NOTE: Min version not 2.3 because autoloader required
%global symfony_min_ver %{?el6:2.3.31}%{!?el6:2.7.1}
-%global symfony_max_ver 4.0
+%else
+%global symfony_min_ver 3.0
+%endif
+%global symfony_max_ver 5.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
+# Range dependencies supported?
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global with_range_dependencies 1
+%else
+%global with_range_dependencies 0
+%endif
+
%global phpdir %{_datadir}/php
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Gherkin DSL parser for PHP
-Group: Development/Libraries
License: MIT
URL: http://behat.org/
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -46,11 +62,15 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
+%if %{with_range_dependencies}
+BuildRequires: (php-composer(symfony/yaml) >= %{symfony_min_ver} with php-composer(symfony/yaml) < %{symfony_max_ver})
+%else
BuildRequires: php-composer(symfony/yaml) >= %{symfony_min_ver}
BuildRequires: php-composer(symfony/yaml) < %{symfony_max_ver}
-## phpcompatinfo (computed from version 4.4.5)
+%endif
+## phpcompatinfo (computed from version 4.6.1)
+BuildRequires: php-ctype
BuildRequires: php-date
-BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -60,7 +80,8 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 4.4.5)
+# phpcompatinfo (computed from version 4.6.1)
+Requires: php-ctype
Requires: php-date
Requires: php-mbstring
Requires: php-pcre
@@ -73,7 +94,6 @@ Requires: php-composer(fedora/autoloader)
Suggests: php-composer(symfony/yaml)
%endif
-
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
@@ -101,8 +121,11 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Dependencies::optional(array(
array(
+ '%{phpdir}/Symfony4/Component/Yaml/autoload.php',
'%{phpdir}/Symfony3/Component/Yaml/autoload.php',
+%if %{with_symfony2}
'%{phpdir}/Symfony/Component/Yaml/autoload.php',
+%endif
),
));
AUTOLOAD
@@ -125,7 +148,7 @@ AUTOLOAD
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in php %{?rhel:php54 php55 php56 php70} php71 php72 php73 php74; do
if [ "php" = "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -147,6 +170,14 @@ exit $RETURN_CODE
%changelog
+* Tue Mar 17 2020 Shawn Iwinski <shawn@iwin.ski> - 4.6.1-2
+- Conditional Symfony 2 or not
+
+* Tue Mar 17 2020 Shawn Iwinski <shawn@iwin.ski> - 4.6.1-1
+- Update to 4.6.1 (RHBZ #1808131)
+- Conditionally use range dependencies
+- Drop Symfony 2 interoperability
+
* Sun Aug 20 2017 Shawn Iwinski <shawn@iwin.ski> - 4.4.5-1
- Update to 4.4.5
- Switch autoloader to fedora/autoloader