summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 12:27:25 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 12:27:25 +0200
commit370819914f97259652aea31100b3111720e2cc17 (patch)
tree0671e7d9eb7f5717830b6f0eb30771957446d600
parent0cf502be74b8f03e0ff601b00cc42392189e1e64 (diff)
backport
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json47
-rw-r--r--php-behat-gherkin.spec1
4 files changed, 59 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..d627882
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,47 @@
+{
+ "name": "behat/gherkin",
+ "description": "Gherkin DSL parser for PHP 5.3",
+ "keywords": ["BDD", "parser", "DSL", "Behat", "Gherkin", "Cucumber"],
+ "homepage": "http://behat.org/",
+ "type": "library",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Konstantin Kudryashov",
+ "email": "ever.zet@gmail.com",
+ "homepage": "http://everzet.com"
+ }
+ ],
+
+ "require": {
+ "php": ">=5.3.1"
+ },
+
+ "require-dev": {
+ "symfony/yaml": "~2.3|~3",
+ "symfony/phpunit-bridge": "~2.7|~3",
+ "phpunit/phpunit": "~4.5|~5"
+ },
+
+ "suggest": {
+ "symfony/yaml": "If you want to parse features, represented in YAML files"
+ },
+
+ "autoload": {
+ "psr-0": {
+ "Behat\\Gherkin": "src/"
+ }
+ },
+
+ "autoload-dev": {
+ "psr-4": {
+ "Tests\\Behat\\": "tests/Behat/"
+ }
+ },
+
+ "extra": {
+ "branch-alias": {
+ "dev-master": "4.4-dev"
+ }
+ }
+}
diff --git a/php-behat-gherkin.spec b/php-behat-gherkin.spec
index 30bd5b9..fe1dbb2 100644
--- a/php-behat-gherkin.spec
+++ b/php-behat-gherkin.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-behat-gherkin
#
# Fedora spec file for php-behat-gherkin
#