summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--php-bartlett-umlwriter-rpm.patch18
-rw-r--r--php-bartlett-umlwriter.spec9
3 files changed, 19 insertions, 16 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-bartlett-umlwriter-rpm.patch b/php-bartlett-umlwriter-rpm.patch
index a32dd8b..9b6dca6 100644
--- a/php-bartlett-umlwriter-rpm.patch
+++ b/php-bartlett-umlwriter-rpm.patch
@@ -1,7 +1,7 @@
diff -up ./bin/umlwriter.rpm ./bin/umlwriter
---- ./bin/umlwriter.rpm 2015-04-02 13:07:20.000000000 +0200
-+++ ./bin/umlwriter 2015-06-26 10:34:32.782633902 +0200
-@@ -2,23 +2,14 @@
+--- ./bin/umlwriter.rpm 2019-11-25 07:34:20.748457734 +0100
++++ ./bin/umlwriter 2019-11-25 07:35:39.059933977 +0100
+@@ -2,17 +2,8 @@
<?php
$appName = 'umlWriter';
@@ -16,16 +16,8 @@ diff -up ./bin/umlwriter.rpm ./bin/umlwriter
- }
-}
-require_once $vendorDir . '/autoload.php';
--
- if (PHP_SAPI !== 'cli') {
- return;
- }
-
+$vendorDir = '/usr/share/php';
+require_once $vendorDir . '/Bartlett/UmlWriter/autoload.php';
-+
- use Bartlett\UmlWriter\Console\Application;
--$application = new Application($appName, '1.3');
-+$application = new Application($appName, '@package_version@');
- $application->run();
+ if (PHP_SAPI !== 'cli') {
+ return;
diff --git a/php-bartlett-umlwriter.spec b/php-bartlett-umlwriter.spec
index 44c86d9..4772367 100644
--- a/php-bartlett-umlwriter.spec
+++ b/php-bartlett-umlwriter.spec
@@ -11,7 +11,7 @@
%undefine __brp_mangle_shebangs
%global bootstrap 0
-%global gh_commit 52248a8990522e88c91a2b7446406dbb43b3903e
+%global gh_commit 9f2b0800a4f541ad74e723e1f2f134dcddb8ddf5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150331
%global gh_owner llaville
@@ -24,7 +24,7 @@
%endif
Name: php-bartlett-umlwriter
-Version: 1.3.0
+Version: 1.3.1
%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Create UML class diagrams from your PHP source
@@ -138,7 +138,7 @@ install -Dpm 644 bin/umlwriter.1 %{buildroot}%{_mandir}/man1/umlwriter.1
%check
%if %{with_tests}
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --bootstrap %{buildroot}%{_datadir}/php/Bartlett/UmlWriter/autoload.php || ret=1
fi
@@ -160,6 +160,9 @@ exit $ret
%changelog
+* Mon Nov 25 2019 Remi Collet <remi@remirepo.net> - 1.3.1-1
+- update to 1.3.1 (no change)
+
* Tue Nov 27 2018 Remi Collet <remi@remirepo.net> - 1.3.0-1
- update to 1.3.0
- raise dependency on bartlett/php-reflect 4.3