summaryrefslogtreecommitdiffstats
path: root/php-bartlett-php-compatinfo-db.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-bartlett-php-compatinfo-db.spec')
-rw-r--r--php-bartlett-php-compatinfo-db.spec18
1 files changed, 15 insertions, 3 deletions
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 1d20348..0e4c4f1 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# See https://github.com/llaville/php-compatinfo-db/releases
-%global gh_commit 275f5b7a463194ebf22c733c786c0f40e50e6a00
+%global gh_commit 75fb80424afece3a251c1af845a6bfe4750bec19
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151031
%global gh_owner llaville
@@ -26,7 +26,7 @@
%bcond_with tests
%endif
-%global upstream_version 3.6.0
+%global upstream_version 3.7.0
#global upstream_prever RC1
Name: php-%{c_vendor}-%{c_project}
@@ -42,7 +42,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Fix sqlite database path
# Fix version and avoir composer/package-versions-deprecated (relying on composer.lock)
# Set proxy files as static
-Patch0: %{name}-3.4-rpm.patch
+Patch0: %{name}-3.7-rpm.patch
# CURL_SSLVERSION constants have been backported
Patch1: %{name}-curltls.patch
@@ -68,6 +68,7 @@ BuildRequires: php-composer-semver3
BuildRequires: php-doctrine-orm >= 2.7
BuildRequires: php-symfony-requirements-checker >= 2.0
%endif
+BuildRequires: php-symfony4-cache >= 4.4
BuildRequires: php-symfony4-config >= 4.4
BuildRequires: php-symfony4-console >= 4.4
BuildRequires: php-symfony4-dependency-injection >= 4.4
@@ -117,6 +118,7 @@ Requires: php-composer-semver3 >= 3.0
Requires: php-doctrine-orm >= 2.7
Requires: php-symfony-requirements-checker >= 2.0
%endif
+Requires: php-symfony4-cache >= 4.4
Requires: php-symfony4-config >= 4.4
Requires: php-symfony4-console >= 4.4
Requires: php-symfony4-dependency-injection >= 4.4
@@ -156,6 +158,7 @@ require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\CompatInfoDb\\', __DIR__);
\Fedora\Autoloader\Dependencies::required(array(
'%{_datadir}/php/Composer/Semver3/autoload.php',
+ '%{_datadir}/php/Symfony4/Component/Cache/autoload.php',
'%{_datadir}/php/Symfony4/Component/Config/autoload.php',
'%{_datadir}/php/Symfony4/Component/Console/autoload.php',
'%{_datadir}/php/Symfony4/Component/DependencyInjection/autoload.php',
@@ -246,6 +249,9 @@ require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/config/boot
\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\CompatInfoDb\\Tests\\', dirname(__DIR__) . '/tests');
EOF
+# https://github.com/llaville/php-compatinfo-db/issues/78
+rm -r tests/Reference/Extension/PhpBundle/Zip
+
ret=0
%{_bindir}/phpunit9 \
--include-path %{buildroot}%{_datadir}/php \
@@ -268,6 +274,12 @@ exit $ret
%changelog
+* Thu Jun 24 2021 Remi Collet <remi@remirepo.net> - 3.7.0-1
+- update to 3.7.0
+- open https://github.com/llaville/php-compatinfo-db/issues/79 imagick
+- open https://github.com/llaville/php-compatinfo-db/issues/78 zip
+- add dependency on symfony/cache for doctrine/cache v2
+
* Fri May 14 2021 Remi Collet <remi@remirepo.net> - 3.6.0-1
- update to 3.6.0