summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-bartlett-php-compatinfo-db-upstream.patch42
-rw-r--r--php-bartlett-php-compatinfo-db.spec2
2 files changed, 42 insertions, 2 deletions
diff --git a/php-bartlett-php-compatinfo-db-upstream.patch b/php-bartlett-php-compatinfo-db-upstream.patch
index 82345d1..7cd6873 100644
--- a/php-bartlett-php-compatinfo-db-upstream.patch
+++ b/php-bartlett-php-compatinfo-db-upstream.patch
@@ -262,3 +262,45 @@ index 7b3254f..c16bfce 100644
}
private function formatSection(array $data, string $section, StyleInterface $io): void
+From 3b8dd5711ad97a0a34fe22bd6df30247d6e8bbf9 Mon Sep 17 00:00:00 2001
+From: Laurent Laville <laurent.laville@gmail.com>
+Date: Thu, 14 Jan 2021 08:55:57 +0000
+Subject: [PATCH] fixe OCI8 reference issue (#62) see report comment
+
+---
+ CHANGELOG-3.x.md | 1 +
+ data/reference/extension/oci8/1/methods.json | 4 ++--
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/CHANGELOG-3.x.md b/CHANGELOG-3.x.md
+index 0229ff1..50c4f04 100644
+--- a/CHANGELOG-3.x.md
++++ b/CHANGELOG-3.x.md
+@@ -9,6 +9,7 @@ using the [Keep a CHANGELOG](http://keepachangelog.com) principles.
+ ### Fixed
+
+ - [#61](https://github.com/llaville/php-compatinfo-db/issues/61) Keep Symfony 4.4 Backward Compatibility
++- [#62](https://github.com/llaville/php-compatinfo-db/issues/62) OCI8 reference issue
+
+ ## [3.1.0] - 2021-01-09
+
+diff --git a/data/reference/extension/oci8/1/methods.json b/data/reference/extension/oci8/1/methods.json
+index 0aa2507..96ed79e 100644
+--- a/data/reference/extension/oci8/1/methods.json
++++ b/data/reference/extension/oci8/1/methods.json
+@@ -42,7 +42,7 @@
+ "ext_min": "1.0",
+ "ext_max": "",
+ "php_min": "4.3.0",
+- "php_max": "7.4.11"
++ "php_max": "7.4.14"
+ },
+ {
+ "class_name": "OCI-Collection",
+@@ -269,4 +269,4 @@
+ "php_min": "4.3.0",
+ "php_max": "7.4.14"
+ }
+-]
+\ No newline at end of file
++]
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 218c963..70acce6 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -246,8 +246,6 @@ require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.ph
\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\CompatInfoDb\\Tests\\', __DIR__);
EOF
-# https://github.com/llaville/php-compatinfo-db/issues/62
-rm -r tests/Reference/Extension/PhpBundle/Oci8
# https://github.com/llaville/php-compatinfo-db/issues/63
rm -r tests/Reference/Extension/PhpPecl/Http