summaryrefslogtreecommitdiffstats
path: root/php-bartlett-php-compatinfo-db.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-03 09:36:20 +0100
committerRemi Collet <remi@remirepo.net>2019-12-03 09:36:20 +0100
commit4af68851ea42db711991cf22c33d292314584087 (patch)
tree16bfde9f4c5643c3753162bed7bda096956c20b3 /php-bartlett-php-compatinfo-db.spec
parent0293430f6f32dee6ad85d9827efc44f80f6746fa (diff)
- update to 2.7.0
- ignore test results with 7.4, reported as https://github.com/llaville/php-compatinfo-db/issues/32
Diffstat (limited to 'php-bartlett-php-compatinfo-db.spec')
-rw-r--r--php-bartlett-php-compatinfo-db.spec20
1 files changed, 17 insertions, 3 deletions
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 160cb70..0c0cd78 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -7,12 +7,12 @@
# Please, preserve the changelog entries
#
# See https://github.com/llaville/php-compatinfo-db/releases
-%global gh_commit bd871074059200484af9f1beddd59ba72be54aca
+%global gh_commit 78595b6a4ad07ea43e06204b3dc62b1134f4bbc9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151031
%global gh_owner llaville
%global gh_project php-compatinfo-db
-%global upstream_version 2.6.0
+%global upstream_version 2.7.0
#global upstream_prever RC1
# Namespace
%global ns_vendor Bartlett
@@ -199,6 +199,9 @@ OPT=$(php -r '
case "73":
$max = Bartlett\CompatInfoDb\ExtensionFactory::LATEST_PHP_7_3;
break;
+ case "74":
+ $max = Bartlett\CompatInfoDb\ExtensionFactory::LATEST_PHP_7_4;
+ break;
default:
exit(0);
}
@@ -246,9 +249,15 @@ require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.ph
\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\Tests\\CompatInfoDb\\', __DIR__);
EOF
+ret=0
%{_bindir}/phpunit \
--include-path %{buildroot}%{_datadir}/php \
- -d memory_limit=1G
+ -d memory_limit=1G || ret=1
+
+if [ $(php -r 'echo PHP_VERSION_ID;') -lt 70400 ]
+then
+ exit $ret
+fi
%endif
@@ -264,6 +273,11 @@ EOF
%changelog
+* Tue Dec 3 2019 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- update to 2.7.0
+- ignore test results with 7.4, reported as
+ https://github.com/llaville/php-compatinfo-db/issues/32
+
* Fri Jul 26 2019 Remi Collet <remi@remirepo.net> - 2.6.0-1
- update to 2.6.0