summaryrefslogtreecommitdiffstats
path: root/php-bartlett-php-compatinfo-db.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-25 17:36:38 +0200
committerRemi Collet <remi@remirepo.net>2021-06-25 17:36:38 +0200
commit325bde333f3afa9549ac6634cfac67e848c340dd (patch)
tree9e59b0be16b71a0ace77aef719a96c25c543ef99 /php-bartlett-php-compatinfo-db.spec
parentc0b72563e8cb00baaff3721fb23b100c52fe1245 (diff)
test build with upstream patches for zip and imagick
Diffstat (limited to 'php-bartlett-php-compatinfo-db.spec')
-rw-r--r--php-bartlett-php-compatinfo-db.spec26
1 files changed, 21 insertions, 5 deletions
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 0e4c4f1..1700e9b 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -25,13 +25,15 @@
# disabled as too much issues, e.g. with symfony-polyfill
%bcond_with tests
%endif
+%bcond_with im6
+%bcond_with im7
%global upstream_version 3.7.0
#global upstream_prever RC1
Name: php-%{c_vendor}-%{c_project}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Reference Database to be used with php-compatinfo library
License: BSD
@@ -45,6 +47,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Patch0: %{name}-3.7-rpm.patch
# CURL_SSLVERSION constants have been backported
Patch1: %{name}-curltls.patch
+# upstream fix
+Patch2: upstream.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.2
@@ -73,6 +77,7 @@ BuildRequires: php-symfony4-config >= 4.4
BuildRequires: php-symfony4-console >= 4.4
BuildRequires: php-symfony4-dependency-injection >= 4.4
BuildRequires: php-symfony4-event-dispatcher >= 4.4
+BuildRequires: php-symfony4-process >= 4.4
BuildRequires: php-symfony4-messenger >= 4.4
BuildRequires: php-symfony4-stopwatch >= 4.4
# For our patch / autoloader
@@ -82,6 +87,12 @@ BuildRequires: php-composer(fedora/autoloader)
BuildRequires: php-cli
%if %{with tests}
BuildRequires: phpunit9
+%if %{with im6}
+BuildRequires: php-pecl-imagick-im6
+%endif
+%if %{with im7}
+BuildRequires: php-pecl-imagick-im7
+%endif
%endif
# From composer.json, "require"
@@ -94,11 +105,13 @@ BuildRequires: phpunit9
# "composer/package-versions-deprecated": "^1.8",
# "composer/semver": "^1.0|^2.0|^3.0",
# "doctrine/orm": "^2.7",
+# "symfony/cache": "^4.4|^5.0",
# "symfony/config": "^4.4|^5.0",
# "symfony/console": "^4.4|^5.0",
# "symfony/dependency-injection": "^4.4|^5.0",
# "symfony/event-dispatcher": "^4.4|^5.0",
# "symfony/messenger": "^4.4|^5.0",
+# "symfony/process": "^4.4|^5.0",
# "symfony/requirements-checker": "^2.0",
# "symfony/stopwatch": "^4.4|^5.0"
Requires: php(language) >= 7.2
@@ -124,6 +137,7 @@ Requires: php-symfony4-console >= 4.4
Requires: php-symfony4-dependency-injection >= 4.4
Requires: php-symfony4-event-dispatcher >= 4.4
Requires: php-symfony4-messenger >= 4.4
+Requires: php-symfony4-process >= 4.4
Requires: php-symfony4-stopwatch >= 4.4
# Required by autoloader
Requires: php-composer(fedora/autoloader)
@@ -142,6 +156,7 @@ Conflicts: php-bartlett-PHP-CompatInfo < 5
%patch0 -p1 -b .rpm
%patch1 -p1 -b .curltls
+%patch2 -p1 -b .up
: relocate
mv config src/config
@@ -249,9 +264,6 @@ require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/config/boot
\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\CompatInfoDb\\Tests\\', dirname(__DIR__) . '/tests');
EOF
-# https://github.com/llaville/php-compatinfo-db/issues/78
-rm -r tests/Reference/Extension/PhpBundle/Zip
-
ret=0
%{_bindir}/phpunit9 \
--include-path %{buildroot}%{_datadir}/php \
@@ -274,11 +286,15 @@ exit $ret
%changelog
-* Thu Jun 24 2021 Remi Collet <remi@remirepo.net> - 3.7.0-1
+* Fri Jun 25 2021 Remi Collet <remi@remirepo.net> - 3.7.0-3
+- test build with upstream patches for zip and imagick
+
+* Thu Jun 24 2021 Remi Collet <remi@remirepo.net> - 3.7.0-2
- update to 3.7.0
- open https://github.com/llaville/php-compatinfo-db/issues/79 imagick
- open https://github.com/llaville/php-compatinfo-db/issues/78 zip
- add dependency on symfony/cache for doctrine/cache v2
+- add dependency on symfony/process
* Fri May 14 2021 Remi Collet <remi@remirepo.net> - 3.6.0-1
- update to 3.6.0