summaryrefslogtreecommitdiffstats
path: root/php-bartlett-php-compatinfo-db.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-15 09:35:08 +0100
committerRemi Collet <remi@remirepo.net>2021-03-15 09:35:08 +0100
commit1e69e7bc68b26962298d568221de6fc9e819afaf (patch)
treecc2790e4bb57b901d7c8fc5258e61881d37674ff /php-bartlett-php-compatinfo-db.spec
parent09420d01c17cd98fbf2e928595b60faace057d63 (diff)
update to 3.4.2
Diffstat (limited to 'php-bartlett-php-compatinfo-db.spec')
-rw-r--r--php-bartlett-php-compatinfo-db.spec28
1 files changed, 15 insertions, 13 deletions
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 8d612f9..6da56e4 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# See https://github.com/llaville/php-compatinfo-db/releases
-%global gh_commit 279b73b83e093a3f01c38114f9ad52ce644e1d07
+%global gh_commit 35e3902e44f3345dae2dcb85f3fb903600ab19af
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151031
%global gh_owner llaville
@@ -26,23 +26,22 @@
%bcond_with tests
%endif
-%global upstream_version 3.3.0
+%global upstream_version 3.4.2
#global upstream_prever RC1
Name: php-%{c_vendor}-%{c_project}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 3%{?dist}
+Release: 1%{?dist}
Summary: Reference Database to be used with php-compatinfo library
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
-# Fix autoloader path
+# Fix autoloader and config path
# Fix sqlite database path
# Fix version and avoir composer/package-versions-deprecated (relying on composer.lock)
-# Set devel mode to avoid missing proxy files
-Patch0: %{name}-3-rpm.patch
+Patch0: %{name}-3.4-rpm.patch
# CURL_SSLVERSION constants have been backported
Patch1: %{name}-curltls.patch
@@ -145,7 +144,6 @@ Conflicts: php-bartlett-PHP-CompatInfo < 5
: relocate
mv config src/config
-mkdir src/proxies
cat << 'EOF' | tee src/autoload.php
<?php
@@ -217,7 +215,6 @@ sed -e "s:%{_datadir}/php/%{ns_vendor}/%{ns_project}:$PWD/src:" \
bin/compatinfo-db >compatinfo-db
export DATABASE_URL=sqlite:///${PWD}/compatinfo.sqlite
-doctrine orm:generate-proxies
doctrine orm:schema-tool:create
: Generate the references database
@@ -240,14 +237,13 @@ install -D -p -m 755 bin/compatinfo-db %{buildroot}%{_bindir}/%{name}
%check
export DATABASE_URL=sqlite:///%{buildroot}%{_datadir}/%{name}/compatinfo.sqlite
-cat << 'EOF' | tee tests/bootstrap.php
+mkdir config
+cat << 'EOF' | tee config/bootstrap.php
<?php
-require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\CompatInfoDb\\Tests\\', __DIR__);
+require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/config/bootstrap.php';
+\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\CompatInfoDb\\Tests\\', dirname(__DIR__) . '/tests');
EOF
-# https://github.com/llaville/php-compatinfo-db/issues/63
-# rm -r tests/Reference/Extension/PhpPecl/Http
ret=0
%{_bindir}/phpunit9 \
@@ -270,6 +266,12 @@ exit $ret
%changelog
+* Mon Mar 15 2021 Remi Collet <remi@remirepo.net> - 3.4.2-1
+- update to 3.4.2
+
+* Sat Mar 13 2021 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+
* Thu Mar 11 2021 Remi Collet <remi@remirepo.net> - 3.3.0-3
- switch back in production mode, and add a proxies directory
from https://github.com/llaville/php-compatinfo-db/pull/67