summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-20 11:12:08 +0100
committerRemi Collet <remi@php.net>2021-12-20 11:12:08 +0100
commitc539bf5ce3b40dfd5e33fd2ce82be41439a6d735 (patch)
tree2bdc28a66ec92a16943f08ad953193efca12bbce
parent0326200b21e9f0f6dd1030f7c2a3dad399d692df (diff)
update to 3.16.1
raise dependency on doctrine/dbal 3.1.4
-rw-r--r--composer.json2
-rw-r--r--php-bartlett-php-compatinfo-db-3.16-rpm.patch (renamed from php-bartlett-php-compatinfo-db-3.14-rpm.patch)13
-rw-r--r--php-bartlett-php-compatinfo-db.spec26
3 files changed, 18 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index 26c130c..f57cbd3 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,7 @@
"composer/package-versions-deprecated": "^1.8",
"composer/semver": "^1.0|^2.0|^3.0",
"doctrine/orm": "^2.7",
- "doctrine/dbal": "^2.13.1||^3.1.1",
+ "doctrine/dbal": "^2.13.1|^3.1.4",
"symfony/cache": "^4.4|^5.0",
"symfony/config": "^4.4|^5.0",
"symfony/console": "^4.4|^5.0",
diff --git a/php-bartlett-php-compatinfo-db-3.14-rpm.patch b/php-bartlett-php-compatinfo-db-3.16-rpm.patch
index c8b30d2..f85717d 100644
--- a/php-bartlett-php-compatinfo-db-3.14-rpm.patch
+++ b/php-bartlett-php-compatinfo-db-3.16-rpm.patch
@@ -10,7 +10,6 @@ diff -up ./bin/compatinfo-db.rpm ./bin/compatinfo-db
use Bartlett\CompatInfoDb\Infrastructure\Framework\Symfony\DependencyInjection\ContainerFactory;
use Bartlett\CompatInfoDb\Presentation\Console\ApplicationInterface;
-diff -up ./cli-config.php.rpm ./cli-config.php
diff -up ./config/bootstrap.php.rpm ./config/bootstrap.php
--- ./config/bootstrap.php.rpm 2021-11-22 10:58:42.000000000 +0100
+++ ./config/bootstrap.php 2021-11-22 15:36:00.058660775 +0100
@@ -115,15 +114,3 @@ diff -up ./src/Presentation/Console/Application.php.rpm ./src/Presentation/Conso
parent::__construct(self::NAME, $version);
}
-diff -up ./cli-config.php.rpm ./cli-config.php
---- ./cli-config.php.rpm 2021-11-22 15:48:52.261030390 +0100
-+++ ./cli-config.php 2021-11-22 15:48:54.913018175 +0100
-@@ -5,7 +5,7 @@ use Bartlett\CompatInfoDb\Infrastructure
- use Doctrine\ORM\EntityManagerInterface;
- use Doctrine\ORM\Tools\Console\ConsoleRunner;
-
--require_once __DIR__ . '/config/bootstrap.php';
-+require_once __DIR__ . '/src/config/bootstrap.php';
-
- $container = (new ContainerFactory())->create();
-
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index c10cd97..f5aa686 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# See https://github.com/llaville/php-compatinfo-db/releases
-%global gh_commit 65080937bf2d2d7606230db0d847eae5be8999b8
+%global gh_commit c2b0356a6240b52140d940fe421517ae8b7cd539
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151031
%global gh_owner llaville
@@ -28,7 +28,7 @@
%bcond_with im6
%bcond_with im7
-%global upstream_version 3.15.0
+%global upstream_version 3.16.1
#global upstream_prever RC1
Name: php-%{c_vendor}-%{c_project}
@@ -44,7 +44,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Fix sqlite database path
# Fix version and avoir composer/package-versions-deprecated (relying on composer.lock)
# Set proxy files as static
-Patch0: %{name}-3.14-rpm.patch
+Patch0: %{name}-3.16-rpm.patch
# Backported features affecting test suite
# - CURL_SSLVERSION constants
# - Phar::OPENSSL_SHA* constants
@@ -66,13 +66,13 @@ BuildRequires: php-spl
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(composer/semver) >= 3.0 with php-composer(composer/semver) < 4)
BuildRequires: (php-composer(doctrine/orm) >= 2.7 with php-composer(doctrine/orm) < 4)
-BuildRequires: (php-composer(doctrine/dbal) >= 3.1.1 with php-composer(doctrine/dbal) < 4)
+BuildRequires: (php-composer(doctrine/dbal) >= 3.1.4 with php-composer(doctrine/dbal) < 4)
BuildRequires: (php-composer(symfony/requirements-checker) >= 2.0 with php-composer(symfony/requirements-checker) < 3)
# remirepo:6
%else
BuildRequires: php-composer-semver3
BuildRequires: php-doctrine-orm >= 2.7
-BuildRequires: php-doctrine-dbal3 >= 3.1.1
+BuildRequires: php-doctrine-dbal3 >= 3.1.4
BuildRequires: php-symfony-requirements-checker >= 2.0
%endif
BuildRequires: php-symfony4-cache >= 4.4
@@ -109,7 +109,7 @@ BuildRequires: php-pecl-imagick-im7
# "composer/package-versions-deprecated": "^1.8",
# "composer/semver": "^1.0|^2.0|^3.0",
# "doctrine/orm": "^2.7",
-# "doctrine/dbal": "^2.13.1||^3.1.1",
+# "doctrine/dbal": "^2.13.1||^3.1.4",
# "symfony/cache": "^4.4|^5.0",
# "symfony/config": "^4.4|^5.0",
# "symfony/console": "^4.4|^5.0",
@@ -130,13 +130,13 @@ Requires: php-spl
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(composer/semver) >= 3.0 with php-composer(composer/semver) < 4)
Requires: (php-composer(doctrine/orm) >= 2.7 with php-composer(doctrine/orm) < 4)
-Requires: (php-composer(doctrine/dbal) >= 3.1.1 with php-composer(doctrine/dbal) < 4)
+Requires: (php-composer(doctrine/dbal) >= 3.1.4 with php-composer(doctrine/dbal) < 4)
Requires: (php-composer(symfony/requirements-checker) >= 2.0 with php-composer(symfony/requirements-checker) < 3)
# remirepo:6
%else
Requires: php-composer-semver3 >= 3.0
Requires: php-doctrine-orm >= 2.7
-Requires: php-doctrine-dbal3 >= 3.1.1
+Requires: php-doctrine-dbal3 >= 3.1.4
Requires: php-symfony-requirements-checker >= 2.0
%endif
Requires: php-symfony4-cache >= 4.4
@@ -248,8 +248,9 @@ sed -e "s:%{_datadir}/php/%{ns_vendor}/%{ns_project}:$PWD/src:" \
bin/compatinfo-db >compatinfo-db
export DATABASE_URL=sqlite:///${PWD}/compatinfo.sqlite
+ln -s src/config config
doctrine orm:generate-proxies
-doctrine orm:schema-tool:create
+doctrine orm:schema-tool:create --ansi
: Generate the references database
php -d memory_limit=2G -d date.timezone=Europe/Paris compatinfo-db db:init
@@ -259,6 +260,9 @@ php -d memory_limit=2G -d date.timezone=Europe/Paris compatinfo-db doctor --json
: Diag
%{_bindir}/php -d date.timezone=Europe/Paris compatinfo-db diagnose
+: Cleanup
+rm config
+
%install
mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
@@ -304,6 +308,10 @@ exit $ret
%changelog
+* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 3.16.1-1
+- update to 3.16.1
+- raise dependency on doctrine/dbal 3.1.4
+
* Thu Dec 2 2021 Remi Collet <remi@remirepo.net> - 3.15.0-1
- update to 3.15.0
- raise dependency on PHP 7.3