summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-10 08:55:34 +0100
committerRemi Collet <remi@remirepo.net>2021-02-10 08:55:34 +0100
commit386d82ada9b208fed426bd9cc11f889de806cfc4 (patch)
tree1c934562b680e2dd93adad220389f29ce3f713b6
parentb73c4f529bf448776ac21319ebf5620d04fecc51 (diff)
update to 3.2.0
-rw-r--r--composer.json10
-rw-r--r--php-bartlett-php-compatinfo-db-curltls.patch74
-rw-r--r--php-bartlett-php-compatinfo-db.spec8
3 files changed, 45 insertions, 47 deletions
diff --git a/composer.json b/composer.json
index 5171be1..08fc69e 100644
--- a/composer.json
+++ b/composer.json
@@ -48,7 +48,8 @@
"autoload": {
"psr-4": {
"Bartlett\\CompatInfoDb\\": "src/"
- }
+ },
+ "files": ["src/Infrastructure/Framework/Symfony/Polyfill.php"]
},
"autoload-dev": {
"psr-4": {
@@ -59,12 +60,13 @@
"setup-database": [
"mkdir -p ${HOME}/.cache/bartlett/ && touch ${HOME}/.cache/bartlett/compatinfo-db.sqlite",
"export DATABASE_URL=sqlite:///${HOME}/.cache/bartlett/compatinfo-db.sqlite",
- "vendor/bin/doctrine orm:schema-tool:create",
- "bin/compatinfo-db db:init"
+ "vendor/bin/doctrine orm:generate-proxies"
],
"post-install-cmd": [
"Bartlett\\CompatInfoDb\\ComposerScripts::preparePharMetadata",
- "@setup-database"
+ "@setup-database",
+ "vendor/bin/doctrine orm:schema-tool:create",
+ "bin/compatinfo-db db:init"
],
"post-update-cmd": [
"Bartlett\\CompatInfoDb\\ComposerScripts::preparePharMetadata",
diff --git a/php-bartlett-php-compatinfo-db-curltls.patch b/php-bartlett-php-compatinfo-db-curltls.patch
index 6a7f7f0..a9ef45d 100644
--- a/php-bartlett-php-compatinfo-db-curltls.patch
+++ b/php-bartlett-php-compatinfo-db-curltls.patch
@@ -1,59 +1,51 @@
-diff -up data/reference/extension/curl/55/constants.json.rhel data/reference/extension/curl/55/constants.json
---- data/reference/extension/curl/55/constants.json.rhel 2021-01-13 14:52:01.078221323 +0100
-+++ data/reference/extension/curl/55/constants.json 2021-01-13 14:56:11.536253445 +0100
-@@ -1861,6 +1861,7 @@
- "ext_max": "",
- "php_min": "5.5.0",
- "php_max": "",
+diff -up data/reference/extension/curl/55/constants.json.curltls data/reference/extension/curl/55/constants.json
+--- data/reference/extension/curl/55/constants.json.curltls 2021-02-10 08:41:37.593374602 +0100
++++ data/reference/extension/curl/55/constants.json 2021-02-10 08:48:53.129243382 +0100
+@@ -1440,26 +1440,31 @@
+ },
+ {
+ "name": "CURL_SSLVERSION_DEFAULT",
+ "optional": true,
- "php_excludes": ""
+ "ext_min": "5.5.0",
+ "php_min": "5.5.0"
},
{
-@@ -1869,6 +1870,7 @@
- "ext_max": "",
- "php_min": "5.5.0",
- "php_max": "",
+ "name": "CURL_SSLVERSION_SSLv2",
+ "optional": true,
- "php_excludes": ""
+ "ext_min": "5.5.0",
+ "php_min": "5.5.0"
},
{
-@@ -1877,6 +1879,7 @@
- "ext_max": "",
- "php_min": "5.5.0",
- "php_max": "",
+ "name": "CURL_SSLVERSION_SSLv3",
+ "optional": true,
- "php_excludes": ""
+ "ext_min": "5.5.0",
+ "php_min": "5.5.0"
},
{
-@@ -1885,6 +1888,7 @@
- "ext_max": "",
- "php_min": "5.5.0",
- "php_max": "",
+ "name": "CURL_SSLVERSION_TLSv1",
+ "optional": true,
- "php_excludes": ""
+ "ext_min": "5.5.0",
+ "php_min": "5.5.0"
},
{
-@@ -1893,6 +1897,7 @@
- "ext_max": "",
- "php_min": "5.5.19RC1",
- "php_max": "",
+ "name": "CURL_SSLVERSION_TLSv1_0",
+ "optional": true,
- "php_excludes": "5.6.0, 5.6.0RC1, 5.6.0RC2, 5.6.0RC3, 5.6.0RC4, 5.6.1, 5.6.1RC1, 5.6.2",
- "dependencies": [
- {
-@@ -1907,6 +1912,7 @@
- "ext_max": "",
+ "ext_min": "5.5.19RC1",
"php_min": "5.5.19RC1",
- "php_max": "",
-+ "optional": true,
"php_excludes": "5.6.0, 5.6.0RC1, 5.6.0RC2, 5.6.0RC3, 5.6.0RC4, 5.6.1, 5.6.1RC1, 5.6.2",
- "dependencies": [
- {
-@@ -1921,6 +1927,7 @@
- "ext_max": "",
+@@ -1472,6 +1477,7 @@
+ },
+ {
+ "name": "CURL_SSLVERSION_TLSv1_1",
++ "optional": true,
+ "ext_min": "5.5.19RC1",
"php_min": "5.5.19RC1",
- "php_max": "",
+ "php_excludes": "5.6.0, 5.6.0RC1, 5.6.0RC2, 5.6.0RC3, 5.6.0RC4, 5.6.1, 5.6.1RC1, 5.6.2",
+@@ -1484,6 +1490,7 @@
+ },
+ {
+ "name": "CURL_SSLVERSION_TLSv1_2",
+ "optional": true,
+ "ext_min": "5.5.19RC1",
+ "php_min": "5.5.19RC1",
"php_excludes": "5.6.0, 5.6.0RC1, 5.6.0RC2, 5.6.0RC3, 5.6.0RC4, 5.6.1, 5.6.1RC1, 5.6.2",
- "dependencies": [
- {
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 5219693..24c5ce0 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -7,12 +7,12 @@
# Please, preserve the changelog entries
#
# See https://github.com/llaville/php-compatinfo-db/releases
-%global gh_commit dee00b4277bba85ad01c625fb054cb9505204eca
+%global gh_commit 5b88639d0b03378d5646d38f7242a257a0ccb273
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151031
%global gh_owner llaville
%global gh_project php-compatinfo-db
-%global upstream_version 3.1.1
+%global upstream_version 3.2.0
#global upstream_prever RC1
# Namespace
%global ns_vendor Bartlett
@@ -215,6 +215,7 @@ sed -e "s:%{_datadir}/php/%{ns_vendor}/%{ns_project}:$PWD/src:" \
bin/compatinfo-db >compatinfo-db
export DATABASE_URL=sqlite:///${PWD}/compatinfo.sqlite
+doctrine orm:generate-proxies
doctrine orm:schema-tool:create
: Generate the references database
@@ -267,6 +268,9 @@ exit $ret
%changelog
+* Wed Feb 10 2021 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+
* Wed Jan 20 2021 Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1