summaryrefslogtreecommitdiffstats
path: root/php-bartlett-PHP-Reflect.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-13 18:02:53 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-13 18:02:53 +0100
commit90cf9ee1c481d5c44c079255b4eb6047b1cf16ff (patch)
tree605f9e06b90696932176ded3d1990c5c5393a907 /php-bartlett-PHP-Reflect.spec
parent5a1c46bae38ac4caa9267e447af4ec58da9b0cf2 (diff)
php-bartlett-PHP-Reflect: 2.6.0
Diffstat (limited to 'php-bartlett-PHP-Reflect.spec')
-rw-r--r--php-bartlett-PHP-Reflect.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 9ddaeed..09561bf 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -6,13 +6,13 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0e2a467f0b6f0c19ee61263bce97fb387408c6e3
+%global gh_commit 191ca7c7e44a36a0cd1dfaf42c4af77d0a9974cc
#global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner llaville
%global gh_project php-reflect
Name: php-bartlett-PHP-Reflect
-Version: 2.5.0
+Version: 2.6.0
%global specrel 1
Release: %{?gh_short:0.%{specrel}.git%{gh_short}}%{!?gh_short:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -39,6 +39,7 @@ BuildRequires: php-composer(symfony/event-dispatcher) >= 2.5
BuildRequires: php-composer(symfony/finder) >= 2.5
BuildRequires: php-composer(symfony/console) >= 2.5
BuildRequires: php-composer(seld/jsonlint) >= 1.1
+BuildRequires: php-composer(justinrainbow/json-schema) >= 1.3
# From composer.json, "require"
# "php": ">=5.3.0",
@@ -53,6 +54,7 @@ BuildRequires: php-composer(seld/jsonlint) >= 1.1
# "symfony/event-dispatcher": "~2.5",
# "symfony/finder": "~2.5",
# "symfony/console": "~2.5"
+# "justinrainbow/json-schema": "~1.3",
# "seld/jsonlint": "~1.1"
Requires: php(language) >= 5.3
Requires: php-date
@@ -75,6 +77,8 @@ Requires: php-composer(symfony/console) >= 2.5
Requires: php-composer(symfony/console) < 3
Requires: php-composer(seld/jsonlint) >= 1.1
Requires: php-composer(seld/jsonlint) < 2
+Requires: php-composer(justinrainbow/json-schema) >= 1.3
+Requires: php-composer(justinrainbow/json-schema) < 2
# From composer.json, "suggest"
# "doctrine/cache": "Allow caching results"
Requires: php-composer(doctrine/cache)
@@ -94,7 +98,8 @@ Documentation: http://php5.laurent-laville.org/reflect/manual/current/en/
%prep
-%setup -q -n %{gh_project}-%{gh_commit}
+#setup -q -n %{gh_project}-%{gh_commit}
+%setup -q -n %{gh_project}-%{version}
%patch0 -p1 -b .rpm
@@ -117,9 +122,8 @@ install -D -p -m 644 bin/phpreflect.1 %{buildroot}%{_mandir}/man1/phpref
%check
-# Version 2.0.0 : OK (128 tests, 128 assertions)
-%{_bindir}/phpunit \
- -d date.timezone=UTC
+# Version 2.0.0 : OK (155 tests, 156 assertions)
+%{_bindir}/phpunit
%clean
@@ -145,6 +149,10 @@ fi
%changelog
+* Thu Nov 13 2014 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- Update to 2.6.0
+- add dependency on justinrainbow/json-schema
+
* Thu Oct 16 2014 Remi Collet <remi@fedoraproject.org> - 2.5.0-1
- Update to 2.5.0
- add dependency on sebastian/version