summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-18 09:22:58 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-18 09:22:58 +0200
commitcfb20e812a4339428644266777a27b3fde7d87c3 (patch)
treebcd8a848bfdfd83df4340654fd3b8345447cc803
parent58c034b683d3fb0e48a6fca49759fc9c4bfc259d (diff)
php-bartlett-PHP-Reflect: allow sebastian/version 2.0
-rw-r--r--composer.json78
-rw-r--r--php-bartlett-PHP-Reflect.spec14
2 files changed, 90 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..b22d5ad
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,78 @@
+{
+ "name": "bartlett/php-reflect",
+ "description": "Adds the ability to reverse-engineer classes, interfaces, functions, constants, namespaces, traits and more.",
+ "keywords": ["reverse-engineer", "reflection"],
+ "type": "library",
+ "license": "BSD-3-Clause",
+ "homepage": "http://php5.laurent-laville.org/reflect/",
+ "support": {
+ "source": "https://github.com/llaville/php-reflect",
+ "issues": "https://github.com/llaville/php-reflect/issues"
+ },
+ "repositories": [
+ {
+ "type": "pear",
+ "url": "https://pear.php.net"
+ }
+ ],
+ "require": {
+ "php": ">=5.4.0",
+ "ext-tokenizer": "*",
+ "ext-pcre": "*",
+ "ext-phar": "*",
+ "ext-spl": "*",
+ "ext-json": "*",
+ "ext-date": "*",
+ "ext-reflection": "*",
+ "sebastian/version": "~1.0",
+ "nikic/php-parser": "~1.4",
+ "doctrine/collections": "~1.2",
+ "symfony/event-dispatcher": "~2.5",
+ "symfony/finder": "~2.5",
+ "symfony/console": "~2.5",
+ "symfony/stopwatch": "~2.5",
+ "symfony/dependency-injection": "~2.5",
+ "phpdocumentor/reflection-docblock": "~2.0",
+ "justinrainbow/json-schema": "~1.3",
+ "seld/jsonlint": "~1.1"
+ },
+ "require-dev": {
+ "doctrine/cache": "~1.3",
+ "psr/log": "~1.0",
+ "monolog/monolog": "~1.10",
+ "bartlett/monolog-callbackfilterhandler": "~1.0",
+ "bartlett/monolog-growlhandler": "~1.0",
+ "bartlett/phpunit-loggertestlistener": "~1.5",
+ "bartlett/umlwriter": "~1.0"
+ },
+ "suggest": {
+ "doctrine/cache": "Allow caching results",
+ "psr/log": "Allow logging events with the LogPlugin",
+ "monolog/monolog": "Allow logging events with the LogPlugin",
+ "bartlett/monolog-callbackfilterhandler": "Advanced filtering strategies for Monolog",
+ "bartlett/monolog-growlhandler": "Sends notifications to Growl for Monolog",
+ "bartlett/phpunit-loggertestlistener": "Allow logging unit tests to your favorite PSR-3 logger interface",
+ "bartlett/umlwriter": "Allow writing UML class diagrams (Graphviz or PlantUML)"
+ },
+ "authors": [
+ {
+ "name": "Laurent Laville",
+ "email": "pear@laurent-laville.org",
+ "homepage": "https://github.com/llaville",
+ "role": "Lead"
+ }
+ ],
+ "bin": [
+ "bin/phpreflect"
+ ],
+ "autoload": {
+ "psr-4": {
+ "Bartlett\\": "src/Bartlett"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Bartlett\\Tests\\Reflect\\": "tests/"
+ }
+ }
+}
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index f001533..63adf14 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -21,7 +21,7 @@
Name: php-bartlett-PHP-Reflect
Version: 4.0.0
-%global specrel 1
+%global specrel 3
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -88,7 +88,7 @@ Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
Requires: php-composer(sebastian/version) >= 1.0
-Requires: php-composer(sebastian/version) < 2
+Requires: php-composer(sebastian/version) < 3
Requires: php-composer(nikic/php-parser) >= 1.4
Requires: php-composer(nikic/php-parser) < 2
Requires: php-composer(doctrine/collections) >= 1.2
@@ -175,6 +175,12 @@ install -D -p -m 644 bin/phpreflect.1 %{buildroot}%{_mandir}/man1/phpref
%{_bindir}/phpunit \
--include-path=%{buildroot}%{_datadir}/php \
--verbose
+
+if which php70; then
+ php70 %{_bindir}/phpunit \
+ --include-path=%{buildroot}%{_datadir}/php \
+ --verbose
+fi
%else
: Test suite disabled
%endif
@@ -198,6 +204,10 @@ fi
%changelog
+* Mon Apr 18 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-3
+- allow sebastian/version 2.0
+- run test suite with both PHP 5 and 7 when available
+
* Sat Dec 5 2015 Remi Collet <remi@fedoraproject.org> - 4.0.0-1
- update to 4.0.0
- raise dependency on nikic/php-parser >= 1.4