summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-01-05 15:11:54 +0100
committerRemi Collet <fedora@famillecollet.com>2015-01-05 15:11:54 +0100
commit754b31a19fde40c68fdf4c74938939aa93265f3d (patch)
tree5d27cd886d6215fd6a02c9c6b643fd477310da5d
parent854d075137153a372ee6ba8d3639c88e230b0456 (diff)
php-bartlett-PHP-Reflect: 2.6.2
-rw-r--r--php-bartlett-PHP-Reflect-pr16.patch23
-rw-r--r--php-bartlett-PHP-Reflect.spec11
2 files changed, 32 insertions, 2 deletions
diff --git a/php-bartlett-PHP-Reflect-pr16.patch b/php-bartlett-PHP-Reflect-pr16.patch
new file mode 100644
index 0000000..9cb5bb5
--- /dev/null
+++ b/php-bartlett-PHP-Reflect-pr16.patch
@@ -0,0 +1,23 @@
+From 9ab5673d110729d23197f2b68bb0685fa8696640 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Mon, 5 Jan 2015 14:58:42 +0100
+Subject: [PATCH] fix failed tests because of file order
+
+---
+ tests/PhpFeature/V504Test.php | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tests/PhpFeature/V504Test.php b/tests/PhpFeature/V504Test.php
+index 14a23b8..ad39ff8 100644
+--- a/tests/PhpFeature/V504Test.php
++++ b/tests/PhpFeature/V504Test.php
+@@ -52,7 +52,8 @@ public static function setUpBeforeClass()
+ $finder->files()
+ ->name('gh15.php')
+ ->name('php504ArrayFeatures.php')
+- ->in(self::$fixtures);
++ ->in(self::$fixtures)
++ ->sortByName()
+ ;
+
+ $pm = new ProviderManager;
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 6b44d5d..5ca4b27 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -6,13 +6,13 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f21f4d332b264973f0be83ccdb4c4e1d8704b9bb
+%global gh_commit 6b059b7106c74e9db5d7dd84c2995eb6fe678331
#global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner llaville
%global gh_project php-reflect
Name: php-bartlett-PHP-Reflect
-Version: 2.6.1
+Version: 2.6.2
%global specrel 1
Release: %{?gh_short:0.%{specrel}.git%{gh_short}}%{!?gh_short:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -26,6 +26,9 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Enable cache plugin
Patch0: %{name}-rpm.patch
+# https://github.com/llaville/php-reflect/pull/16
+Patch1: %{name}-pr16.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3
@@ -102,6 +105,7 @@ Documentation: http://php5.laurent-laville.org/reflect/manual/current/en/
#setup -q -n %{gh_project}-%{version}
%patch0 -p1 -b .rpm
+%patch1 -p1 -b .pr16
sed -e 's/@package_version@/%{version}/' \
-i $(find src -name \*.php)
@@ -149,6 +153,9 @@ fi
%changelog
+* Mon Jan 5 2015 Remi Collet <remi@fedoraproject.org> - 2.6.2-1
+- Update to 2.6.2
+
* Thu Dec 4 2014 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
- Update to 2.6.1