summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-20 09:13:14 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-20 09:13:14 +0200
commit685fb8480727533b0b13a36c50309cb60ffcd9cb (patch)
tree9c57deb38ee10a559e32b3df3f121b5ca53f4de1
parent4f39b288d6e5f39ed95de4bc89a9df96c7faf11a (diff)
php-pecl-couchbase2: duplicate of php-pecl-couchbase (for new API)
-rw-r--r--php-bartlett-PHP-Reflect-rpm.patch18
-rw-r--r--php-bartlett-PHP-Reflect.spec12
2 files changed, 18 insertions, 12 deletions
diff --git a/php-bartlett-PHP-Reflect-rpm.patch b/php-bartlett-PHP-Reflect-rpm.patch
index 2d25467..942bc5c 100644
--- a/php-bartlett-PHP-Reflect-rpm.patch
+++ b/php-bartlett-PHP-Reflect-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./bin/phpreflect.json.dist.rpm ./bin/phpreflect.json.dist
---- ./bin/phpreflect.json.dist.rpm 2014-08-22 08:04:25.256132414 +0200
-+++ ./bin/phpreflect.json.dist 2014-08-22 08:04:29.413148972 +0200
+--- ./bin/phpreflect.json.dist.rpm 2014-09-19 13:52:26.000000000 +0200
++++ ./bin/phpreflect.json.dist 2014-09-19 16:08:31.695874693 +0200
@@ -9,6 +9,19 @@
{
"name": "Analyser",
@@ -22,8 +22,8 @@ diff -up ./bin/phpreflect.json.dist.rpm ./bin/phpreflect.json.dist
],
"analysers" : [
diff -up ./bin/phpreflect.rpm ./bin/phpreflect
---- ./bin/phpreflect.rpm 2014-08-21 19:09:40.000000000 +0200
-+++ ./bin/phpreflect 2014-08-22 08:04:07.852063131 +0200
+--- ./bin/phpreflect.rpm 2014-09-19 13:52:26.000000000 +0200
++++ ./bin/phpreflect 2014-09-19 16:12:13.853757847 +0200
@@ -1,11 +1,11 @@
-#!/usr/bin/env php
+#!/usr/bin/php
@@ -38,11 +38,12 @@ diff -up ./bin/phpreflect.rpm ./bin/phpreflect
if (!getenv("REFLECT")) {
$home = defined('PHP_WINDOWS_VERSION_BUILD') ? 'USERPROFILE' : 'HOME';
-@@ -22,7 +22,26 @@ if (\Phar::running()) {
+@@ -22,8 +22,27 @@ if (\Phar::running()) {
}
}
}
--require_once $vendorDir . '/autoload.php';
+-$loader = require_once $vendorDir . '/autoload.php';
+-$loader->setUseIncludePath(true);
+require_once $vendorDir . '/PhpParser/Autoloader.php';
+PhpParser\Autoloader::register();
+
@@ -62,13 +63,14 @@ diff -up ./bin/phpreflect.rpm ./bin/phpreflect
+ 'Seld\\JsonLint' => $vendorDir,
+ 'Bartlett' => $vendorDir,
+));
++$loader->useIncludePath(true);
+$loader->register();
if (PHP_SAPI !== 'cli') {
return;
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2014-08-21 19:09:40.000000000 +0200
-+++ ./tests/bootstrap.php 2014-08-22 08:04:07.852063131 +0200
+--- ./tests/bootstrap.php.rpm 2014-09-19 13:52:26.000000000 +0200
++++ ./tests/bootstrap.php 2014-09-19 16:08:31.695874693 +0200
@@ -1,6 +1,19 @@
<?php
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 45dc9ab..fb311eb 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -6,13 +6,13 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit d29fddd3c9732d2faa74eae0c3ddfdfdef551489
+%global gh_commit 5f2e0a7e08e377c6924ffb5d24bc41d800a393f2
#global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner llaville
%global gh_project php-reflect
Name: php-bartlett-PHP-Reflect
-Version: 2.3.0
+Version: 2.4.0
%global specrel 1
Release: %{?gh_short:0.%{specrel}.git%{gh_short}}%{!?gh_short:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -47,7 +47,7 @@ BuildRequires: php-composer(seld/jsonlint) >= 1.1
# "ext-json": "*",
# "ext-date": "*",
# "phpunit/php-timer": ">=1.0.0",
-# "nikic/php-parser": "1.0.0beta1",
+# "nikic/php-parser": "~1.0",
# "symfony/event-dispatcher": "~2.5",
# "symfony/finder": "~2.5",
# "symfony/console": "~2.5"
@@ -60,7 +60,8 @@ Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
Requires: php-composer(phpunit/php-timer) >= 1.0.0
-Requires: php-composer(nikic/php-parser) >= 1.0.0
+Requires: php-composer(nikic/php-parser) >= 1.0
+Requires: php-composer(nikic/php-parser) < 2
Requires: php-composer(symfony/event-dispatcher) >= 2.5
Requires: php-composer(symfony/event-dispatcher) < 3
Requires: php-composer(symfony/finder) >= 2.5
@@ -139,6 +140,9 @@ fi
%changelog
+* Fri Sep 19 2014 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
+- Update to 2.4.0
+
* Fri Aug 22 2014 Remi Collet <remi@fedoraproject.org> - 2.3.0-1
- Update to 2.3.0
- add dependency on seld/jsonlint