summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-05 09:24:32 +0200
committerRemi Collet <remi@remirepo.net>2017-10-05 09:24:32 +0200
commit5f1a0245fbcb9ee4d10e74806cb3932158024f16 (patch)
tree8cf8cc558013c9c0d104f6c22835b42b2fdb9d69
parent5ccf72aa69a9d130078d05aab23ffff1885ed1a5 (diff)
fix autoloader for Symfony 3, FTBFS from Koschei
-rw-r--r--php-bartlett-PHP-Reflect-autoload.php2
-rw-r--r--php-bartlett-PHP-Reflect.spec5
2 files changed, 5 insertions, 2 deletions
diff --git a/php-bartlett-PHP-Reflect-autoload.php b/php-bartlett-PHP-Reflect-autoload.php
index a7606de..eda9084 100644
--- a/php-bartlett-PHP-Reflect-autoload.php
+++ b/php-bartlett-PHP-Reflect-autoload.php
@@ -8,7 +8,7 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\', dirname(__DIR__));
\Fedora\Autoloader\Dependencies::required(array(
array(
- '/usr/share/php/Symfony/Component3/autoload.php',
+ '/usr/share/php/Symfony3/Component/autoload.php',
'/usr/share/php/Symfony/Component/autoload.php',
),
'/usr/share/php/PhpParser2/autoload.php',
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index e9449ba..31c674d 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -21,7 +21,7 @@
Name: php-bartlett-PHP-Reflect
Version: 4.1.0
-%global specrel 1
+%global specrel 2
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -218,6 +218,9 @@ fi
%changelog
+* Thu Oct 5 2017 Remi Collet <remi@remirepo.net> - 4.1.0-2
+- fix autoloader for Symfony 3, FTBFS from Koschei
+
* Thu May 4 2017 Remi Collet <remi@remirepo.net> - 4.1.0-1
- Update to 4.1.0
- raise dependency on nikic/php-parser >= 2.1