summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-26 17:20:05 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-26 17:20:05 +0100
commit55f2dca73b04a11bd504cea87b7fe0271d546338 (patch)
tree10b425d6113ecbfdbf254ccff6e81d79e9ff6110
parentb92aee7e1c2591a25ac40a1cf00a12a69e6ae523 (diff)
php-bartlett-PHP-Reflect: sync with rawhid
-rw-r--r--Makefile2
-rw-r--r--PHP_Reflect-addhtml.patch12
-rw-r--r--PHP_Reflect-docs.patch71
-rw-r--r--php-bartlett-PHP-Reflect.spec44
4 files changed, 39 insertions, 90 deletions
diff --git a/Makefile b/Makefile
index 1e65467..13af741 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-include ../common/Makefile
+include ../../../common/Makefile
diff --git a/PHP_Reflect-addhtml.patch b/PHP_Reflect-addhtml.patch
index ae9a230..c62cf03 100644
--- a/PHP_Reflect-addhtml.patch
+++ b/PHP_Reflect-addhtml.patch
@@ -1,16 +1,16 @@
-diff -up PHP_Reflect-1.0.2/php-bartlett-PHP-Reflect.xml.inst2 PHP_Reflect-1.0.2/php-bartlett-PHP-Reflect.xml
---- PHP_Reflect-1.0.2/php-bartlett-PHP-Reflect.xml.inst2 2011-09-19 18:13:52.630592571 +0200
-+++ PHP_Reflect-1.0.2/php-bartlett-PHP-Reflect.xml 2011-09-19 18:13:57.232589618 +0200
-@@ -238,6 +238,15 @@ Bug fixes:
- <file baseinstalldir="Bartlett" md5sum="13e7cd0079e1cdf3283ba099e0f87f9f" name="LICENSE" role="doc">
+diff -up PHP_Reflect-1.1.0/php-bartlett-PHP-Reflect.xml.addhtml PHP_Reflect-1.1.0/php-bartlett-PHP-Reflect.xml
+--- PHP_Reflect-1.1.0/php-bartlett-PHP-Reflect.xml.addhtml 2011-11-11 19:30:07.000000000 +0100
++++ PHP_Reflect-1.1.0/php-bartlett-PHP-Reflect.xml 2011-11-11 19:31:26.000000000 +0100
+@@ -255,5 +255,15 @@ Bug fixes:
<tasks:replace from="@package_version@" to="version" type="package-info" />
</file>
-+ <file baseinstalldir="Bartlett" name="docs/userguide.html" role="doc" />
++ <file baseinstalldir="Bartlett" name="docs/phpreflect-book.html" role="doc" />
+ <file baseinstalldir="Bartlett" name="docs/index.html" role="doc" />
+ <file baseinstalldir="Bartlett" name="docs/CHANGELOG.html" role="doc" />
+ <file baseinstalldir="Bartlett" name="docs/INSTALL.html" role="doc" />
+ <file baseinstalldir="Bartlett" name="docs/LICENSE.html" role="doc" />
+ <file baseinstalldir="Bartlett" name="docs/sources/scanFile.html" role="doc" />
++ <file baseinstalldir="Bartlett" name="docs/sources/scanFunctionArguments.html" role="doc" />
+ <file baseinstalldir="Bartlett" name="docs/sources/Token.html" role="doc" />
+ <file baseinstalldir="Bartlett" name="docs/sources/Autoload.html" role="doc" />
+ <file baseinstalldir="Bartlett" name="docs/sources/Reflect.html" role="doc" />
diff --git a/PHP_Reflect-docs.patch b/PHP_Reflect-docs.patch
deleted file mode 100644
index 79b99c4..0000000
--- a/PHP_Reflect-docs.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- docs/index.txt.orig 2011-07-18 17:56:01.598097428 +0200
-+++ docs/index.txt 2011-07-18 17:55:43.602953982 +0200
-@@ -94,17 +94,15 @@
- The PHP_Reflect manual is available in a selection of formats. Pick a format
- from the table below to start downloading.
-
--[grid="rows",format="csv"]
- [options="header"]
- |===========================
--Language,Single HTML file,Many HTML files,HTML Help file,PDF file
--English,link:{binary_dir}userguide.zip[userguide.zip] (6Kb), link:{binary_dir}userguide.chunked.zip[userguide.chunked.zip] (42Kb) , link:{binary_dir}userguide.chm.zip[userguide.chm.zip] (39Kb), link:{binary_dir}userguide.pdf[pdf] (70Kb)
-+| Language | Single HTML file | Many HTML files | HTML Help file | PDF file
-+| English | link:{binary_dir}userguide.zip[userguide.zip] 6 Kb | link:{binary_dir}userguide.chunked.zip[userguide.chunked.zip] 42 Kb | link:{binary_dir}userguide.chm[userguide.chm.zip] 46 Kb | link:{binary_dir}userguide.pdf[userguide.pdf] 70 Kb
- |===========================
-
-
--[appendix]
--Classes Source Code
---------------------
-+== Appendix A: Classes Source Code
-+
- Below you can find highlighted PHP source code
- (with http://pygments.org/[Pygments])
- of PHP_Reflect classes version {revnumber}
-@@ -113,27 +111,22 @@
- * link:sources/Autoload.html[Autoload]
- * link:sources/Token.html[Tokens]
-
--[appendix]
--Examples
----------
-+== Appendix B: Examples
-+
- .Scan a simple file
- * link:sources/scanFile.html[Basic usage with default options]
-
--[appendix]
--Changelog
-----------
-+== Appendix C: Changelog
- link:CHANGELOG.html[History of changes]
-
--[appendix]
--License
---------
-+== Appendix D: License
-+
- Released under the link:LICENSE.html[BSD] license,
- you are free to do whatever you want, even in a commercial environment.
- You are also encouraged to contribute.
-
--[appendix]
--Credits
---------
-+== Appendix E: Credits
-+
-
- [quote, , https://github.com/sebastianbergmann/]
- ____
-@@ -144,9 +137,8 @@
- ____
-
-
--[appendix]
--Links
-------
-+== Appendix F: Links
-+
- All pages of this site, and user guide were generated with AsciiDoc 8.6.5,
- assisted by FOP 1.0 (for PDFs). Automated build process uses Phing 2.4.5
-
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 44a49e4..5b9b080 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -2,7 +2,7 @@
%global channel bartlett.laurent-laville.org
%global pear_name PHP_Reflect
-%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
+%if 0%{?fedora} >= 12
%global withhtmldoc 1
%else
%global withhtmldoc 0
@@ -10,7 +10,7 @@
Name: php-bartlett-PHP-Reflect
-Version: 1.0.2
+Version: 1.4.2
Release: 2%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -19,8 +19,6 @@ License: BSD
URL: http://bartlett.laurent-laville.org/
Source0: http://%{channel}/get/%{pear_name}-%{version}%{?prever}.tgz
-# for old asciidoc version https://bugzilla.redhat.com/556171
-Patch0: PHP_Reflect-docs.patch
# Don't install .js (unused)
Patch1: PHP_Reflect-deljs.patch
# Install generated doc using pear command
@@ -62,7 +60,6 @@ HTML Documentation: %{pear_docdir}/%{pear_name}/docs/index.html
cd %{pear_name}-%{version}%{?prever}
mv -f ../package.xml %{name}.xml
-%patch0 -p0 -b .fix
%patch1 -p1 -b .deljs
%if %{withhtmldoc}
%patch2 -p1 -b .addhtml
@@ -74,21 +71,20 @@ cd %{pear_name}-%{version}%{?prever}
%if %{withhtmldoc}
# Generate the HTML documentation
-phing -f docs/build-phing.xml \
+phing -f docs/build-phing.xml \
-Dhomedir=$PWD \
-Dasciidoc.home=%{_datadir}/asciidoc \
- make-full-docs
+ -Doutput.dir=$PWD/docs \
+ -Dbuild.tarball=false \
+ make-html-docs
# Asciidoc fails silently
# Check that our patch for installed doc is ok
cpt=$(find docs -name \*.html | wc -l)
echo "File generated:$cpt, expected:9"
-[ $cpt -eq 9 ] || exit 1
+[ $cpt -eq 10 ] || exit 1
%endif
-# restore unpatched docs (for install and checksum)
-mv docs/index.txt.fix docs/index.txt
-
%install
rm -rf %{buildroot}
@@ -108,7 +104,7 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
cd %{pear_name}-%{version}%{?prever}
-# Version 1.0.2 : OK (25 tests, 42 assertions)
+# Version 1.3.0 : OK (34 tests, 55 assertions)
%{_bindir}/phpunit \
-d date.timezone=UTC \
--bootstrap %{buildroot}%{pear_phpdir}/Bartlett/PHP/Reflect/Autoload.php \
@@ -139,6 +135,30 @@ fi
%changelog
+* Tue Aug 14 2012 Remi Collet <remi@fedoraproject.org> - 1.4.2-2
+- rebuildt for new pear_testdir
+
+* Wed Aug 01 2012 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
+- Version 1.4.2 (stable) - API 1.4.0 (stable)
+
+* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Fri Feb 17 2012 Remi Collet <remi@fedoraproject.org> - 1.3.0-2
+- bump release
+
+* Fri Feb 17 2012 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- Version 1.3.0 (stable) - API 1.3.0 (stable)
+
+* Sun Feb 05 2012 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- Version 1.2.0 (stable) - API 1.2.0 (stable)
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Fri Nov 11 2011 Remi Collet <Fedora@FamilleCollet.com> - 1.1.0-1
+- Version 1.1.0 (stable) - API 1.1.0 (stable)
+
* Mon Sep 19 2011 Remi Collet <Fedora@FamilleCollet.com> - 1.0.2-2
- remove unused .js and improve installation of generated doc
- use buildroot macro