summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-19 06:43:08 +0100
committerRemi Collet <remi@remirepo.net>2017-12-19 06:43:08 +0100
commit3e5927c49203233b44ac91f6f5adb20bd6466808 (patch)
tree5c90a0359465b82251a7c86a90851d89d7eb808c
parent10d34b640bc9c1e4b290fa15db98ba58bf4a9f41 (diff)
fix autoloader to ensure nikic/php-parser v2 is used
-rw-r--r--php-bartlett-PHP-Reflect-autoload.php2
-rw-r--r--php-bartlett-PHP-Reflect.spec7
2 files changed, 6 insertions, 3 deletions
diff --git a/php-bartlett-PHP-Reflect-autoload.php b/php-bartlett-PHP-Reflect-autoload.php
index eda9084..08bc459 100644
--- a/php-bartlett-PHP-Reflect-autoload.php
+++ b/php-bartlett-PHP-Reflect-autoload.php
@@ -7,11 +7,11 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\', dirname(__DIR__));
\Fedora\Autoloader\Dependencies::required(array(
+ '/usr/share/php/PhpParser2/autoload.php',
array(
'/usr/share/php/Symfony3/Component/autoload.php',
'/usr/share/php/Symfony/Component/autoload.php',
),
- '/usr/share/php/PhpParser2/autoload.php',
'/usr/share/php/Seld/JsonLint/autoload.php',
'/usr/share/php/JsonSchema/autoload.php',
'/usr/share/php/SebastianBergmann/Version/autoload.php',
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 3f27328..1bf6a67 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -27,7 +27,7 @@
Name: php-bartlett-PHP-Reflect
Version: 4.2.2
-%global specrel 1
+%global specrel 2
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -183,7 +183,7 @@ install -D -p -m 644 bin/phpreflect.1 %{buildroot}%{_mandir}/man1/phpref
%check
%if %{with_tests}
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd %{_bindir}/phpunit \
--include-path=%{buildroot}%{_datadir}/php \
@@ -214,6 +214,9 @@ fi
%changelog
+* Tue Dec 19 2017 Remi Collet <remi@remirepo.net> - 4.2.2-2
+- fix autoloader to ensure nikic/php-parser v2 is used
+
* Thu Dec 14 2017 Remi Collet <remi@remirepo.net> - 4.2.2-1
- Update to 4.2.2