summaryrefslogtreecommitdiffstats
path: root/php-bartlett-PHP-CompatInfo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-bartlett-PHP-CompatInfo.spec')
-rw-r--r--php-bartlett-PHP-CompatInfo.spec16
1 files changed, 9 insertions, 7 deletions
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index e648e01..94c7d3c 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-bartlett-PHP-CompatInfo
#
-# Copyright (c) 2011-2019 Remi Collet
+# Copyright (c) 2011-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,13 +11,13 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 4c4da0eacb582c15dd6a696eb9123786e3b2de25
+%global gh_commit 2aed4fbbed13290c160f24ca1befc58ddd42cda8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
%global gh_project php-compat-info
#global prever RC2
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%bcond_without tests
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global sym_prefix php-symfony3
@@ -38,15 +38,16 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Script for fedora-review
Source1: fedora-review-check
-# Autoloader for RPM - die composer !
+# RPM autoloader
Source2: %{name}-5.1.0-autoload.php
# Autoload and sqlite database path
+# avoid jean85/pretty-package-versions
Patch0: %{name}-5.3.0-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.1.3
-%if %{with_tests}
+%if %{with tests}
# to run test suite
BuildRequires: php-pdo_sqlite
# remirepo:1
@@ -80,8 +81,9 @@ BuildRequires: php-composer(fedora/autoloader)
# "ext-json": "*",
# "ext-pdo": "*",
# "ext-pdo_sqlite": "*",
-# "bartlett/php-reflect": "4.4.x-dev as 4.4.0",
+# "bartlett/php-reflect": "^4.4",
# "bartlett/php-compatinfo-db": "^2.0",
+# "jean85/pretty-package-versions": "^1.5",
# "psr/log": "^1.0"
Requires: php(language) >= 7.1.3
Requires: php-cli
@@ -155,7 +157,7 @@ install -D -p -m 644 bin/phpcompatinfo.1 %{buildroot}%{_mandir}/man1/php
install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}/fedora-review-check
-%if %{with_tests}
+%if %{with tests}
%check
mkdir vendor
ln -s %{buildroot}%{_datadir}/php/Bartlett/CompatInfo/autoload.php vendor/