summaryrefslogtreecommitdiffstats
path: root/php-bartlett-PHP-CompatInfo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-bartlett-PHP-CompatInfo.spec')
-rw-r--r--php-bartlett-PHP-CompatInfo.spec82
1 files changed, 46 insertions, 36 deletions
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 8382afb..a9f997e 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,13 +11,13 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 041352673a390b3e0822fc4b0e295ac6267dffbf
+%global gh_commit 832e40edc6e818f10f432803ddd9350b37f07d8f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
%global gh_project php-compatinfo
-%global upstream_version 6.4.2
+%global upstream_version 6.5.2
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
@@ -25,7 +25,8 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
-License: BSD and MIT
+# see bundled libraries list below
+License: BSD-3-Clause and MIT
URL: https://github.com/llaville/php-compatinfo
Source0: %{name}-%{version}-%{gh_short}.tgz
# Script for fedora-review
@@ -56,7 +57,7 @@ Requires: php-xmlreader
# Bundled libraries
# License BSD-3-Clause
-Provides: bundled(php-bartlett-php-compatinfo-db) = 4.3.0
+Provides: bundled(php-bartlett-php-compatinfo-db) = 4.6.1
Provides: bundled(php-nikic-php-parser) = v4.15.1
# License MIT
Provides: bundled(php-bartlett-sarif-php-sdk) = 1.0.1
@@ -64,37 +65,37 @@ Provides: bundled(php-brick-math) = 0.9.3
Provides: bundled(php-composer-semver) = 3.3.2
Provides: bundled(php-doctrine-annotations) = 1.13.3
Provides: bundled(php-doctrine-cache) = 2.2.0
-Provides: bundled(php-doctrine-collections) = 1.7.3
-Provides: bundled(php-doctrine-common) = 3.4.1
-Provides: bundled(php-doctrine-dbal) = 3.4.5
+Provides: bundled(php-doctrine-collections) = 1.8.0
+Provides: bundled(php-doctrine-common) = 3.4.3
+Provides: bundled(php-doctrine-dbal) = 3.5.1
Provides: bundled(php-doctrine-deprecations) = v1.0.0
-Provides: bundled(php-doctrine-event-manager) = 1.1.2
-Provides: bundled(php-doctrine-inflector) = 2.0.5
+Provides: bundled(php-doctrine-event-manager) = 1.2.0
+Provides: bundled(php-doctrine-inflector) = 2.0.6
Provides: bundled(php-doctrine-instantiator) = 1.4.1
Provides: bundled(php-doctrine-lexer) = 1.2.3
-Provides: bundled(php-doctrine-orm) = 2.13.2
-Provides: bundled(php-doctrine-persistence) = 3.0.3
+Provides: bundled(php-doctrine-orm) = 2.13.3
+Provides: bundled(php-doctrine-persistence) = 3.0.4
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-ramsey-collection) = 1.2.2
Provides: bundled(php-ramsey-uuid) = 4.2.3
-Provides: bundled(php-symfony-amqp-messenger) = v5.4.11
-Provides: bundled(php-symfony-cache) = v5.4.11
+Provides: bundled(php-symfony-amqp-messenger) = v5.4.13
+Provides: bundled(php-symfony-cache) = v5.4.13
Provides: bundled(php-symfony-cache-contracts) = v2.5.2
Provides: bundled(php-symfony-config) = v5.4.11
-Provides: bundled(php-symfony-console) = v5.4.12
-Provides: bundled(php-symfony-dependency-injection) = v5.4.11
+Provides: bundled(php-symfony-console) = v5.4.14
+Provides: bundled(php-symfony-dependency-injection) = v5.4.13
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-doctrine-messenger) = v5.4.12
Provides: bundled(php-symfony-event-dispatcher) = v5.4.9
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.12
+Provides: bundled(php-symfony-filesystem) = v5.4.13
Provides: bundled(php-symfony-finder) = v5.4.11
-Provides: bundled(php-symfony-http-client) = v5.4.12
+Provides: bundled(php-symfony-http-client) = v5.4.14
Provides: bundled(php-symfony-http-client-contracts) = v2.5.2
-Provides: bundled(php-symfony-messenger) = v5.4.11
+Provides: bundled(php-symfony-messenger) = v5.4.14
Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.26.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.26.0
@@ -104,12 +105,12 @@ Provides: bundled(php-symfony-polyfill-php73) = v1.26.0
Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
Provides: bundled(php-symfony-polyfill-php81) = v1.26.0
Provides: bundled(php-symfony-process) = v5.4.11
-Provides: bundled(php-symfony-redis-messenger) = v5.4.6
+Provides: bundled(php-symfony-redis-messenger) = v5.4.13
Provides: bundled(php-symfony-requirements-checker) = v2.0.1
-Provides: bundled(php-symfony-serializer) = v5.4.12
+Provides: bundled(php-symfony-serializer) = v5.4.14
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-stopwatch) = v5.4.5
-Provides: bundled(php-symfony-string) = v5.4.12
+Provides: bundled(php-symfony-stopwatch) = v5.4.13
+Provides: bundled(php-symfony-string) = v5.4.14
Provides: bundled(php-symfony-var-exporter) = v5.4.10
Provides: phpcompatinfo = %{version}
@@ -144,22 +145,22 @@ rm -r tests
: List bundled libraries and Licenses
php -r '
- $pkgs = file_get_contents("vendor/composer/installed.json");
- $pkgs = json_decode($pkgs, true);
- if (!is_array($pkgs) || !isset($pkgs["packages"])) {
+ $pkgs = file_get_contents("vendor/composer/installed.json");
+ $pkgs = json_decode($pkgs, true);
+ if (!is_array($pkgs) || !isset($pkgs["packages"])) {
echo "cant decode json file\n";
- exit(3);
- }
- $res = [];
+ exit(3);
+ }
+ $res = [];
foreach($pkgs["packages"] as $pkg) {
- $lic = implode(" and ", $pkg["license"]);
- if (!isset($res[$lic])) $res[$lic] = [];
- $res[$lic][] = sprintf("Provides: bundled(php-%s) = %s", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
- }
- foreach($res as $lic => $lib) {
- sort($lib);
- printf("# License %s\n%s\n", $lic, implode("\n", $lib));
- }
+ $lic = implode(" and ", $pkg["license"]);
+ if (!isset($res[$lic])) $res[$lic] = [];
+ $res[$lic][] = sprintf("Provides: bundled(php-%s) = %s", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
+ }
+ foreach($res as $lic => $lib) {
+ sort($lib);
+ printf("# License %s\n%s\n", $lic, implode("\n", $lib));
+ }
'
%build
@@ -198,6 +199,15 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}/fedora-
%changelog
+* Tue Oct 25 2022 Remi Collet <remi@remirepo.net> - 6.5.2-1
+- update to 6.5.2
+
+* Mon Oct 24 2022 Remi Collet <remi@remirepo.net> - 6.5.1-1
+- update to 6.5.1
+
+* Mon Oct 24 2022 Remi Collet <remi@remirepo.net> - 6.5.0-1
+- update to 6.5.0
+
* Tue Sep 27 2022 Remi Collet <remi@remirepo.net> - 6.4.2-1
- update to 6.4.2