summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json9
-rw-r--r--installed.json116
-rwxr-xr-xmakesrc.sh4
-rw-r--r--php-bartlett-PHP-CompatInfo.spec29
4 files changed, 82 insertions, 76 deletions
diff --git a/composer.json b/composer.json
index 5aee5c7..2ba23ca 100644
--- a/composer.json
+++ b/composer.json
@@ -4,10 +4,10 @@
"keywords": ["compatibility", "version"],
"type": "library",
"license": "BSD-3-Clause",
- "homepage": "http://php5.laurent-laville.org/compatinfo/",
+ "homepage": "https://github.com/llaville/php-compatinfo",
"support": {
- "source": "https://github.com/llaville/php-compat-info",
- "issues": "https://github.com/llaville/php-compat-info/issues"
+ "source": "https://github.com/llaville/php-compatinfo",
+ "issues": "https://github.com/llaville/php-compatinfo/issues"
},
"require": {
"php": "^7.4|^8.0",
@@ -15,7 +15,7 @@
"ext-libxml": "*",
"ext-pcre": "*",
"ext-spl": "*",
- "bartlett/php-compatinfo-db": "^3.6",
+ "bartlett/php-compatinfo-db": ">=3.6 <3.17",
"composer/package-versions-deprecated": "^1.8",
"doctrine/collections": "^1.4",
"nikic/php-parser": "^4.10",
@@ -36,7 +36,6 @@
"authors": [
{
"name": "Laurent Laville",
- "email": "pear@laurent-laville.org",
"homepage": "https://github.com/llaville",
"role": "Lead"
},
diff --git a/installed.json b/installed.json
index fffb6ae..dbd8f32 100644
--- a/installed.json
+++ b/installed.json
@@ -224,17 +224,17 @@
},
{
"name": "composer/semver",
- "version": "3.2.6",
- "version_normalized": "3.2.6.0",
+ "version": "3.2.7",
+ "version_normalized": "3.2.7.0",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
- "reference": "83e511e247de329283478496f7a1e114c9517506"
+ "reference": "deac27056b57e46faf136fae7b449eeaa71661ee"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/semver/zipball/83e511e247de329283478496f7a1e114c9517506",
- "reference": "83e511e247de329283478496f7a1e114c9517506",
+ "url": "https://api.github.com/repos/composer/semver/zipball/deac27056b57e46faf136fae7b449eeaa71661ee",
+ "reference": "deac27056b57e46faf136fae7b449eeaa71661ee",
"shasum": ""
},
"require": {
@@ -244,7 +244,7 @@
"phpstan/phpstan": "^0.12.54",
"symfony/phpunit-bridge": "^4.2 || ^5"
},
- "time": "2021-10-25T11:34:17+00:00",
+ "time": "2022-01-04T09:57:54+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -288,7 +288,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/semver/issues",
- "source": "https://github.com/composer/semver/tree/3.2.6"
+ "source": "https://github.com/composer/semver/tree/3.2.7"
},
"funding": [
{
@@ -2869,26 +2869,29 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.23.0",
- "version_normalized": "1.23.0.0",
+ "version": "v1.24.0",
+ "version_normalized": "1.24.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
- "reference": "46cd95797e9df938fdd2b03693b5fca5e64b01ce"
+ "reference": "30885182c981ab175d4d034db0f6f469898070ab"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/46cd95797e9df938fdd2b03693b5fca5e64b01ce",
- "reference": "46cd95797e9df938fdd2b03693b5fca5e64b01ce",
+ "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/30885182c981ab175d4d034db0f6f469898070ab",
+ "reference": "30885182c981ab175d4d034db0f6f469898070ab",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
+ "provide": {
+ "ext-ctype": "*"
+ },
"suggest": {
"ext-ctype": "For best performance"
},
- "time": "2021-02-19T12:13:01+00:00",
+ "time": "2021-10-20T20:35:02+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -2931,7 +2934,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.23.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.24.0"
},
"funding": [
{
@@ -2951,17 +2954,17 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.23.1",
- "version_normalized": "1.23.1.0",
+ "version": "v1.24.0",
+ "version_normalized": "1.24.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
- "reference": "16880ba9c5ebe3642d1995ab866db29270b36535"
+ "reference": "81b86b50cf841a64252b439e738e97f4a34e2783"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/16880ba9c5ebe3642d1995ab866db29270b36535",
- "reference": "16880ba9c5ebe3642d1995ab866db29270b36535",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/81b86b50cf841a64252b439e738e97f4a34e2783",
+ "reference": "81b86b50cf841a64252b439e738e97f4a34e2783",
"shasum": ""
},
"require": {
@@ -2970,7 +2973,7 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2021-05-27T12:26:48+00:00",
+ "time": "2021-11-23T21:10:46+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -3015,7 +3018,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.23.1"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.24.0"
},
"funding": [
{
@@ -3035,8 +3038,8 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.23.0",
- "version_normalized": "1.23.0.0",
+ "version": "v1.24.0",
+ "version_normalized": "1.24.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
@@ -3102,7 +3105,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.23.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.24.0"
},
"funding": [
{
@@ -3122,26 +3125,29 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.23.1",
- "version_normalized": "1.23.1.0",
+ "version": "v1.24.0",
+ "version_normalized": "1.24.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "9174a3d80210dca8daa7f31fec659150bbeabfc6"
+ "reference": "0abb51d2f102e00a4eefcf46ba7fec406d245825"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/9174a3d80210dca8daa7f31fec659150bbeabfc6",
- "reference": "9174a3d80210dca8daa7f31fec659150bbeabfc6",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/0abb51d2f102e00a4eefcf46ba7fec406d245825",
+ "reference": "0abb51d2f102e00a4eefcf46ba7fec406d245825",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
+ "provide": {
+ "ext-mbstring": "*"
+ },
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2021-05-27T12:26:48+00:00",
+ "time": "2021-11-30T18:21:41+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -3185,7 +3191,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.23.1"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.24.0"
},
"funding": [
{
@@ -3205,8 +3211,8 @@
},
{
"name": "symfony/polyfill-php72",
- "version": "v1.23.0",
- "version_normalized": "1.23.0.0",
+ "version": "v1.24.0",
+ "version_normalized": "1.24.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php72.git",
@@ -3264,7 +3270,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php72/tree/v1.23.0"
+ "source": "https://github.com/symfony/polyfill-php72/tree/v1.24.0"
},
"funding": [
{
@@ -3284,23 +3290,23 @@
},
{
"name": "symfony/polyfill-php73",
- "version": "v1.23.0",
- "version_normalized": "1.23.0.0",
+ "version": "v1.24.0",
+ "version_normalized": "1.24.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php73.git",
- "reference": "fba8933c384d6476ab14fb7b8526e5287ca7e010"
+ "reference": "cc5db0e22b3cb4111010e48785a97f670b350ca5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/fba8933c384d6476ab14fb7b8526e5287ca7e010",
- "reference": "fba8933c384d6476ab14fb7b8526e5287ca7e010",
+ "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/cc5db0e22b3cb4111010e48785a97f670b350ca5",
+ "reference": "cc5db0e22b3cb4111010e48785a97f670b350ca5",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2021-02-19T12:13:01+00:00",
+ "time": "2021-06-05T21:20:04+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -3346,7 +3352,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php73/tree/v1.23.0"
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.24.0"
},
"funding": [
{
@@ -3366,23 +3372,23 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.23.1",
- "version_normalized": "1.23.1.0",
+ "version": "v1.24.0",
+ "version_normalized": "1.24.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "1100343ed1a92e3a38f9ae122fc0eb21602547be"
+ "reference": "57b712b08eddb97c762a8caa32c84e037892d2e9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/1100343ed1a92e3a38f9ae122fc0eb21602547be",
- "reference": "1100343ed1a92e3a38f9ae122fc0eb21602547be",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/57b712b08eddb97c762a8caa32c84e037892d2e9",
+ "reference": "57b712b08eddb97c762a8caa32c84e037892d2e9",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2021-07-28T13:41:28+00:00",
+ "time": "2021-09-13T13:58:33+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -3432,7 +3438,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.23.1"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.24.0"
},
"funding": [
{
@@ -3452,23 +3458,23 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.23.0",
- "version_normalized": "1.23.0.0",
+ "version": "v1.24.0",
+ "version_normalized": "1.24.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
- "reference": "e66119f3de95efc359483f810c4c3e6436279436"
+ "reference": "5de4ba2d41b15f9bd0e19b2ab9674135813ec98f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/e66119f3de95efc359483f810c4c3e6436279436",
- "reference": "e66119f3de95efc359483f810c4c3e6436279436",
+ "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/5de4ba2d41b15f9bd0e19b2ab9674135813ec98f",
+ "reference": "5de4ba2d41b15f9bd0e19b2ab9674135813ec98f",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2021-05-21T13:25:03+00:00",
+ "time": "2021-09-13T13:58:11+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -3514,7 +3520,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.23.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.24.0"
},
"funding": [
{
diff --git a/makesrc.sh b/makesrc.sh
index 327123d..c0e118c 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -16,10 +16,10 @@ echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT || exit 1
- cp
+ cp composer.json vendor/composer/installed.json ../
+ sed -e 's/"config": {/"config": {"platform": {"php": "7.4.0"},/' -i composer.json
composer install --no-dev --optimize-autoloader
- cp composer.json vendor/composer/installed.json ../
mkdir data
cp ${HOME}/.cache/bartlett/compatinfo-db.sqlite data
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index e64ff3f..879a544 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,13 +11,13 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 4beab5e0a5c27fb81a3ba0b262b3ed85a19500be
+%global gh_commit 7f878c7b534f3c4bb4d2200267678d53324b5d08
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
%global gh_project php-compatinfo
-%global upstream_version 6.0.2
+%global upstream_version 6.0.3
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
@@ -26,7 +26,7 @@ Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
License: BSD and MIT
-URL: https://llaville.github.io/php-compatinfo/
+URL: https://github.com/llaville/php-compatinfo
Source0: %{name}-%{version}-%{gh_short}.tgz
# Script for fedora-review
Source1: fedora-review-check
@@ -67,7 +67,7 @@ Requires: php-xmlreader
Provides: bundled(php-bartlett-php-compatinfo-db) = 3.16.1
Provides: bundled(php-brick-math) = 0.9.3
Provides: bundled(php-composer-package-versions-deprecated) = 1.11.99.4
-Provides: bundled(php-composer-semver) = 3.2.6
+Provides: bundled(php-composer-semver) = 3.2.7
Provides: bundled(php-doctrine-annotations) = 1.13.2
Provides: bundled(php-doctrine-cache) = 2.1.1
Provides: bundled(php-doctrine-collections) = 1.6.8
@@ -100,14 +100,14 @@ Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.0.0
Provides: bundled(php-symfony-filesystem) = v6.0.0
Provides: bundled(php-symfony-finder) = v5.4.2
Provides: bundled(php-symfony-messenger) = v5.4.2
-Provides: bundled(php-symfony-polyfill-ctype) = v1.23.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.23.1
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.23.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.23.1
-Provides: bundled(php-symfony-polyfill-php72) = v1.23.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.23.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.23.1
-Provides: bundled(php-symfony-polyfill-php81) = v1.23.0
+Provides: bundled(php-symfony-polyfill-ctype) = v1.24.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.24.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.24.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.24.0
+Provides: bundled(php-symfony-polyfill-php72) = v1.24.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.24.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.24.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.24.0
Provides: bundled(php-symfony-process) = v5.4.2
Provides: bundled(php-symfony-redis-messenger) = v6.0.2
Provides: bundled(php-symfony-requirements-checker) = v2.0.1
@@ -127,8 +127,6 @@ version and extensions required for it to run. CLI version has many reports
(extension, interface, class, function, constant) to display and ability to
show content of dictionary references.
-Documentation: http://php5.laurent-laville.org/compatinfo/manual/current/en/
-
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -180,6 +178,9 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}/fedora-
%changelog
+* Wed Jan 5 2022 Remi Collet <remi@remirepo.net> - 6.0.3-1
+- update to 6.0.3
+
* Mon Jan 3 2022 Remi Collet <remi@remirepo.net> - 6.0.2-1
- update to 6.0.2