summaryrefslogtreecommitdiffstats
path: root/php-bartlett-PHP-CompatInfo.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-15 09:37:59 +0100
committerRemi Collet <remi@remirepo.net>2021-03-15 09:37:59 +0100
commitc24a2f097abc2f72b912d611c2cde91728a897d9 (patch)
tree645fee43dc7ca4749cafdfc239b24a37152dea5a /php-bartlett-PHP-CompatInfo.spec
parent9651e41907c0705eb87107a4e7f92098c9e53f09 (diff)
update to 5.5.1
raise dependency on bartlett/php-compatinfo-db 3.4
Diffstat (limited to 'php-bartlett-PHP-CompatInfo.spec')
-rw-r--r--php-bartlett-PHP-CompatInfo.spec41
1 files changed, 20 insertions, 21 deletions
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index a8c5f88..b743d56 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,7 +11,7 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit eee33868bcfb662d55eb7164b9bb749619c8b9d6
+%global gh_commit 38294902ae898ae4d29b300a516474330670f33f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
@@ -19,18 +19,12 @@
#global prever RC2
%bcond_without tests
-%global upstream_version 5.5.0
+%global upstream_version 5.5.1
#global upstream_prever RC1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-%global sym_prefix php-symfony3
-%else
-%global sym_prefix php-symfony
-%endif
-
Name: php-bartlett-PHP-CompatInfo
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 0%{?dist}
+Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
License: BSD
@@ -40,9 +34,9 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Script for fedora-review
Source1: fedora-review-check
-# Autoload and sqlite database path
+# Autoload and config path
# avoid jean85/pretty-package-versions
-Patch0: %{name}-5.5.0-rpm.patch
+Patch0: %{name}-5.5-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.2
@@ -52,7 +46,7 @@ BuildRequires: php-pdo_sqlite
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(bartlett/php-reflect) >= 4.4 with php-composer(bartlett/php-reflect) < 5)
-BuildRequires: (php-composer(bartlett/php-compatinfo-db) >= 3.3 with php-composer(bartlett/php-compatinfo-db) < 4)
+BuildRequires: (php-composer(bartlett/php-compatinfo-db) >= 3.4 with php-composer(bartlett/php-compatinfo-db) < 4)
BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
BuildRequires: (php-composer(ramsey/uuid) >= 4.0 with php-composer(ramsey/uuid) < 5)
BuildRequires: (php-composer(symfony/config) >= 4.4 with php-composer(symfony/config) < 6)
@@ -66,7 +60,7 @@ BuildRequires: (php-composer(doctrine/collections) >= 1.4 with php-comp
# remirepo:14
%else
BuildRequires: php-bartlett-PHP-Reflect >= 4.4
-BuildRequires: php-bartlett-php-compatinfo-db >= 3.3
+BuildRequires: php-bartlett-php-compatinfo-db >= 3.4
BuildRequires: php-PsrLog >= 1.0
BuildRequires: php-ramsey-uuid >= 4.0
BuildRequires: php-symfony4-config >= 4.4
@@ -93,7 +87,7 @@ BuildRequires: php-fedora-autoloader-devel
# "ext-pdo": "*",
# "ext-pdo_sqlite": "*",
# "bartlett/php-reflect": "^4.4",
-# "bartlett/php-compatinfo-db": "^3.3",
+# "bartlett/php-compatinfo-db": "^3.4",
# "doctrine/collections": "^1.4",
# "composer/package-versions-deprecated": "^1.8",
# "psr/log": "^1.0",
@@ -116,7 +110,7 @@ Requires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(bartlett/php-reflect) >= 4.4 with php-composer(bartlett/php-reflect) < 5)
-Requires: (php-composer(bartlett/php-compatinfo-db) >= 3.3 with php-composer(bartlett/php-compatinfo-db) < 4)
+Requires: (php-composer(bartlett/php-compatinfo-db) >= 3.4 with php-composer(bartlett/php-compatinfo-db) < 4)
Requires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
Requires: (php-composer(ramsey/uuid) >= 4.0 with php-composer(ramsey/uuid) < 5)
Requires: (php-composer(symfony/config) >= 4.4 with php-composer(symfony/config) < 6)
@@ -130,7 +124,7 @@ Requires: (php-composer(doctrine/collections) >= 1.4 with php-comp
# remirepo:14
%else
Requires: php-bartlett-PHP-Reflect >= 4.4
-Requires: php-bartlett-php-compatinfo-db >= 3.3
+Requires: php-bartlett-php-compatinfo-db >= 3.4
Requires: php-PsrLog >= 1.0
Requires: php-ramsey-uuid >= 4.0
Requires: php-symfony4-config >= 4.4
@@ -206,8 +200,6 @@ find src -name \*rpm -delete -print
# fix path in configuration
sed -e 's:src/Bartlett/CompatInfo/::' -i config/set/*php
mv config src/Bartlett/CompatInfo/config
-# for tests
-ln -s src/Bartlett/CompatInfo/config config
# Check package version
FILE=src/Bartlett/CompatInfo/Console/Application.php
@@ -231,13 +223,16 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
%if %{with tests}
%check
-mkdir vendor
-cat << 'EOF' | tee vendor/autoload.php
+mkdir config
+cat << 'EOF' | tee config/bootstrap.php
<?php
-require_once "%{buildroot}%{_datadir}/php/Bartlett/CompatInfo/autoload.php";
+require_once "%{buildroot}%{_datadir}/php/Bartlett/CompatInfo/config/bootstrap.php";
\Fedora\Autoloader\Autoload::addPsr4('Bartlett\\Tests\\CompatInfo\\', dirname(__DIR__) . '/tests');
EOF
+sed -e 's:@BUILDPATH@:%{buildroot}%{_datadir}/php/Bartlett/CompatInfo:' \
+ -i tests/TestCase.php tests/Sniffs/SniffTestCase.php tests/Reference/ParameterTest.php
+
ret=0
for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
@@ -268,6 +263,10 @@ fi
%changelog
+* Mon Mar 15 2021 Remi Collet <remi@remirepo.net> - 5.5.1-1
+- update to 5.5.1
+- raise dependency on bartlett/php-compatinfo-db 3.4
+
* Thu Mar 11 2021 Remi Collet <remi@remirepo.net> - 5.5.0-0
- test build of upcoming 5.5.0
- raise dependency on PHP 7.2