summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-16 07:02:43 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-16 07:02:43 +0100
commiteebc2647f13b06de97644799d2399e7b4c6eda82 (patch)
tree364385f615aca9575ce20991f7ef89f46a05bf36
parent8268e8b14b981b6f97860ab22f97e36bbee5963f (diff)
php-bartlett-PHP-CompatInfo: 5.0.2
-rw-r--r--composer.json2
-rw-r--r--php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch16
-rw-r--r--php-bartlett-PHP-CompatInfo.spec13
3 files changed, 10 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 7bb77fa..10fc491 100644
--- a/composer.json
+++ b/composer.json
@@ -23,7 +23,7 @@
"ext-json": "*",
"ext-pdo_sqlite": "*",
"bartlett/php-reflect": "~4.0",
- "bartlett/php-compatinfo-db": "~1.0"
+ "bartlett/php-compatinfo-db": "~1.15"
},
"require-dev": {
"doctrine/cache": "~1.3",
diff --git a/php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch b/php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch
index ed5eed3..55a4c09 100644
--- a/php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch
+++ b/php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch
@@ -82,18 +82,4 @@ diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
-$application = new Application($appName, '5.0');
+$application = new Application($appName, '@package_version@');
$application->run();
-diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./src/Bartlett/CompatInfo/Console/Application.php.rpm 2016-03-09 18:38:00.713180108 +0100
-+++ ./src/Bartlett/CompatInfo/Console/Application.php 2016-03-09 18:36:09.737741387 +0100
-@@ -52,9 +52,10 @@
- $v = Environment::versionRefDb();
-
- return sprintf(
-- '<info>%s</info> version <comment>%s</comment> DB built <comment>%s</comment>',
-+ '<info>%s</info> version <comment>%s</comment> DB version <comment>%s</comment> built <comment>%s</comment>',
- $this->getName(),
- $this->getVersion(),
-+ $v['build.version'],
- $v['build.string']
- );
- }
+
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index de9fc40..89e43e7 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 300a1689891aa97a6733ef496081ec394f53486b
+%global gh_commit 49d67523234b35697a0b5b6b2dd8e9b6a23f44cb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
@@ -16,8 +16,8 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-bartlett-PHP-CompatInfo
-Version: 5.0.1
-%global specrel 2
+Version: 5.0.2
+%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -42,7 +42,7 @@ BuildRequires: php(language) >= 5.4.0
BuildRequires: %{_bindir}/phpunit
BuildRequires: php-pdo_sqlite
BuildRequires: php-composer(bartlett/php-reflect) >= 4.0
-BuildRequires: php-composer(bartlett/php-compatinfo-db) >= 1.0
+BuildRequires: php-composer(bartlett/php-compatinfo-db) >= 1.15
# For our patch / autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
@@ -66,7 +66,7 @@ Requires: php-pdo_sqlite
Requires: php-spl
Requires: php-composer(bartlett/php-reflect) >= 4.0
Requires: php-composer(bartlett/php-reflect) < 5
-Requires: php-composer(bartlett/php-compatinfo-db) >= 1.0
+Requires: php-composer(bartlett/php-compatinfo-db) >= 1.15
Requires: php-composer(bartlett/php-compatinfo-db) < 2
Requires: php-composer(symfony/console) >= 2.5
Requires: php-composer(symfony/console) < 3
@@ -177,6 +177,9 @@ fi
%changelog
+* Fri Dec 16 2016 Remi Collet <remi@fedoraproject.org> - 5.0.2-1
+- update to 5.0.2
+
* Mon Oct 31 2016 Remi Collet <remi@fedoraproject.org> - 5.0.1-2
- switch to fedora/autoloader