summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-10 16:32:33 +0100
committerRemi Collet <remi@php.net>2021-12-10 16:32:33 +0100
commit8f81c5eb651757303fd68cd6c3aca1ea00c2b3a6 (patch)
tree85de876783b65258f0ead2c23793aafd1a2c49e6
parent91c97d26de6d18c3b52a97ef8360335a948e64e7 (diff)
update to 5.5.4
raise dependency on bartlett/php-compatinfo-db 3.6
-rw-r--r--composer.json2
-rw-r--r--php-bartlett-PHP-CompatInfo-5.5.4-rpm.patch (renamed from php-bartlett-PHP-CompatInfo-5.5.2-rpm.patch)32
-rw-r--r--php-bartlett-PHP-CompatInfo.spec22
3 files changed, 30 insertions, 26 deletions
diff --git a/composer.json b/composer.json
index ff46137..0d87468 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"ext-pdo": "*",
"ext-pdo_sqlite": "*",
"bartlett/php-reflect": "^4.4",
- "bartlett/php-compatinfo-db": "^3.4",
+ "bartlett/php-compatinfo-db": "^3.6",
"doctrine/collections": "^1.4",
"composer/package-versions-deprecated": "^1.8",
"psr/log": "^1.0",
diff --git a/php-bartlett-PHP-CompatInfo-5.5.2-rpm.patch b/php-bartlett-PHP-CompatInfo-5.5.4-rpm.patch
index 0ada6f5..80e3196 100644
--- a/php-bartlett-PHP-CompatInfo-5.5.2-rpm.patch
+++ b/php-bartlett-PHP-CompatInfo-5.5.4-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
---- ./bin/phpcompatinfo.rpm 2021-04-12 09:54:09.000000000 +0200
-+++ ./bin/phpcompatinfo 2021-04-13 10:41:27.780928446 +0200
+--- ./bin/phpcompatinfo.rpm 2021-12-10 15:36:22.000000000 +0100
++++ ./bin/phpcompatinfo 2021-12-10 16:26:30.756115071 +0100
@@ -8,12 +8,12 @@ if (PHP_SAPI !== 'cli') {
gc_disable(); // performance boost
@@ -17,8 +17,8 @@ diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
$app = $container->get(ApplicationInterface::class);
$app->setContainer($container);
diff -up ./config/bootstrap.php.rpm ./config/bootstrap.php
---- ./config/bootstrap.php.rpm 2021-04-12 09:54:09.000000000 +0200
-+++ ./config/bootstrap.php 2021-04-13 10:41:27.780928446 +0200
+--- ./config/bootstrap.php.rpm 2021-12-10 15:36:22.000000000 +0100
++++ ./config/bootstrap.php 2021-12-10 16:26:30.757115067 +0100
@@ -6,6 +6,8 @@ if (\Phar::running()) {
];
} else {
@@ -29,20 +29,20 @@ diff -up ./config/bootstrap.php.rpm ./config/bootstrap.php
__DIR__ . '/../vendor/autoload.php',
// dependency
diff -up ./config/set/default.php.rpm ./config/set/default.php
---- ./config/set/default.php.rpm 2021-04-12 09:54:09.000000000 +0200
-+++ ./config/set/default.php 2021-04-13 10:41:27.780928446 +0200
-@@ -33,7 +33,7 @@ use function Symfony\Component\Dependenc
+--- ./config/set/default.php.rpm 2021-12-10 16:26:30.757115067 +0100
++++ ./config/set/default.php 2021-12-10 16:28:22.196710654 +0100
+@@ -32,7 +32,7 @@ use function Symfony\Component\Dependenc
+ * @return void
*/
- return static function (ContainerConfigurator $containerConfigurator): void
- {
-- $containerConfigurator->import(dirname(__DIR__,2) . '/vendor/bartlett/php-compatinfo-db/config/set/default.php');
+ return static function (ContainerConfigurator $containerConfigurator): void {
+- $containerConfigurator->import(dirname(__DIR__, 2) . '/vendor/bartlett/php-compatinfo-db/config/set/default.php');
+ $containerConfigurator->import('/usr/share/php/Bartlett/CompatInfoDb/config/set/default.php');
$containerConfigurator->import(__DIR__ . '/common.php');
$parameters = $containerConfigurator->parameters();
diff -up ./src/Bartlett/CompatInfo/Console/Application.php.rpm ./src/Bartlett/CompatInfo/Console/Application.php
---- ./src/Bartlett/CompatInfo/Console/Application.php.rpm 2021-04-12 09:54:09.000000000 +0200
-+++ ./src/Bartlett/CompatInfo/Console/Application.php 2021-04-13 10:41:27.780928446 +0200
+--- ./src/Bartlett/CompatInfo/Console/Application.php.rpm 2021-12-10 15:36:22.000000000 +0100
++++ ./src/Bartlett/CompatInfo/Console/Application.php 2021-12-10 16:26:30.757115067 +0100
@@ -30,8 +30,6 @@ use Symfony\Component\DependencyInjectio
use Symfony\Component\EventDispatcher\EventDispatcher;
use Symfony\Component\EventDispatcher\EventDispatcherInterface ;
@@ -68,8 +68,8 @@ diff -up ./src/Bartlett/CompatInfo/Console/Application.php.rpm ./src/Bartlett/Co
parent::__construct(self::NAME, $version);
diff -up ./tests/Reference/ParameterTest.php.rpm ./tests/Reference/ParameterTest.php
---- ./tests/Reference/ParameterTest.php.rpm 2021-04-12 09:54:09.000000000 +0200
-+++ ./tests/Reference/ParameterTest.php 2021-04-13 10:41:27.780928446 +0200
+--- ./tests/Reference/ParameterTest.php.rpm 2021-12-10 15:36:22.000000000 +0100
++++ ./tests/Reference/ParameterTest.php 2021-12-10 16:26:30.757115067 +0100
@@ -42,7 +42,7 @@ final class ParameterTest extends SniffT
*/
public function functionProvider()
@@ -80,8 +80,8 @@ diff -up ./tests/Reference/ParameterTest.php.rpm ./tests/Reference/ParameterTest
$functions = [];
foreach ($repository->getAll() as $function) {
diff -up ./tests/TestCase.php.rpm ./tests/TestCase.php
---- ./tests/TestCase.php.rpm 2021-04-13 10:41:27.780928446 +0200
-+++ ./tests/TestCase.php 2021-04-13 10:43:04.778512016 +0200
+--- ./tests/TestCase.php.rpm 2021-12-10 15:36:22.000000000 +0100
++++ ./tests/TestCase.php 2021-12-10 16:26:30.757115067 +0100
@@ -46,7 +46,7 @@ abstract class TestCase extends \PHPUnit
*/
protected function executeAnalysis(string $dataSource): array
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 85cfcff..7d990d8 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,15 +11,15 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 7353738b51e38b0763e2bf154d05c55ad2fdc105
+%global gh_commit e3b01295c0c46c3b751ef4a01dc41ad696815bc6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
-%global gh_project php-compat-info
+%global gh_project php-compatinfo
#global prever RC2
%bcond_without tests
-%global upstream_version 5.5.3
+%global upstream_version 5.5.4
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
@@ -36,7 +36,7 @@ Source1: fedora-review-check
# Autoload and config path
# avoid jean85/pretty-package-versions
-Patch0: %{name}-5.5.2-rpm.patch
+Patch0: %{name}-5.5.4-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.2
@@ -87,7 +87,7 @@ BuildRequires: php-fedora-autoloader-devel
# "ext-pdo": "*",
# "ext-pdo_sqlite": "*",
# "bartlett/php-reflect": "^4.4",
-# "bartlett/php-compatinfo-db": "^3.4",
+# "bartlett/php-compatinfo-db": "^3.6",
# "doctrine/collections": "^1.4",
# "composer/package-versions-deprecated": "^1.8",
# "psr/log": "^1.0",
@@ -110,7 +110,7 @@ Requires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(bartlett/php-reflect) >= 4.4 with php-composer(bartlett/php-reflect) < 5)
-Requires: (php-composer(bartlett/php-compatinfo-db) >= 3.4 with php-composer(bartlett/php-compatinfo-db) < 4)
+Requires: (php-composer(bartlett/php-compatinfo-db) >= 3.6 with php-composer(bartlett/php-compatinfo-db) < 4)
Requires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
Requires: (php-composer(ramsey/uuid) >= 4.0 with php-composer(ramsey/uuid) < 5)
Requires: (php-composer(symfony/config) >= 4.4 with php-composer(symfony/config) < 6)
@@ -124,7 +124,7 @@ Requires: (php-composer(doctrine/collections) >= 1.4 with php-comp
# remirepo:14
%else
Requires: php-bartlett-PHP-Reflect >= 4.4
-Requires: php-bartlett-php-compatinfo-db >= 3.4
+Requires: php-bartlett-php-compatinfo-db >= 3.6
Requires: php-PsrLog >= 1.0
Requires: php-ramsey-uuid >= 4.0
Requires: php-symfony4-config >= 4.4
@@ -203,7 +203,7 @@ mv config src/Bartlett/CompatInfo/config
# Check package version
FILE=src/Bartlett/CompatInfo/Console/Application.php
-sed -e 's/5.5.1/%{version}/' -i $FILE
+#sed -e 's/5.5.1/#{version}/' -i $FILE
grep " VERSION" $FILE
grep %{version} $FILE
@@ -235,7 +235,7 @@ sed -e 's:@BUILDPATH@:%{buildroot}%{_datadir}/php/Bartlett/CompatInfo:' \
-i tests/TestCase.php tests/Sniffs/SniffTestCase.php tests/Reference/ParameterTest.php
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -264,6 +264,10 @@ fi
%changelog
+* Fri Dec 10 2021 Remi Collet <remi@remirepo.net> - 5.5.4-1
+- update to 5.5.4
+- raise dependency on bartlett/php-compatinfo-db 3.6
+
* Mon May 3 2021 Remi Collet <remi@remirepo.net> - 5.5.3-1
- update to 5.5.3