summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-14 16:23:18 +0100
committerRemi Collet <remi@php.net>2023-11-14 16:23:18 +0100
commit32f9735a0ccaa55380d89891c78de157b7a6c161 (patch)
tree4993dff1bde9c993a76ae3ba603d81e6fb7d67bf
parent0cb8ff26f3ee364b31e6cf3cae5ce13f4de5cdee (diff)
update to 7.0.1
update bundled bartlett/php-compatinfo-db to 5.13.0
-rw-r--r--composer.json4
-rw-r--r--installed.json14
-rw-r--r--php-bartlett-PHP-CompatInfo-7.0.0-php83.patch70
-rw-r--r--php-bartlett-PHP-CompatInfo.spec19
4 files changed, 94 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 3444690..a52ece0 100644
--- a/composer.json
+++ b/composer.json
@@ -10,11 +10,11 @@
"issues": "https://github.com/llaville/php-compatinfo/issues"
},
"require": {
- "php": "^8.0",
+ "php": "~8.0 || ~8.1 || ~8.2",
"ext-json": "*",
"ext-pcre": "*",
"ext-spl": "*",
- "bartlett/php-compatinfo-db": "^5.0",
+ "bartlett/php-compatinfo-db": "^5.12",
"bartlett/sarif-php-sdk": "^1.0",
"composer-runtime-api": "^2.1",
"doctrine/collections": "^1.4",
diff --git a/installed.json b/installed.json
index afd81e5..0fb6d09 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "bartlett/php-compatinfo-db",
- "version": "5.12.0",
- "version_normalized": "5.12.0.0",
+ "version": "5.13.0",
+ "version_normalized": "5.13.0.0",
"source": {
"type": "git",
"url": "https://github.com/llaville/php-compatinfo-db.git",
- "reference": "7435f3757390e422f7bdc7a78d805173a2676732"
+ "reference": "6f6114c1ca1afbf5aabd8727d48125db6741fd79"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/llaville/php-compatinfo-db/zipball/7435f3757390e422f7bdc7a78d805173a2676732",
- "reference": "7435f3757390e422f7bdc7a78d805173a2676732",
+ "url": "https://api.github.com/repos/llaville/php-compatinfo-db/zipball/6f6114c1ca1afbf5aabd8727d48125db6741fd79",
+ "reference": "6f6114c1ca1afbf5aabd8727d48125db6741fd79",
"shasum": ""
},
"require": {
@@ -26,7 +26,7 @@
"ext-pdo": "*",
"ext-phar": "*",
"ext-spl": "*",
- "php": "^8.0",
+ "php": "~8.0 || ~8.1 || ~8.2",
"symfony/cache": "^5.4 || ^6.0",
"symfony/config": "^5.4 || ^6.0",
"symfony/console": "^5.4 || ^6.0",
@@ -43,7 +43,7 @@
"psr/log": "^1.0 || ^3.0",
"symfony/framework-bundle": "^5.4 || ^6.0"
},
- "time": "2023-11-10T13:23:40+00:00",
+ "time": "2023-11-13T15:55:54+00:00",
"bin": [
"bin/compatinfo-db"
],
diff --git a/php-bartlett-PHP-CompatInfo-7.0.0-php83.patch b/php-bartlett-PHP-CompatInfo-7.0.0-php83.patch
new file mode 100644
index 0000000..eeb3b98
--- /dev/null
+++ b/php-bartlett-PHP-CompatInfo-7.0.0-php83.patch
@@ -0,0 +1,70 @@
+From bc069b672d65748fdc257e23c667310946e7837e Mon Sep 17 00:00:00 2001
+From: Laurent Laville <laurent.laville@gmail.com>
+Date: Thu, 2 Nov 2023 06:52:05 +0000
+Subject: [PATCH] initialize PHP 8.3 support
+
+---
+ composer.json | 2 +-
+ config/set/php83.php | 18 ++++++++++++++++++
+ config/set/up-to-php83.php | 14 ++++++++++++++
+ 3 files changed, 33 insertions(+), 1 deletion(-)
+ create mode 100644 config/set/php83.php
+ create mode 100644 config/set/up-to-php83.php
+
+diff --git a/composer.json b/composer.json
+index 34446906..9afc85cd 100644
+--- a/composer.json
++++ b/composer.json
+@@ -70,7 +70,7 @@
+ "extra": {
+ "enable-patching": true,
+ "branch-alias": {
+- "dev-master": "7.0.x-dev"
++ "dev-master": "8.0.x-dev"
+ }
+ }
+ }
+diff --git a/config/set/php83.php b/config/set/php83.php
+new file mode 100644
+index 00000000..32531fb1
+--- /dev/null
++++ b/config/set/php83.php
+@@ -0,0 +1,18 @@
++<?php declare(strict_types=1);
++/**
++ * This file is part of the PHP_CompatInfo package.
++ *
++ * For the full copyright and license information, please view the LICENSE
++ * file that was distributed with this source code.
++ */
++
++use Symfony\Component\DependencyInjection\Loader\Configurator\ContainerConfigurator;
++
++/**
++ * Build the Container with PHP 8.3 features detection
++ *
++ * @author Laurent Laville
++ * @since Release 8.0.0
++ */
++return static function (ContainerConfigurator $containerConfigurator): void {
++};
+diff --git a/config/set/up-to-php83.php b/config/set/up-to-php83.php
+new file mode 100644
+index 00000000..8a496337
+--- /dev/null
++++ b/config/set/up-to-php83.php
+@@ -0,0 +1,14 @@
++<?php declare(strict_types=1);
++/**
++ * Build the Container with PHP features detection up to version 8.3
++ *
++ * @author Laurent Laville
++ * @since Release 8.0.0
++ */
++
++use Symfony\Component\DependencyInjection\Loader\Configurator\ContainerConfigurator;
++
++return static function (ContainerConfigurator $containerConfigurator): void {
++ $containerConfigurator->import(__DIR__ . '/up-to-php82.php');
++ $containerConfigurator->import(__DIR__ . '/php83.php');
++};
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index f3ea6c6..eb249ef 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,18 +11,18 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 7b053000a684d1fa3840e0ab3c5833fecdf02dc3
+%global gh_commit c94491403ade577b5a1d6f0a460339394e039f3c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
%global gh_project php-compatinfo
-%global upstream_version 7.0.0
+%global upstream_version 7.0.1
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 3%{?dist}
+Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
# SPDX: see bundled libraries list below
@@ -36,6 +36,8 @@ Source9: makesrc.sh
# Relocate the database
Patch0: %{name}-6.0.0-rpm.patch
+# Allow PHP 8.3
+Patch1: %{name}-7.0.0-php83.patch
BuildArch: noarch
BuildRequires: php(language) >= 8.0
@@ -57,7 +59,7 @@ Requires: php-xmlreader
# Bundled libraries
# License BSD-3-Clause
-Provides: bundled(php-bartlett-php-compatinfo-db) = 5.12.0
+Provides: bundled(php-bartlett-php-compatinfo-db) = 5.13.0
Provides: bundled(php-nikic-php-parser) = v4.17.1
# License MIT
Provides: bundled(php-bartlett-sarif-php-sdk) = 1.0.1
@@ -123,6 +125,7 @@ show content of dictionary references.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
%patch -P0 -p1 -b .rpm
+%patch -P1 -p1
# https://github.com/llaville/php-compatinfo-db/issues/112
sed -e 's/touch/@touch/' -i vendor/bartlett/php-compatinfo-db/config/set/default.php
@@ -199,6 +202,14 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}/fedora-
%changelog
+* Tue Nov 14 2023 Remi Collet <remi@remirepo.net> - 7.0.1-1
+- update to 7.0.1
+- update bundled bartlett/php-compatinfo-db to 5.13.0
+
+* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 7.0.0-4
+- add missing file for PHP 8.3 reported as
+ https://github.com/llaville/php-compatinfo/issues/364
+
* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 7.0.0-3
- update bundled bartlett/php-compatinfo-db to 5.12.0