summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-19 12:59:00 +0100
committerRemi Collet <remi@php.net>2024-03-19 12:59:00 +0100
commitb42b4d80e9196e4299233a6c3002ee3d2638ea8a (patch)
tree83c9f85dc21c22d64b59432bb223c338518a0dd4
parent37c1fdaa9d796e8e000a9ab9475c5bb7585c98c0 (diff)
update to 7.1.3HEADmaster
update bundled bartlett/php-compatinfo-db to 6.4.2
-rw-r--r--composer.json2
-rw-r--r--installed.json244
-rw-r--r--php-bartlett-PHP-CompatInfo.spec44
3 files changed, 147 insertions, 143 deletions
diff --git a/composer.json b/composer.json
index 05a38d9..08a9f56 100644
--- a/composer.json
+++ b/composer.json
@@ -14,7 +14,7 @@
"ext-json": "*",
"ext-pcre": "*",
"ext-spl": "*",
- "bartlett/php-compatinfo-db": "^5.12 || ^6.0",
+ "bartlett/php-compatinfo-db": "^5.12 || ^6.4.2",
"bartlett/sarif-php-sdk": "^1.0",
"composer-runtime-api": "^2.1",
"doctrine/collections": "^1.4",
diff --git a/installed.json b/installed.json
index d72d2fd..b2d9380 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "bartlett/php-compatinfo-db",
- "version": "6.2.1",
- "version_normalized": "6.2.1.0",
+ "version": "6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/llaville/php-compatinfo-db.git",
- "reference": "9e9f934e14392ec4fcb0c46af1caa673b0ea0c65"
+ "reference": "82c3db7be34269ef6ae6c819037a2b0da988d447"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/llaville/php-compatinfo-db/zipball/9e9f934e14392ec4fcb0c46af1caa673b0ea0c65",
- "reference": "9e9f934e14392ec4fcb0c46af1caa673b0ea0c65",
+ "url": "https://api.github.com/repos/llaville/php-compatinfo-db/zipball/82c3db7be34269ef6ae6c819037a2b0da988d447",
+ "reference": "82c3db7be34269ef6ae6c819037a2b0da988d447",
"shasum": ""
},
"require": {
@@ -42,7 +42,7 @@
"psr/log": "^3.0",
"symfony/framework-bundle": "^6.4 || ^7.0"
},
- "time": "2024-02-08T05:35:39+00:00",
+ "time": "2024-03-19T06:38:13+00:00",
"bin": [
"bin/compatinfo-db"
],
@@ -559,17 +559,17 @@
},
{
"name": "doctrine/dbal",
- "version": "3.8.1",
- "version_normalized": "3.8.1.0",
+ "version": "3.8.3",
+ "version_normalized": "3.8.3.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/dbal.git",
- "reference": "c9ea252cdce4da324ede3d6c5913dd89f769afd2"
+ "reference": "db922ba9436b7b18a23d1653a0b41ff2369ca41c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/dbal/zipball/c9ea252cdce4da324ede3d6c5913dd89f769afd2",
- "reference": "c9ea252cdce4da324ede3d6c5913dd89f769afd2",
+ "url": "https://api.github.com/repos/doctrine/dbal/zipball/db922ba9436b7b18a23d1653a0b41ff2369ca41c",
+ "reference": "db922ba9436b7b18a23d1653a0b41ff2369ca41c",
"shasum": ""
},
"require": {
@@ -585,12 +585,12 @@
"doctrine/coding-standard": "12.0.0",
"fig/log-test": "^1",
"jetbrains/phpstorm-stubs": "2023.1",
- "phpstan/phpstan": "1.10.57",
+ "phpstan/phpstan": "1.10.58",
"phpstan/phpstan-strict-rules": "^1.5",
"phpunit/phpunit": "9.6.16",
"psalm/plugin-phpunit": "0.18.4",
"slevomat/coding-standard": "8.13.1",
- "squizlabs/php_codesniffer": "3.8.1",
+ "squizlabs/php_codesniffer": "3.9.0",
"symfony/cache": "^5.4|^6.0|^7.0",
"symfony/console": "^4.4|^5.4|^6.0|^7.0",
"vimeo/psalm": "4.30.0"
@@ -598,7 +598,7 @@
"suggest": {
"symfony/console": "For helpful console commands such as SQL execution and import of files."
},
- "time": "2024-02-03T17:33:49+00:00",
+ "time": "2024-03-03T15:55:06+00:00",
"bin": [
"bin/doctrine-dbal"
],
@@ -655,7 +655,7 @@
],
"support": {
"issues": "https://github.com/doctrine/dbal/issues",
- "source": "https://github.com/doctrine/dbal/tree/3.8.1"
+ "source": "https://github.com/doctrine/dbal/tree/3.8.3"
},
"funding": [
{
@@ -819,17 +819,17 @@
},
{
"name": "doctrine/inflector",
- "version": "2.0.9",
- "version_normalized": "2.0.9.0",
+ "version": "2.0.10",
+ "version_normalized": "2.0.10.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/inflector.git",
- "reference": "2930cd5ef353871c821d5c43ed030d39ac8cfe65"
+ "reference": "5817d0659c5b50c9b950feb9af7b9668e2c436bc"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/inflector/zipball/2930cd5ef353871c821d5c43ed030d39ac8cfe65",
- "reference": "2930cd5ef353871c821d5c43ed030d39ac8cfe65",
+ "url": "https://api.github.com/repos/doctrine/inflector/zipball/5817d0659c5b50c9b950feb9af7b9668e2c436bc",
+ "reference": "5817d0659c5b50c9b950feb9af7b9668e2c436bc",
"shasum": ""
},
"require": {
@@ -843,7 +843,7 @@
"phpunit/phpunit": "^8.5 || ^9.5",
"vimeo/psalm": "^4.25 || ^5.4"
},
- "time": "2024-01-15T18:05:13+00:00",
+ "time": "2024-02-18T20:23:39+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -893,7 +893,7 @@
],
"support": {
"issues": "https://github.com/doctrine/inflector/issues",
- "source": "https://github.com/doctrine/inflector/tree/2.0.9"
+ "source": "https://github.com/doctrine/inflector/tree/2.0.10"
},
"funding": [
{
@@ -1066,17 +1066,17 @@
},
{
"name": "doctrine/orm",
- "version": "2.18.0",
- "version_normalized": "2.18.0.0",
+ "version": "2.19.2",
+ "version_normalized": "2.19.2.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/orm.git",
- "reference": "f2176a9ce56cafdfd1624d54bfdb076819083d5b"
+ "reference": "40a0964f06e142e173b783c45688e5f5efaed6aa"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/orm/zipball/f2176a9ce56cafdfd1624d54bfdb076819083d5b",
- "reference": "f2176a9ce56cafdfd1624d54bfdb076819083d5b",
+ "url": "https://api.github.com/repos/doctrine/orm/zipball/40a0964f06e142e173b783c45688e5f5efaed6aa",
+ "reference": "40a0964f06e142e173b783c45688e5f5efaed6aa",
"shasum": ""
},
"require": {
@@ -1105,21 +1105,21 @@
"doctrine/annotations": "^1.13 || ^2",
"doctrine/coding-standard": "^9.0.2 || ^12.0",
"phpbench/phpbench": "^0.16.10 || ^1.0",
- "phpstan/phpstan": "~1.4.10 || 1.10.35",
+ "phpstan/phpstan": "~1.4.10 || 1.10.59",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.6",
"psr/log": "^1 || ^2 || ^3",
"squizlabs/php_codesniffer": "3.7.2",
"symfony/cache": "^4.4 || ^5.4 || ^6.4 || ^7.0",
"symfony/var-exporter": "^4.4 || ^5.4 || ^6.2 || ^7.0",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0 || ^7.0",
- "vimeo/psalm": "4.30.0 || 5.16.0"
+ "vimeo/psalm": "4.30.0 || 5.22.2"
},
"suggest": {
"ext-dom": "Provides support for XSD validation for XML mapping files",
"symfony/cache": "Provides cache support for Setup Tool with doctrine/cache 2.0",
"symfony/yaml": "If you want to use YAML Metadata Mapping Driver"
},
- "time": "2024-01-31T15:53:12+00:00",
+ "time": "2024-03-18T19:12:56+00:00",
"bin": [
"bin/doctrine"
],
@@ -1164,23 +1164,23 @@
],
"support": {
"issues": "https://github.com/doctrine/orm/issues",
- "source": "https://github.com/doctrine/orm/tree/2.18.0"
+ "source": "https://github.com/doctrine/orm/tree/2.19.2"
},
"install-path": "../doctrine/orm"
},
{
"name": "doctrine/persistence",
- "version": "3.2.0",
- "version_normalized": "3.2.0.0",
+ "version": "3.3.2",
+ "version_normalized": "3.3.2.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/persistence.git",
- "reference": "63fee8c33bef740db6730eb2a750cd3da6495603"
+ "reference": "477da35bd0255e032826f440b94b3e37f2d56f42"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/persistence/zipball/63fee8c33bef740db6730eb2a750cd3da6495603",
- "reference": "63fee8c33bef740db6730eb2a750cd3da6495603",
+ "url": "https://api.github.com/repos/doctrine/persistence/zipball/477da35bd0255e032826f440b94b3e37f2d56f42",
+ "reference": "477da35bd0255e032826f440b94b3e37f2d56f42",
"shasum": ""
},
"require": {
@@ -1202,7 +1202,7 @@
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
"vimeo/psalm": "4.30.0 || 5.3.0"
},
- "time": "2023-05-17T18:32:04+00:00",
+ "time": "2024-03-12T14:54:36+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1251,7 +1251,7 @@
],
"support": {
"issues": "https://github.com/doctrine/persistence/issues",
- "source": "https://github.com/doctrine/persistence/tree/3.2.0"
+ "source": "https://github.com/doctrine/persistence/tree/3.3.2"
},
"funding": [
{
@@ -1271,17 +1271,17 @@
},
{
"name": "nikic/php-parser",
- "version": "v5.0.0",
- "version_normalized": "5.0.0.0",
+ "version": "v5.0.2",
+ "version_normalized": "5.0.2.0",
"source": {
"type": "git",
"url": "https://github.com/nikic/PHP-Parser.git",
- "reference": "4a21235f7e56e713259a6f76bf4b5ea08502b9dc"
+ "reference": "139676794dc1e9231bf7bcd123cfc0c99182cb13"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/nikic/PHP-Parser/zipball/4a21235f7e56e713259a6f76bf4b5ea08502b9dc",
- "reference": "4a21235f7e56e713259a6f76bf4b5ea08502b9dc",
+ "url": "https://api.github.com/repos/nikic/PHP-Parser/zipball/139676794dc1e9231bf7bcd123cfc0c99182cb13",
+ "reference": "139676794dc1e9231bf7bcd123cfc0c99182cb13",
"shasum": ""
},
"require": {
@@ -1294,7 +1294,7 @@
"ircmaxell/php-yacc": "^0.0.7",
"phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
},
- "time": "2024-01-07T17:17:35+00:00",
+ "time": "2024-03-05T20:51:40+00:00",
"bin": [
"bin/php-parse"
],
@@ -1326,7 +1326,7 @@
],
"support": {
"issues": "https://github.com/nikic/PHP-Parser/issues",
- "source": "https://github.com/nikic/PHP-Parser/tree/v5.0.0"
+ "source": "https://github.com/nikic/PHP-Parser/tree/v5.0.2"
},
"install-path": "../nikic/php-parser"
},
@@ -1784,17 +1784,17 @@
},
{
"name": "symfony/cache",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/cache.git",
- "reference": "49f8cdee544a621a621cd21b6cda32a38926d310"
+ "reference": "0ef36534694c572ff526d91c7181f3edede176e7"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/cache/zipball/49f8cdee544a621a621cd21b6cda32a38926d310",
- "reference": "49f8cdee544a621a621cd21b6cda32a38926d310",
+ "url": "https://api.github.com/repos/symfony/cache/zipball/0ef36534694c572ff526d91c7181f3edede176e7",
+ "reference": "0ef36534694c572ff526d91c7181f3edede176e7",
"shasum": ""
},
"require": {
@@ -1828,7 +1828,7 @@
"symfony/messenger": "^5.4|^6.0|^7.0",
"symfony/var-dumper": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-23T14:51:35+00:00",
+ "time": "2024-02-22T20:27:10+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1863,7 +1863,7 @@
"psr6"
],
"support": {
- "source": "https://github.com/symfony/cache/tree/v6.4.3"
+ "source": "https://github.com/symfony/cache/tree/v6.4.4"
},
"funding": [
{
@@ -1962,17 +1962,17 @@
},
{
"name": "symfony/clock",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.5",
+ "version_normalized": "6.4.5.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/clock.git",
- "reference": "f48770105c544001da00b8d745873a628e0de198"
+ "reference": "ecba44be4def12cd71e0460b956ab7e51a2c980e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/clock/zipball/f48770105c544001da00b8d745873a628e0de198",
- "reference": "f48770105c544001da00b8d745873a628e0de198",
+ "url": "https://api.github.com/repos/symfony/clock/zipball/ecba44be4def12cd71e0460b956ab7e51a2c980e",
+ "reference": "ecba44be4def12cd71e0460b956ab7e51a2c980e",
"shasum": ""
},
"require": {
@@ -1983,7 +1983,7 @@
"provide": {
"psr/clock-implementation": "1.0"
},
- "time": "2024-01-23T14:51:35+00:00",
+ "time": "2024-03-01T14:02:27+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2019,7 +2019,7 @@
"time"
],
"support": {
- "source": "https://github.com/symfony/clock/tree/v6.4.3"
+ "source": "https://github.com/symfony/clock/tree/v6.4.5"
},
"funding": [
{
@@ -2039,17 +2039,17 @@
},
{
"name": "symfony/config",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/config.git",
- "reference": "206482ff3ed450495b1d5b7bad1bc3a852def96f"
+ "reference": "6ea4affc27f2086c9d16b92ab5429ce1e3c38047"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/config/zipball/206482ff3ed450495b1d5b7bad1bc3a852def96f",
- "reference": "206482ff3ed450495b1d5b7bad1bc3a852def96f",
+ "url": "https://api.github.com/repos/symfony/config/zipball/6ea4affc27f2086c9d16b92ab5429ce1e3c38047",
+ "reference": "6ea4affc27f2086c9d16b92ab5429ce1e3c38047",
"shasum": ""
},
"require": {
@@ -2069,7 +2069,7 @@
"symfony/service-contracts": "^2.5|^3",
"symfony/yaml": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-29T13:26:27+00:00",
+ "time": "2024-02-26T07:52:26+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2097,7 +2097,7 @@
"description": "Helps you find, load, combine, autofill and validate configuration values of any kind",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/config/tree/v6.4.3"
+ "source": "https://github.com/symfony/config/tree/v6.4.4"
},
"funding": [
{
@@ -2117,17 +2117,17 @@
},
{
"name": "symfony/console",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "2aaf83b4de5b9d43b93e4aec6f2f8b676f7c567e"
+ "reference": "0d9e4eb5ad413075624378f474c4167ea202de78"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/2aaf83b4de5b9d43b93e4aec6f2f8b676f7c567e",
- "reference": "2aaf83b4de5b9d43b93e4aec6f2f8b676f7c567e",
+ "url": "https://api.github.com/repos/symfony/console/zipball/0d9e4eb5ad413075624378f474c4167ea202de78",
+ "reference": "0d9e4eb5ad413075624378f474c4167ea202de78",
"shasum": ""
},
"require": {
@@ -2160,7 +2160,7 @@
"symfony/stopwatch": "^5.4|^6.0|^7.0",
"symfony/var-dumper": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-23T14:51:35+00:00",
+ "time": "2024-02-22T20:27:10+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2194,7 +2194,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v6.4.3"
+ "source": "https://github.com/symfony/console/tree/v6.4.4"
},
"funding": [
{
@@ -2214,17 +2214,17 @@
},
{
"name": "symfony/dependency-injection",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/dependency-injection.git",
- "reference": "6871811c5a5c5e180244ddb689746446db02c05b"
+ "reference": "6236e5e843cb763e9d0f74245678b994afea5363"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/dependency-injection/zipball/6871811c5a5c5e180244ddb689746446db02c05b",
- "reference": "6871811c5a5c5e180244ddb689746446db02c05b",
+ "url": "https://api.github.com/repos/symfony/dependency-injection/zipball/6236e5e843cb763e9d0f74245678b994afea5363",
+ "reference": "6236e5e843cb763e9d0f74245678b994afea5363",
"shasum": ""
},
"require": {
@@ -2250,7 +2250,7 @@
"symfony/expression-language": "^5.4|^6.0|^7.0",
"symfony/yaml": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-30T08:32:12+00:00",
+ "time": "2024-02-22T20:27:10+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2278,7 +2278,7 @@
"description": "Allows you to standardize and centralize the way objects are constructed in your application",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/dependency-injection/tree/v6.4.3"
+ "source": "https://github.com/symfony/dependency-injection/tree/v6.4.4"
},
"funding": [
{
@@ -2663,17 +2663,17 @@
},
{
"name": "symfony/http-client",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.5",
+ "version_normalized": "6.4.5.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/http-client.git",
- "reference": "a9034bc119fab8238f76cf49c770f3135f3ead86"
+ "reference": "f3c86a60a3615f466333a11fd42010d4382a82c7"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/http-client/zipball/a9034bc119fab8238f76cf49c770f3135f3ead86",
- "reference": "a9034bc119fab8238f76cf49c770f3135f3ead86",
+ "url": "https://api.github.com/repos/symfony/http-client/zipball/f3c86a60a3615f466333a11fd42010d4382a82c7",
+ "reference": "f3c86a60a3615f466333a11fd42010d4382a82c7",
"shasum": ""
},
"require": {
@@ -2708,7 +2708,7 @@
"symfony/process": "^5.4|^6.0|^7.0",
"symfony/stopwatch": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-29T15:01:07+00:00",
+ "time": "2024-03-02T12:45:30+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2739,7 +2739,7 @@
"http"
],
"support": {
- "source": "https://github.com/symfony/http-client/tree/v6.4.3"
+ "source": "https://github.com/symfony/http-client/tree/v6.4.5"
},
"funding": [
{
@@ -2840,17 +2840,17 @@
},
{
"name": "symfony/messenger",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/messenger.git",
- "reference": "18d3ea9ed6d1487802f3f716596a6325cdc5ef15"
+ "reference": "443b2644a3f43678adb5281a4e3fae6fbf2473c7"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/messenger/zipball/18d3ea9ed6d1487802f3f716596a6325cdc5ef15",
- "reference": "18d3ea9ed6d1487802f3f716596a6325cdc5ef15",
+ "url": "https://api.github.com/repos/symfony/messenger/zipball/443b2644a3f43678adb5281a4e3fae6fbf2473c7",
+ "reference": "443b2644a3f43678adb5281a4e3fae6fbf2473c7",
"shasum": ""
},
"require": {
@@ -2882,7 +2882,7 @@
"symfony/stopwatch": "^5.4|^6.0|^7.0",
"symfony/validator": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-30T13:33:32+00:00",
+ "time": "2024-02-26T07:52:26+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2910,7 +2910,7 @@
"description": "Helps applications send and receive messages to/from other applications or via message queues",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/messenger/tree/v6.4.3"
+ "source": "https://github.com/symfony/messenger/tree/v6.4.4"
},
"funding": [
{
@@ -3499,23 +3499,23 @@
},
{
"name": "symfony/process",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "31642b0818bfcff85930344ef93193f8c607e0a3"
+ "reference": "710e27879e9be3395de2b98da3f52a946039f297"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/31642b0818bfcff85930344ef93193f8c607e0a3",
- "reference": "31642b0818bfcff85930344ef93193f8c607e0a3",
+ "url": "https://api.github.com/repos/symfony/process/zipball/710e27879e9be3395de2b98da3f52a946039f297",
+ "reference": "710e27879e9be3395de2b98da3f52a946039f297",
"shasum": ""
},
"require": {
"php": ">=8.1"
},
- "time": "2024-01-23T14:51:35+00:00",
+ "time": "2024-02-20T12:31:00+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -3543,7 +3543,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v6.4.3"
+ "source": "https://github.com/symfony/process/tree/v6.4.4"
},
"funding": [
{
@@ -3632,17 +3632,17 @@
},
{
"name": "symfony/serializer",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/serializer.git",
- "reference": "51a06ee93c4d5ab5b9edaa0635d8b83953e3c14d"
+ "reference": "88da7f8fe03c5f4c2a69da907f1de03fab2e6872"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/serializer/zipball/51a06ee93c4d5ab5b9edaa0635d8b83953e3c14d",
- "reference": "51a06ee93c4d5ab5b9edaa0635d8b83953e3c14d",
+ "url": "https://api.github.com/repos/symfony/serializer/zipball/88da7f8fe03c5f4c2a69da907f1de03fab2e6872",
+ "reference": "88da7f8fe03c5f4c2a69da907f1de03fab2e6872",
"shasum": ""
},
"require": {
@@ -3685,7 +3685,7 @@
"symfony/var-exporter": "^5.4|^6.0|^7.0",
"symfony/yaml": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-30T08:32:12+00:00",
+ "time": "2024-02-22T20:27:10+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -3713,7 +3713,7 @@
"description": "Handles serializing and deserializing data structures, including object graphs, into array structures or other formats like XML and JSON.",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/serializer/tree/v6.4.3"
+ "source": "https://github.com/symfony/serializer/tree/v6.4.4"
},
"funding": [
{
@@ -3883,17 +3883,17 @@
},
{
"name": "symfony/string",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "7a14736fb179876575464e4658fce0c304e8c15b"
+ "reference": "4e465a95bdc32f49cf4c7f07f751b843bbd6dcd9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/7a14736fb179876575464e4658fce0c304e8c15b",
- "reference": "7a14736fb179876575464e4658fce0c304e8c15b",
+ "url": "https://api.github.com/repos/symfony/string/zipball/4e465a95bdc32f49cf4c7f07f751b843bbd6dcd9",
+ "reference": "4e465a95bdc32f49cf4c7f07f751b843bbd6dcd9",
"shasum": ""
},
"require": {
@@ -3913,7 +3913,7 @@
"symfony/translation-contracts": "^2.5|^3.0",
"symfony/var-exporter": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-25T09:26:29+00:00",
+ "time": "2024-02-01T13:16:41+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -3952,7 +3952,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v6.4.3"
+ "source": "https://github.com/symfony/string/tree/v6.4.4"
},
"funding": [
{
@@ -3972,17 +3972,17 @@
},
{
"name": "symfony/var-exporter",
- "version": "v6.4.3",
- "version_normalized": "6.4.3.0",
+ "version": "v6.4.4",
+ "version_normalized": "6.4.4.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/var-exporter.git",
- "reference": "a8c12b5448a5ac685347f5eeb2abf6a571ec16b8"
+ "reference": "0bd342e24aef49fc82a21bd4eedd3e665d177e5b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/var-exporter/zipball/a8c12b5448a5ac685347f5eeb2abf6a571ec16b8",
- "reference": "a8c12b5448a5ac685347f5eeb2abf6a571ec16b8",
+ "url": "https://api.github.com/repos/symfony/var-exporter/zipball/0bd342e24aef49fc82a21bd4eedd3e665d177e5b",
+ "reference": "0bd342e24aef49fc82a21bd4eedd3e665d177e5b",
"shasum": ""
},
"require": {
@@ -3992,7 +3992,7 @@
"require-dev": {
"symfony/var-dumper": "^5.4|^6.0|^7.0"
},
- "time": "2024-01-23T14:51:35+00:00",
+ "time": "2024-02-26T08:37:45+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -4030,7 +4030,7 @@
"serialize"
],
"support": {
- "source": "https://github.com/symfony/var-exporter/tree/v6.4.3"
+ "source": "https://github.com/symfony/var-exporter/tree/v6.4.4"
},
"funding": [
{
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 949d980..d8fc216 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -12,13 +12,13 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 072d0f8637341f880b6844cd50d2c2c9918a69b2
+%global gh_commit 7a74bd0ad8fda76930c23ebc180cd6ca190c7a19
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-02-08
+%global gh_date 2024-03-19
%global gh_owner llaville
%global gh_project php-compatinfo
-%global upstream_version 7.1.2
+%global upstream_version 7.1.3
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
@@ -58,8 +58,8 @@ Requires: php-xmlreader
# Bundled libraries
# License BSD-3-Clause
-Provides: bundled(php-bartlett-php-compatinfo-db) = 6.2.1
-Provides: bundled(php-nikic-php-parser) = v5.0.0
+Provides: bundled(php-bartlett-php-compatinfo-db) = 6.4.2
+Provides: bundled(php-nikic-php-parser) = v5.0.2
# License MIT
Provides: bundled(php-bartlett-sarif-php-sdk) = 1.1.0
Provides: bundled(php-brick-math) = 0.11.0
@@ -67,14 +67,14 @@ Provides: bundled(php-composer-semver) = 3.4.0
Provides: bundled(php-doctrine-cache) = 2.2.0
Provides: bundled(php-doctrine-collections) = 1.8.0
Provides: bundled(php-doctrine-common) = 3.4.3
-Provides: bundled(php-doctrine-dbal) = 3.8.1
+Provides: bundled(php-doctrine-dbal) = 3.8.3
Provides: bundled(php-doctrine-deprecations) = 1.1.3
Provides: bundled(php-doctrine-event-manager) = 2.0.0
-Provides: bundled(php-doctrine-inflector) = 2.0.9
+Provides: bundled(php-doctrine-inflector) = 2.0.10
Provides: bundled(php-doctrine-instantiator) = 2.0.0
Provides: bundled(php-doctrine-lexer) = 3.0.1
-Provides: bundled(php-doctrine-orm) = 2.18.0
-Provides: bundled(php-doctrine-persistence) = 3.2.0
+Provides: bundled(php-doctrine-orm) = 2.19.2
+Provides: bundled(php-doctrine-persistence) = 3.3.2
Provides: bundled(php-psr-cache) = 3.0.0
Provides: bundled(php-psr-clock) = 1.0.0
Provides: bundled(php-psr-container) = 2.0.2
@@ -82,20 +82,20 @@ Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 3.0.0
Provides: bundled(php-ramsey-collection) = 2.0.0
Provides: bundled(php-ramsey-uuid) = 4.7.5
-Provides: bundled(php-symfony-cache) = v6.4.3
+Provides: bundled(php-symfony-cache) = v6.4.4
Provides: bundled(php-symfony-cache-contracts) = v3.4.0
-Provides: bundled(php-symfony-clock) = v6.4.3
-Provides: bundled(php-symfony-config) = v6.4.3
-Provides: bundled(php-symfony-console) = v6.4.3
-Provides: bundled(php-symfony-dependency-injection) = v6.4.3
+Provides: bundled(php-symfony-clock) = v6.4.5
+Provides: bundled(php-symfony-config) = v6.4.4
+Provides: bundled(php-symfony-console) = v6.4.4
+Provides: bundled(php-symfony-dependency-injection) = v6.4.4
Provides: bundled(php-symfony-deprecation-contracts) = v3.4.0
Provides: bundled(php-symfony-event-dispatcher) = v6.4.3
Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.4.0
Provides: bundled(php-symfony-filesystem) = v6.4.3
Provides: bundled(php-symfony-finder) = v6.4.0
-Provides: bundled(php-symfony-http-client) = v6.4.3
+Provides: bundled(php-symfony-http-client) = v6.4.5
Provides: bundled(php-symfony-http-client-contracts) = v3.4.0
-Provides: bundled(php-symfony-messenger) = v6.4.3
+Provides: bundled(php-symfony-messenger) = v6.4.4
Provides: bundled(php-symfony-polyfill-ctype) = v1.29.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.29.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.29.0
@@ -103,13 +103,13 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.29.0
Provides: bundled(php-symfony-polyfill-php72) = v1.29.0
Provides: bundled(php-symfony-polyfill-php80) = v1.29.0
Provides: bundled(php-symfony-polyfill-php83) = v1.29.0
-Provides: bundled(php-symfony-process) = v6.4.3
+Provides: bundled(php-symfony-process) = v6.4.4
Provides: bundled(php-symfony-requirements-checker) = v2.0.1
-Provides: bundled(php-symfony-serializer) = v6.4.3
+Provides: bundled(php-symfony-serializer) = v6.4.4
Provides: bundled(php-symfony-service-contracts) = v3.4.1
Provides: bundled(php-symfony-stopwatch) = v6.4.3
-Provides: bundled(php-symfony-string) = v6.4.3
-Provides: bundled(php-symfony-var-exporter) = v6.4.3
+Provides: bundled(php-symfony-string) = v6.4.4
+Provides: bundled(php-symfony-var-exporter) = v6.4.4
Provides: phpcompatinfo = %{version}
Provides: php-composer(bartlett/php-compatinfo) = %{version}
@@ -203,6 +203,10 @@ install -D -p -m 755 %{SOURCE1} \
%changelog
+* Tue Mar 19 2024 Remi Collet <remi@remirepo.net> - 7.1.3-1
+- update to 7.1.3
+- update bundled bartlett/php-compatinfo-db to 6.4.2
+
* Thu Feb 8 2024 Remi Collet <remi@remirepo.net> - 7.1.2-1
- update to 7.1.2
- update bundled bartlett/php-compatinfo-db to 6.2.1