summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-28 08:38:10 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-28 08:38:10 +0100
commit98b3de94e1d50a2149b9032784b59bc24bd69c9a (patch)
tree39d40c4c2c07362e92472fb27f3906ca0dad67f5
parent8be483d2a0bf2117af02d1e213b64d9245f231fb (diff)
php-bantu-ini-get-wrapper: backport stuffHEADmaster
-rw-r--r--Makefile4
-rw-r--r--php-bantu-ini-get-wrapper.spec10
2 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-bantu-ini-get-wrapper.spec b/php-bantu-ini-get-wrapper.spec
index 26ab87c..dfdb75b 100644
--- a/php-bantu-ini-get-wrapper.spec
+++ b/php-bantu-ini-get-wrapper.spec
@@ -22,6 +22,7 @@ URL: https://github.com/%{github_owner}/%{github_name}
# https://fedoraproject.org/wiki/Packaging:SourceURL#Github
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{github_name}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# For tests
BuildRequires: php(language) >= %{php_min_ver}
@@ -45,6 +46,7 @@ Convenience wrapper around ini_get().
%install
+rm -rf %{buildroot}
# use PSR-0 layout relative to _datadir/php
mkdir -p %{buildroot}%{_datadir}/php/%{psr4_prefix}
cp -pr src/* %{buildroot}%{_datadir}/php/%{psr4_prefix}
@@ -58,7 +60,12 @@ cp -pr src/* %{buildroot}%{_datadir}/php/%{psr4_prefix}
%{_bindir}/phpunit --bootstrap bootstrap.php
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md composer.json
@@ -66,5 +73,8 @@ cp -pr src/* %{buildroot}%{_datadir}/php/%{psr4_prefix}
%changelog
+* Sun Dec 28 2014 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- add backport stuff for remi repo
+
* Fri Dec 12 2014 Adam Williamson <awilliam@redhat.com> - 1.0.1-1
- initial package