summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-31 09:19:34 +0100
committerRemi Collet <remi@php.net>2022-01-31 09:19:34 +0100
commit7568e514a1c06abfb7bd1a350d128dd20c4c39d0 (patch)
treed98f514ecc3853b2e2950949ab215094187ee6aa
parentff69fbe79b61e9ba31b49e277cc5010311db468f (diff)
update to 2.0.5
-rw-r--r--composer.json8
-rw-r--r--php-bacon-qr-code2.spec15
2 files changed, 18 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index b240199..1440cc3 100644
--- a/composer.json
+++ b/composer.json
@@ -26,7 +26,13 @@
},
"require-dev": {
"phpunit/phpunit": "^7 | ^8 | ^9",
+ "spatie/phpunit-snapshot-assertions": "^4.2.9",
"squizlabs/php_codesniffer": "^3.4",
- "phly/keep-a-changelog": "^1.4"
+ "phly/keep-a-changelog": "^2.1"
+ },
+ "config": {
+ "allow-plugins": {
+ "ocramius/package-versions": true
+ }
}
}
diff --git a/php-bacon-qr-code2.spec b/php-bacon-qr-code2.spec
index 8011e2c..bf92496 100644
--- a/php-bacon-qr-code2.spec
+++ b/php-bacon-qr-code2.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-bacon-qr-code2
#
-# Copyright (c) 2017-2021 Remi Collet
+# Copyright (c) 2017-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
%bcond_without tests
-%global gh_commit f73543ac4e1def05f1a70bcd1525c8a157a1ad09
+%global gh_commit 7190fc6c20370e0e93da6717b182b8249d5b8e71
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Bacon
%global gh_project BaconQrCode
@@ -22,7 +22,7 @@
%global major 2
Name: php-%{pk_project}%{major}
-Version: 2.0.4
+Version: 2.0.5
Release: 1%{?dist}
Summary: QR code generator for PHP
@@ -51,6 +51,7 @@ BuildRequires: php-dasprid-enum
%endif
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^7 | ^8 | ^9",
+# "spatie/phpunit-snapshot-assertions": "^4.2.9",
# "squizlabs/php_codesniffer": "^3.1",
# "phly/keep-a-changelog": "^1.4"
%global phpunit %{_bindir}/phpunit9
@@ -131,6 +132,9 @@ then
exit 0
fi
+: ignore test using spatie/phpunit-snapshot-assertions
+rm test/Integration/ImagickRenderingTest.php
+
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -138,7 +142,7 @@ require '%{buildroot}%{php_home}/%{ns_project}%{major}/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" php73 php74 php80 php81; do
+for cmd in "php %{phpunit}" php74 php80 php81; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -160,6 +164,9 @@ exit $ret
%changelog
+* Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 2.0.5-1
+- update to 2.0.5
+
* Mon Jun 21 2021 Remi Collet <remi@remirepo.net> - 2.0.4-1
- update to 2.0.4