summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-15 13:50:21 +0200
committerRemi Collet <remi@remirepo.net>2020-07-15 13:50:21 +0200
commit538a8b4437e3b8fbc109d4d7865835b9f64c947e (patch)
tree47871be7ae49e0384564c3098d2d8516cbb98286
parent68ce44708667cfc43fb69e559e3eddf9a5395f14 (diff)
update to 2.0.1
-rw-r--r--php-bacon-qr-code2.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-bacon-qr-code2.spec b/php-bacon-qr-code2.spec
index 221baad..31f285f 100644
--- a/php-bacon-qr-code2.spec
+++ b/php-bacon-qr-code2.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit eaac909da3ccc32b748a65b127acd8918f58d9b0
+%global gh_commit 6e53ced3d2499cee4a0ef23a7c4d6449607ac7da
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Bacon
%global gh_project BaconQrCode
@@ -18,10 +18,10 @@
%global ns_project %{gh_project}
%global php_home %{_datadir}/php
%global major 2
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
Name: php-%{pk_project}%{major}
-Version: 2.0.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: QR code generator for PHP
@@ -32,7 +32,7 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= 7.1
BuildRequires: php-iconv
@@ -122,7 +122,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
if php -r 'exit(PHP_INT_SIZE<8 ? 0 : 1);'
then
: ignore test suite because of https://github.com/Bacon/BaconQrCode/issues/31
@@ -136,7 +136,7 @@ require '%{buildroot}%{php_home}/%{ns_project}%{major}/autoload.php';
EOF
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
@@ -157,6 +157,9 @@ exit $ret
%changelog
+* Wed Jul 15 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1
+
* Mon Sep 2 2019 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- rename to php-bacon-qr-code2