summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-02 15:47:25 +0200
committerRemi Collet <remi@remirepo.net>2019-09-02 15:47:25 +0200
commit3cdc7e66640a3f4ac03ece3edfdb381f3d4e261d (patch)
tree3bbc66bfa01e1a78f8a3c07ca30cab2fa749d47c
duplicate v1 stuff
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json29
-rw-r--r--php-bacon-qr-code2.spec144
4 files changed, 184 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..086f4c5
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,29 @@
+{
+ "name": "bacon/bacon-qr-code",
+ "description": "BaconQrCode is a QR code generator for PHP.",
+ "license" : "BSD-2-Clause",
+ "homepage": "https://github.com/Bacon/BaconQrCode",
+ "require": {
+ "php": "^5.4|^7.0",
+ "ext-iconv": "*"
+ },
+ "suggest": {
+ "ext-gd": "to generate QR code images"
+ },
+ "authors": [
+ {
+ "name": "Ben Scholzen 'DASPRiD'",
+ "email": "mail@dasprids.de",
+ "homepage": "http://www.dasprids.de",
+ "role": "Developer"
+ }
+ ],
+ "autoload": {
+ "psr-0": {
+ "BaconQrCode": "src/"
+ }
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.8"
+ }
+}
diff --git a/php-bacon-qr-code2.spec b/php-bacon-qr-code2.spec
new file mode 100644
index 0000000..dace8d2
--- /dev/null
+++ b/php-bacon-qr-code2.spec
@@ -0,0 +1,144 @@
+# remirepo/fedora spec file for php-bacon-qr-code
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 5a91b62b9d37cee635bbf8d553f4546057250bee
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner Bacon
+%global gh_project BaconQrCode
+
+%global pk_vendor bacon
+%global pk_project bacon-qr-code
+
+%global ns_vendor %nil
+%global ns_project %{gh_project}
+%global php_home %{_datadir}/php
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{pk_project}
+Version: 1.0.3
+Release: 1%{?dist}
+Summary: QR code generator for PHP
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php(language) >= 5.4
+BuildRequires: php-gd
+BuildRequires: php-reflection
+BuildRequires: php-simplexml
+BuildRequires: php-ctype
+BuildRequires: php-iconv
+BuildRequires: php-spl
+BuildRequires: php-composer(phpunit/phpunit)
+# Required by autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.3.3"
+Requires: php(language) >= 5.3.3
+Requires: php-iconv
+# From composer.json, "suggest": {
+# "ext-gd": "to generate QR code images"
+Requires: php-gd
+# From phpcompatinfo report for version 1.0.1
+Requires: php-reflection
+Requires: php-simplexml
+Requires: php-ctype
+Requires: php-spl
+# Required by autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+BaconQrCode is a port of QR code portion of the ZXing library.
+It currently only features the encoder part, but could later
+receive the decoder part as well.
+
+As the Reed Solomon codec implementation of the ZXing library
+performs quite slow in PHP, it was exchanged with the implementation
+by Phil Karn.
+
+Autoloader: %{php_home}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+cat << 'EOF' | tee src/%{ns_project}/autoload.php
+<?php
+/* Autoloader for %{name} and its dependencies */
+require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_project}\\', __DIR__);
+EOF
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{php_home}
+cp -pr src/%{ns_project} %{buildroot}%{php_home}/%{ns_project}
+
+
+%check
+%if %{with_tests}
+if php -r 'exit(PHP_INT_SIZE<8 ? 0 : 1);'
+then
+ : ignore test suite because of https://github.com/Bacon/BaconQrCode/issues/31
+ exit 0
+fi
+
+cd tests
+cat << 'EOF' | tee bootstrap.php
+<?php
+require '%{buildroot}%{php_home}/%{ns_project}/autoload.php';
+EOF
+
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc README.md
+%{php_home}/%{ns_project}
+
+
+%changelog
+* Thu Oct 19 2017 Remi Collet <remi@remirepo.net> - 1.0.3-1
+- Update to 1.0.3
+
+* Mon Jul 3 2017 Remi Collet <remi@remirepo.net> - 1.0.1-4
+- run test suite only on 64-bit arch
+
+* Mon Jul 3 2017 Remi Collet <remi@remirepo.net> - 1.0.1-2
+- fix directory ownership, from review #1465313
+
+* Tue Jun 27 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- initial package, version 1.0.1
+- open https://github.com/Bacon/BaconQrCode/pull/29 - phpunit