summaryrefslogtreecommitdiffstats
path: root/php-bacon-qr-code.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-19 06:30:53 +0200
committerRemi Collet <remi@remirepo.net>2017-10-19 06:30:53 +0200
commit8bf87d9c86c7f9546ea09e398963d7efff7a3729 (patch)
tree834f1d7ffde739491d22a23a505ffb0e4926bd91 /php-bacon-qr-code.spec
parent3eed1e08bb1e0a313c4273253a2173e036928511 (diff)
Diffstat (limited to 'php-bacon-qr-code.spec')
-rw-r--r--php-bacon-qr-code.spec17
1 files changed, 8 insertions, 9 deletions
diff --git a/php-bacon-qr-code.spec b/php-bacon-qr-code.spec
index 6a80737..dace8d2 100644
--- a/php-bacon-qr-code.spec
+++ b/php-bacon-qr-code.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 031a2ce68c5794064b49d11775b2daf45c96e21c
+%global gh_commit 5a91b62b9d37cee635bbf8d553f4546057250bee
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Bacon
%global gh_project BaconQrCode
@@ -20,8 +20,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_project}
-Version: 1.0.1
-Release: 4%{?dist}
+Version: 1.0.3
+Release: 1%{?dist}
Summary: QR code generator for PHP
Group: Development/Libraries
@@ -29,13 +29,10 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-# upstream patch
-Patch0: https://github.com/%{gh_owner}/%{gh_project}/commit/8f16a007ea94f65894c8c71e0aaeba83e0d13993.patch
-
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 5.3.3
+BuildRequires: php(language) >= 5.4
BuildRequires: php-gd
BuildRequires: php-reflection
BuildRequires: php-simplexml
@@ -50,6 +47,7 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": ">=5.3.3"
Requires: php(language) >= 5.3.3
+Requires: php-iconv
# From composer.json, "suggest": {
# "ext-gd": "to generate QR code images"
Requires: php-gd
@@ -57,7 +55,6 @@ Requires: php-gd
Requires: php-reflection
Requires: php-simplexml
Requires: php-ctype
-Requires: php-iconv
Requires: php-spl
# Required by autoloader
Requires: php-composer(fedora/autoloader)
@@ -79,7 +76,6 @@ Autoloader: %{php_home}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .upstream
cat << 'EOF' | tee src/%{ns_project}/autoload.php
<?php
@@ -134,6 +130,9 @@ exit $ret
%changelog
+* Thu Oct 19 2017 Remi Collet <remi@remirepo.net> - 1.0.3-1
+- Update to 1.0.3
+
* Mon Jul 3 2017 Remi Collet <remi@remirepo.net> - 1.0.1-4
- run test suite only on 64-bit arch