summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-12 14:09:45 +0200
committerRemi Collet <remi@remirepo.net>2020-10-12 14:09:45 +0200
commitfe31d529a1f2f3da93ef497814ba813c5939cd59 (patch)
tree1e116ed5c4515293692ad72f44d093e0812da0f9
parent89e9b0373d0db6300170dfd54fdf4429f9ad7a0b (diff)
rebuild for #remirepoHEADmaster
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json26
-rw-r--r--php-email-address-validation.spec13
4 files changed, 52 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..6c72ddb
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,26 @@
+{
+ "name": "aziraphale/email-address-validator",
+ "version": "2.0.1",
+ "description": "Fork of AddedBytes' PHP EmailAddressValidator script, now with Composer support!",
+ "homepage": "https://github.com/aziraphale/email-address-validator",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Dave Child",
+ "email": "dave@addedbytes.com"
+ },
+ {
+ "name": "Andrew Gillard",
+ "email": "andrew@lorddeath.net"
+ }
+ ],
+ "require": {},
+ "autoload": {
+ "psr-0": {
+ "EmailAddressValidator": ""
+ }
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7"
+ }
+}
diff --git a/php-email-address-validation.spec b/php-email-address-validation.spec
index 89e9c41..4d6e228 100644
--- a/php-email-address-validation.spec
+++ b/php-email-address-validation.spec
@@ -1,3 +1,13 @@
+# remirepo spec file for php-email-address-validation, from:
+#
+# Fedora spec file for php-email-address-validation
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
Name: php-email-address-validation
Version: 2.0.1
Release: 1%{?dist}
@@ -50,6 +60,9 @@ phpunit --verbose --bootstrap %{buildroot}%{_datadir}/php/%{name}/EmailAddressVa
%changelog
+* Mon Oct 12 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- rebuild for #remirepo
+
* Mon Aug 31 2020 Artur Iwicki <fedora@svgames.pl> - 2.0.1-1
- Switch main source to a fork (composer: aziraphale/email-address-validator)
- Run the test suite during %%check