summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-aws-sdk3-upstream-pull-request-1298.patch134
-rw-r--r--php-aws-sdk3.spec18
2 files changed, 7 insertions, 145 deletions
diff --git a/php-aws-sdk3-upstream-pull-request-1298.patch b/php-aws-sdk3-upstream-pull-request-1298.patch
deleted file mode 100644
index 1d116c2..0000000
--- a/php-aws-sdk3-upstream-pull-request-1298.patch
+++ /dev/null
@@ -1,134 +0,0 @@
-From 634ba5285ced6c01b0824c5c22baeef17e04d33c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Sat, 27 May 2017 08:12:19 +0200
-Subject: [PATCH 1/3] fix count(): Parameter must be an array or an object that
- implements Countable (php 7.2)
-
----
- src/History.php | 2 +-
- src/LruArrayCache.php | 9 +++++++--
- tests/S3/BatchDeleteTest.php | 2 +-
- 3 files changed, 9 insertions(+), 4 deletions(-)
-
-diff --git a/src/History.php b/src/History.php
-index 89e278a72..d9feee8a0 100644
---- a/src/History.php
-+++ b/src/History.php
-@@ -11,7 +11,7 @@
- class History implements \Countable, \IteratorAggregate
- {
- private $maxEntries;
-- private $entries;
-+ private $entries = array();
-
- /**
- * @param int $maxEntries Maximum number of entries to store.
-diff --git a/src/LruArrayCache.php b/src/LruArrayCache.php
-index 39ff7fc04..aef2dd537 100644
---- a/src/LruArrayCache.php
-+++ b/src/LruArrayCache.php
-@@ -11,13 +11,13 @@
- * cache, if the number of cached items exceeds the allowed number, the first
- * N number of items are removed from the array.
- */
--class LruArrayCache implements CacheInterface
-+class LruArrayCache implements CacheInterface, \Countable
- {
- /** @var int */
- private $maxItems;
-
- /** @var array */
-- private $items;
-+ private $items = array();
-
- /**
- * @param int $maxItems Maximum number of allowed cache items.
-@@ -71,4 +71,9 @@ public function remove($key)
- {
- unset($this->items[$key]);
- }
-+
-+ public function count()
-+ {
-+ return count($this->items);
-+ }
- }
-diff --git a/tests/S3/BatchDeleteTest.php b/tests/S3/BatchDeleteTest.php
-index 7934379af..dda2641b5 100644
---- a/tests/S3/BatchDeleteTest.php
-+++ b/tests/S3/BatchDeleteTest.php
-@@ -206,7 +206,7 @@ public function testWithNoMatchingObjects()
- $batch->delete();
- $last = $mock->getLastCommand();
- $this->assertEquals('ListObjects', $last->getName());
-- $this->assertEquals(0, count($last['Delete']['Objects']));
-+ $this->assertFalse(isset($last['Delete']['Objects']));
- $this->assertEquals('foo', $last['Bucket']);
- }
- }
-
-From 5dc49b75e05b43fc250d8dd949d583287ce1b2a0 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Sat, 27 May 2017 08:41:21 +0200
-Subject: [PATCH 2/3] fix session_set_save_handler(): Cannot change save
- handler when headers already sent (php 7.2)
-
----
- tests/DynamoDb/DynamoDbClientTest.php | 1 +
- tests/DynamoDb/SessionHandlerTest.php | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/tests/DynamoDb/DynamoDbClientTest.php b/tests/DynamoDb/DynamoDbClientTest.php
-index 1b549921e..1bec6759b 100644
---- a/tests/DynamoDb/DynamoDbClientTest.php
-+++ b/tests/DynamoDb/DynamoDbClientTest.php
-@@ -12,6 +12,7 @@
-
- /**
- * @covers \Aws\DynamoDb\DynamoDbClient
-+ * @runTestsInSeparateProcesses
- */
- class DynamoDbClientTest extends \PHPUnit_Framework_TestCase
- {
-diff --git a/tests/DynamoDb/SessionHandlerTest.php b/tests/DynamoDb/SessionHandlerTest.php
-index 07915e652..62c4a97a9 100644
---- a/tests/DynamoDb/SessionHandlerTest.php
-+++ b/tests/DynamoDb/SessionHandlerTest.php
-@@ -6,6 +6,7 @@
-
- /**
- * @covers Aws\DynamoDb\SessionHandler
-+ * @runTestsInSeparateProcesses
- */
- class SessionHandlerTest extends \PHPUnit_Framework_TestCase
- {
-
-From 93ba536daac90e15a5c91eb6e7d8507cf4546406 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Sat, 27 May 2017 08:52:22 +0200
-Subject: [PATCH 3/3] enable nightly (7.2)
-
----
- .travis.yml | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/.travis.yml b/.travis.yml
-index 4160ad7de..68b0646ac 100644
---- a/.travis.yml
-+++ b/.travis.yml
-@@ -5,6 +5,7 @@ php:
- - 5.6
- - 7.0
- - 7.1
-+ - nightly
- - hhvm
-
- sudo: false
-@@ -16,6 +17,7 @@ env:
- matrix:
- allow_failures:
- - php: hhvm
-+ - php: nightly
- fast_finish: true
-
- install:
diff --git a/php-aws-sdk3.spec b/php-aws-sdk3.spec
index ac32685..cb11b79 100644
--- a/php-aws-sdk3.spec
+++ b/php-aws-sdk3.spec
@@ -12,8 +12,8 @@
%global github_owner aws
%global github_name aws-sdk-php
-%global github_version 3.31.5
-%global github_commit bb28d91e5766539224f06240472e5184bfddca66
+%global github_version 3.32.0
+%global github_commit 3cd5606efca95480a17b0f9d0f21190cd25cef77
%global composer_vendor aws
%global composer_project aws-sdk-php
@@ -68,11 +68,6 @@ URL: http://aws.amazon.com/sdkforphp
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-# Fix for PHP 7.2
-# https://github.com/aws/aws-sdk-php/pull/1298
-# https://github.com/aws/aws-sdk-php/pull/1298.patch
-Patch0: %{name}-upstream-pull-request-1298.patch
-
BuildArch: noarch
# Library version value and autoloader check
BuildRequires: php-cli
@@ -110,7 +105,7 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-simplexml
BuildRequires: php-spl
-## phpcompatinfo (computed from version 3.31.0)
+## phpcompatinfo (computed from version 3.32.0)
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-filter
@@ -175,9 +170,6 @@ Autoloader: %{phpdir}/Aws3/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-: Fix for PHP 7.2
-%patch0 -p1
-
%build
: Create autoloader
@@ -279,6 +271,10 @@ exit $RETURN_CODE
%changelog
+* Thu Jul 27 2017 Shawn Iwinski <shawn@iwin.ski> - 3.32.0-1
+- Update to 3.32.0 (RHBZ #1472012)
+- Remove patch to fix PHP 7.2 failures
+
* Mon Jul 17 2017 Shawn Iwinski <shawn@iwin.ski> - 3.31.5-1
- Updated to 3.31.5 (RHBZ #1468058)