summaryrefslogtreecommitdiffstats
path: root/php-aws-sdk3.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-27 07:32:18 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-27 07:32:18 +0100
commitb4e805593b45307841f45d3254510cc9674d316d (patch)
treef74e03eb37c1fb01e7d0f5199e6e9a27d3ce907e /php-aws-sdk3.spec
parentdb4ff5e14ed1cae6facf7d26d708462ba7ddee40 (diff)
php-aws-sdk3: sync with Fedora
Diffstat (limited to 'php-aws-sdk3.spec')
-rw-r--r--php-aws-sdk3.spec32
1 files changed, 17 insertions, 15 deletions
diff --git a/php-aws-sdk3.spec b/php-aws-sdk3.spec
index 1c9adf6..e9012ff 100644
--- a/php-aws-sdk3.spec
+++ b/php-aws-sdk3.spec
@@ -95,7 +95,7 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-simplexml
BuildRequires: php-spl
-## phpcompatinfo (computed from version 3.20.6)
+## phpcompatinfo (computed from version 3.20.11)
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-filter
@@ -117,7 +117,7 @@ Requires: php-composer(guzzlehttp/psr7) < %{guzzle_psr7_max_ver}
Requires: php-composer(guzzlehttp/psr7) >= %{guzzle_psr7_min_ver}
Requires: php-composer(mtdowling/jmespath.php) < %{jmespath_max_ver}
Requires: php-composer(mtdowling/jmespath.php) >= %{jmespath_min_ver}
-# phpcompatinfo (computed from version 3.20.6)
+# phpcompatinfo (computed from version 3.20.11)
Requires: php-date
Requires: php-filter
Requires: php-hash
@@ -237,21 +237,19 @@ rm -f \
export AWS_ACCESS_KEY_ID=foo
export AWS_SECRET_ACCESS_KEY=bar
-run=0
-ret=0
-if which php56; then
- php56 %{_bindir}/phpunit -d memory_limit=1G --testsuite=unit --bootstrap bootstrap.php || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit -d memory_limit=1G --testsuite=unit --bootstrap bootstrap.php || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
+: Upstream tests
%{_bindir}/phpunit -d memory_limit=1G --verbose --testsuite=unit \
--bootstrap bootstrap.php
-fi
-exit $ret
+
+: Upstream tests with SCLs if available
+SCL_RETURN_CODE=0
+for SCL in php56 php70 php71; do
+ if which $SCL; then
+ $SCL %{_bindir}/phpunit -d memory_limit=1G --verbose --testsuite=unit \
+ --bootstrap bootstrap.php || SCL_RETURN_CODE=1
+ fi
+done
+exit $SCL_RETURN_CODE
%else
: Tests skipped
%endif
@@ -273,6 +271,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Dec 26 2016 Shawn Iwinski <shawn@iwin.ski> - 3.20.11-1
+- Updated to 3.20.11 (RHBZ #1405254)
+- Run upstream tests with SCLs if they are available
+
* Fri Dec 23 2016 Remi Collet <remi@remirepo.net> - 3.20.11-1
- update to 3.20.11